Installation / Removal > Rockbox Utility

Iaudio m3 killed!! Help please!!


Helo ,
Today I tested the rockbox at my 20GB Iaudio m3. Anything goes wrong. Now the computer couldn´t indentify my player. If I put it on it at the m3 screen is just the start-picture. Only If I disconnect the player from the computer and push the reset button I can turn it off.
If I don´t connect the player to the computer and turn it on it shows:

„Rockbox Bootloader
Version 1
Batt: 4,04 V
Loading Firmware
Result: File not Foun~
Can´t load rockbox.ia~

…and then it turns itself off.
(~ stands for a missing alphabetic character- it´s over the screen edge.)

Please help me. - Thanx for all your ideas :-\
Regards Rolf
 !! :-\

This sounds like you haven't installed the actual firmware yet but one thing that still should work is the Cowon loader which gets run if you just connect USB while the player is off (no Rockbox code is run at this point). So:

- turn the player off
- connect USB
- player should show the original firmware's "connected" screen and should be seen by your PC
- put the Rockbox build on your player (from the "Installation" tab chose "Install Rockbox")

Maybe you could also try to check the disk for filesystem errors and if you want to controll if Rockbox is now correctly on the M3 - there should be a .rockbox folder in the root of your player (could be hidden on e.g. MacOS).

There is also a little trick you need to get it charging. It's already mentioned in some post but since it's not documented otherwise, here it is one more: connect the player to USB first (from "off" too, I believe), then plug the charger, then you can disconnect USB again and the M3 should charge as normal.

Thanks a lot pixelma,

I tried your proposals with following effects:

-If I turn the player on and connect it to USB only the start-screen appears. And then - if the USB is still connected - I can´t turn off the player, even if I push the reset-button - on pushing the button the display turn of and if I release the button the same start-screen appears.

I can´t look in no case into the m3 because Vista or even more Linux doesn´t accept the m3 as a player or a harddisk - just vista recognice a USB-massstorage but with a yellow exclamation mark in the devicemanager. And so there is no other harddrive at my filebrowser like before.

May be my failing at - or after - the rockbox installation was the deletion of the whole harddisk, because I thought the firmware was loading in a chip after installation and so I formatted the harddisk...
Are the any hot-keys or something like that to restore the m3 to life or may be is there a software to enforce vista to appears the harddisk of my m3 ?
I hope so at least...


--- Quote from: Romeo on July 08, 2009, 06:21:31 PM ----If I turn the player on and connect it to USB (...)
--- End quote ---
You should connect it to USB while the player is turned off. The M3 should then automatically boot into the Cowon loader USB mode - this works on my M5 and I've been told by the developer who did the M3 port that it also always worked for him on the M3.

I meant if I turn the player "off" and connect it to USB just the start-screen-picture appears.
Usually it shows the loading progress, but it isn´t shown - just the start-screen picture. :'(
and it just goes so far and not further...

UPDATE:    S O L V E D !!!!!!   ;D

For everybody who have a nearly analog problem than me,
here a - may be dangerous - but working last alternative:

Open the player - remove harddisk - start again without hdd and connect the player at USB - than connect the hdd with the player (be careful - every pin should docking at the same moment) - and wonder - The PC will detect a new hdd!!
Now you can put the original or rockbox files at the hdd and screw the player together.
 ;) :D


[0] Message Index

Go to full version