Installation / Removal > Rockbox Utility

Problem with Ipod video 30GB

(1/2) > >>

I have installed rockbox using Rockbox Utility for Linux. Also i've tried manual install with the same result.
After restarting Ipod i see this:

--- Quote ---Rockbox boot loader
Version: 3.0
IPOD version: 0x000B0011
Partition 1: 0x0B: 7010 MB
Loading Rockbox...
Can't load rockbox.ipod:
File not found
Hold ...
then ...
--- End quote ---
Directory .rockbox is in its place.
It's strange that rockbox boot loader detects partition size as 7GB. Actually its size is near 30GB.

It looks like the filesystem may be screwed up somehow. Have you tried running fsck.vfat on your iPod to check its filesystem?

yes I run fsck.vfat on filesystem and made sure it's clean.
I can add, that some programs (like parted) do not support logical sector size (LSS) of 2048, and only support LSS of 512.
My Ipod's fat32 partition is formatted with LSS of 2048, because mkfs.vfat sad that this hardware does not support other LSS.
I do not know exactly that problem is in logical sector size. Because other users with Ipod video 30GB have everything alright with rockbox, no? It's interesting if their partition size was detected right and what logical sector size their partition have.

The more important (and should've asked earlier) question: Do you have a 5G or 5.5G iPod? You can check by the model number (and a little Googling).

Obviously he does, since the bootloader works. says mkfs.vfat isn't good to do on disks over 30GB.  I realise yours is 30GB, but maybe you should try mtools instead anyway.


[0] Message Index

[#] Next page

Go to full version