Installation / Removal > Cowon - Installation/Removal

BAD CHECKSUM error during boot


Hey there,

I have trying to get the 3.0 built of Rockbox running on my iAudio X5L 30GB. I have tried both the manual instruction and the utility, using the stable built. I have carefully read the steps required before installation. In all attempts and all cases, the following message appears during boot:
Sum: 20FA####
Can't load rockbox.iaudio:

What is displayed on the positions of the #### varies. Does anyone have an idea what this message means, and what I can do to fix it?!


Sounds to me like you either extracted the wrong iAudio build, or the rockbox.iaudio file didn't extract properly from the archive.

How did you install Rockbox? Manually or with Rockbox Utility?

Thanks for your reply.

I tried both ways. Equal result.

The last time I chose to install via the utility and marked that I'd like it to NOT use a cached version, in other words, download a fresh one. Should be the proper one I reckon.

In addition to my initial post, I found that using the original firmware (2.10e) results in scribbling sounds in any audio file (mp3 - vbr + cbr, wav, ...) as if decoding has errors, presumably while buffering from HD to flash (always at the start of playing or skipping, sometime during play).

Does this clarify?

The sum shouldn't change if you're downloading the same build each time. You might try running a disk check of some sort to make sure your disk is okay.


[0] Message Index

Go to full version