Third Party > Unsupported Builds

H320/340 Car compatible custom bootloader build. (Update: Added cradle support)

<< < (6/7) > >>

Glad to have helped.  That link should remain, didn't use crappy rapidshare this time...

So - I get that error every time I start up if the player has been off for more than a few minutes. If it's only been powered down for a short time, the wake-on-power works fine. I'll look deeper into this when I have more time to spend on it :-)

I realise this is a bit of a thread mine, but will try my luck anyway as it's the most relevant thread.

I did a similar mod to this firmware a while back, to get the H340 to direct boot and restart playback when the ignition was turned on in my car (i'd connected an appropriately wired charger to the DC input of the H300).  It's worked well for approx 10 years.

I recently got a new head unit with USB functionality, and would like the H300 to start up, charge and present itself as a USB disk when power is applied.

* With the stock firmware, the device starts charging and requires you to hit Play to get it to boot and present as a drive.
* With a v5 rockbox bootloader, the device boots straight into USB bootloader mode, which does not charge.

* With the firmware in this thread, the device boots into Rockbox *but does not charge*.  The charge indicators do not appear unless you unplug and replug the USB cable.  I am using Rockbox 3.12.  USB Charge setting has been tried on Enabled and Forced.

* With the SVN firmware the device is semi-bricked on a white screen.  To recover it, I hard-reset the device with HOLD enabled and a DC charger plugged in (this was found via trial and error in a desperate attempt to bring it back to life).

Any ideas on the best way to achieve my desired outcome?  I think this firmware is close, but need the rockbox build to correctly enable the charge function on bootup.  Alternately I could try to hack the USB charge function into the bootloader, but as the svn bootloader is busted this wont work.


Long story short;

I found this post -- -- The previous known ok bootloader: 19309.  To check out this revision using git,

git reset --hard 815998c6693998b7d7a3a523058ff0988e735d27

I then edited the bootloader to call usb_charging_enable(true); right before the USB bootloader loop; this allows the device to charge successfully! 

Calling it before handing off to Rockbox did not resolve bullet point three above; Rockbox must be resetting the GPIO pins, causing the charge mode to disable if USB is inserted when Rockbox boots.  Bug?


PPS:  If you brick your player with a bad SVN firmware, this trick worked for me to get back into the stock firmware.

Plug DC input into player, boot player to hang, enable hold, then hit reset button. 


[0] Message Index

[#] Next page

[*] Previous page

Go to full version