Third Party > Unsupported Builds

H320/340 Car compatible custom bootloader build. (Update: Added cradle support)

<< < (3/7) > >>


I tried to replicate the bug that you presented, but I was not able to.  My bootloader does not freeze at the voltage.  What exact model of H3xx series do you have?  If more people could test this, we could narrow down the root cause.  But you seem to be the only other user to try this bootloader build, so I'm not sure the exact cause.

I use the H340 (with a 60GB hitachi drive)

I'm using a H340 with original Toshiba drive.  Soon to be replacing the Battery since it doesn't hold very much charge.  I have changed the battery before but the new one ballooned and I had to put the original back in.  Maybe the HDD isn't quite back in properly.

I can tell you, that the hard drive does spin up when it freezes at the voltage.  From there it keeps spinning and does nothing.  I've gone back to the original rockbox bootloader and it all work fine though  ???

I also was unable to use the USB bootloader mode (with holding A-B) with your bootloader.  Maybe it's all related somehow.

Well, ViperKnight, this totally happened to me yesterday while driving to a concert.  It would lock up at the voltage reporting.  I have no idea if the harddrive spun up though, as I was in a car.  After the concert, however, it started up perfectly fine.  I had no charger or USB cable to try and 'unfreeze' it.  When I tried booting into the original firmware, it started fine, but duing the original firmware's boot sequence, it stopped and said "CHECK HDD CONNECTION" on the bottom, which I don't know what could cause that.  The ATA init is after the original firmware part of rockbox's bootloader, but I'm not an expert in this.  This is what leads me to believe it may be in rockbox's shutdown, but not sure...

I'm not exactly sure if it will enter "USB Bootloader" when it freezes where  it is (the voltage prompt), as the bootloader itself appears to be freezing.  There must be something being done to the harddrive on shutdown that may cause this, but no idea...  If I had a debugger, I could easily find the cause of this.  I will continue testing, but I can't get it to happen every time, and it's only happened once.

Hmm....I've never got the "Check HDD" error ???

All that I can say to help is that the issue is somewhere between the voltage check and the shortcut to boot the original firmware.  No matter the freeze I could always boot the original firmware.  Just not rockbox. 

I'll have a crack at looking at the code, although I'm relatively new to C (have done other languages), to see if there's anything I can spot.

Updated patch to re-include "Bootloader Charging" mode.  Now, when booting with a power cord in and holding the Mode (A-B) button, it will enter "Bootloader Charging".


[0] Message Index

[#] Next page

[*] Previous page

Go to full version