Rockbox Development > New Ports

Creative ZEN

<< < (44/44)

I have installed Windows 10 creator update 1703 using the windows 10 update agent. It seems that Microsoft has sorted out the MTP issue because my nexus 6 phone was eventually recognised. Before that even Nexus 6 did not show up as mass storage device when choosing connecting using MTP mode.

I got an error while trying to upload the bootloader from linux:
$ ./sendfirm64 firmware_zen_lcd.nk
libmtp version: 1.1.3

Device 0 (VID=041e and PID=4157) is a Creative ZEN.
error returned by libusb_claim_interface() = -6LIBMTP PANIC: Unable to initialize device
No devices.

even though I could see the drive mounted and accessible.
I then tried it from windows and it worked.
However when the ZEN is turned off or on there is a very loud pop in the headphones that wasn't there with the original firmware. Is there anything in settings that could help?

Also I noticed the blue switch led only lights up briefly during startup, but then it goes dark even when the device is on.
Also the datetime setting doesn't survive restart (other settings do)


--- Quote from: RufusLoacker on March 04, 2017, 03:26:05 AM ---
--- Quote from: pamaury on March 03, 2017, 01:50:55 PM ---
--- Quote from: ch3mn3y on March 03, 2017, 01:47:44 PM ---I seem to not be able to flash any nk file. When sending firmware_zen_lcd.nk there is Error occured during sending!, and when trying to install older firmware_zen.nk, there is Error while opening firmware_zen.nk! + Error occured during sending!

I'm doing it on Win8.1, but I have done it before on the same machine, so not sure what's wrong?

--- End quote ---

Maybe you forgot to erase the previous firmware ? As explained in, you need to power off the device, press the play button and power on (keep holding). You get the recovery menu, select "Reload firmware", then send the file.

--- End quote ---

I'm having the same problem, and even the Creative firmware loader doesn't recognize the device as connected. TRied multiple combinations of erasing firmware/plugging it in, different usb ports...
I'm on Windows 10

 I fear I may have bricked it lol

--- End quote ---

Im having much the same issue i believe mine is stuck in some sort of error state and there is no screen and not recognized by USB i can't reset format or send the firmware, this happened right when i tried to run doom on it screen went black and i waited for awhile then i tried to reset and now its not responding to anything "bricked" if anyone has any suggestions i would very much appreciate it (thank you)

you will likely have to wait till it runs down or disconnect the battery

I have several doubts with this model of Creative ZEN and other questions, for example any MP4 player or Creative media player that integrated FM radio with RDS?
The Creative ZEN dont have RDS.And is compatible with the games?

Please, answer me in this new thread ;):,54540.0.html


[0] Message Index

[*] Previous page

Go to full version