Installation / Removal > Apple - Installation/Removal

no .rockbox directory error (rockbox loads however)

<< < (6/6)

zajacattack:
The sure way to tell: can you play videos in the OF normally? Without any sort of patching?

plainkeyman:
greetings, i was attempting to install this and resulted in the EXACT same situation as ground_sniper.  although, my ipod is the 80gig model (5.5).

i'm using version: r17138

i'm trying to install from mac osx.  i happen to have a linux machine avail.  here is my partition table information:


# fdisk -l /dev/sdd
Note: sector size is 2048 (not 512)

Disk /dev/sdd: 80.0 GB, 80026359808 bytes
255 heads, 63 sectors/track, 2432 cylinders
Units = cylinders of 16065 * 2048 = 32901120 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1               1           4      128394    0  Empty
/dev/sdd2               5        2432    78011640    b  W95 FAT32


i did NOT use windows to partition this, i used the boot record from this url:
http://download.rockbox.org/bootloader/ipod/mbr-video80gb-2048.bin

# md5sum  mbr-video80gb-2048.bin
80ac20fd058625961a22303fd306fb07  mbr-video80gb-2048.bin



after this, i proceeded to use the disk utility to format the partition.  i copied the .rockbox directory, and used ipodpatcher successfully.  same results.


i suspect the partition table or how the firmware reads the partition is the culprit.  can anyone verify that this mbr files does work and this version (r17138) works ok?

also.. i tried using mtools instead of disk utility... but got this:


$ sudo mformat -t 2428 -h 255 -s 63 -S 2048 -M 2048 -F a:
argssize must be less than 6
Mtools version 3.9.11, dated May 31st, 2007
Usage: mformat [-V] [-t tracks] [-h heads] [-n sectors] [-v label] [-1] [-4] [-8] [-f size] [-N serialnumber] [-k] [-B bootsector] [-r root_dir_len] [-L fat_len] [-F] [-I fsVersion] [-C] [-c cluster_size] [-H hidden_sectors] [-S hardsectorsize] [-M softsectorsize] [-3] [-2 track0sectors] [-0 rate0] [-A rateany] [-a]device

stevenkelby:
Did you ever figure this out?

I used rockbox successfully for nearly a year, then I replaced my 5.5G 80GB video ipods battery ass about face and fried the mobo. I had a new mobo installed by Vinnie at RWA and it worked perfectly until I tried rockbox again.

First rockbox would play 10 - 20 seconds of a track then freeze and give an error message. It was a different message each time and I can't remember it now but it would be in the WPS and would appear in the top left corner saying something about Data Abort or missing files or something and a long error code (different number each time). Had to hard reboot, then it would work fine until I start playing a track, any track, mp3, flac etc, and it would have the same error with in maybe 5 to 30 seconds (different each time)

After trying to reinstall a few times here's where I'm at now.

Reformatted disk in FAT32

Reinstalled stock firmware from itunes. Itunes has always, and is now, working perfectly.

Installed bootloader and Current build from rockbox utility and have tried doing it manually too.

The rockbox finishes it's thing successfully, gives teh RB installed successfully message and I eject the ipod.

Now when it reboots I get this screen:

Rockbox boot loader
Version: 2.0
IPOD version: 0xFFFFFFFF
TOSHIBA MK8010GAH
Partition 1: 0x0B 76224 MB
Loading Rockbox...
Error!
Can't load rockbox.ipod:
File not found
Hold MENU+SELECT to reboot
then SELECT+PLAY for disk mode

I have reformatted and reinstalled with different versions of itunes and rockbox and from different PCs but get this same basic message.

Any ideas?

Many thanks.

Edit:


OK I just reformatted again and installed everything manually using the current build. Rockbox works again now, until I try to play a tune. Got about 10 seconds. Now the WPS is blank apart from the yellow "NOW PLAYING" bar at the top, a blank grey bar near the bottom and the RB, squiggle (random?) and repeat logos.

The top left says (looks like, it's over the yellow and hard to read):

Data abort at
C000007A  (0)

Edit:

Rebooted and changed theme to ipod catcher so I can read errors..

12 seconds playing before:

Prefetch abort
at CDCB5B2C  (0)


12 seconds:

Prefetch abort
at 722629D2  (0)

12 seconds:

Prefetch abort
at CDCB5B2C  (0)


12 seconds:

Prefetch abort
at CDCB5B2C  (0)


Changed theme to Rockboxed:

12 seconds:

Prefetch abort
at BDD2E89A  (0)




12 seconds:

Prefetch abort
at FB910088   (0)


And so forth.

Any ideas?

Thanks,

Steve.

Llorean:
Try using a 32mb build. It's possible your replaced motherboard isn't actually from an 80gb iPod.

stevenkelby:

--- Quote from: Llorean on April 18, 2008, 01:31:58 PM ---Try using a 32mb build. It's possible your replaced motherboard isn't actually from an 80gb iPod.

--- End quote ---

It worked perfect, thank you!

I installed the current build for the 30GB ipod video and now it al works perfectly.

I never would have thought to try that, if you need any top end cables made cheap, let me know ;)

Navigation

[0] Message Index

[*] Previous page

Go to full version