Rockbox Technical Forums

Installation / Removal => Manual Installation => Cowon - Installation/Removal => Topic started by: newbeewan on September 02, 2006, 09:16:06 AM

Title: No more playing file after usb unplugged
Post by: newbeewan on September 02, 2006, 09:16:06 AM
Hi,

After unpluging my X5 from usb, RB can't play music...
I need to restart my player every time !

Is somebody else's got the same pb ?

Thanks a lot
Title: Re: No more playing file after usb unplugged
Post by: xlarge on September 02, 2006, 04:31:00 PM
Nopes.

Restart your player every time what?

Maybe you didn't really install rb correctly?

have you flashed it but not extracted the zip containing .rockbox folder and rockbox.iaudio file?
Title: Re: No more playing file after usb unplugged
Post by: newbeewan on September 03, 2006, 03:51:31 AM

Restart your player every time what?

If I want to play some music after unplug my x5 from USB, I must shutdown-restart it...


Maybe you didn't really install rb correctly?

have you flashed it but not extracted the zip containing .rockbox folder and rockbox.iaudio file?


It is correctly installed, I'm using rockbox for 3 years (previously on archos recorder and now on x5)...
The bootloader is the test version of the doubleboot and associate to the OF with mkboot all  provided by RaeNye.
I'm running the dailybuild (060902).
Title: Re: No more playing file after usb unplugged
Post by: bluebrother on September 03, 2006, 08:49:43 AM
I have the same problem on h120. Also, there is a task on flyspray dealing with h300. So it actually seems to be a bug. But you can simply use rolo for reloading rockbox (rolo is working on x5, isn't it?) instead of a complete shutdown - restart.

But as you are running an experimental boot loader I'd suggest trying it with the official one.
Title: Re: No more playing file after usb unplugged
Post by: newbeewan on September 03, 2006, 09:02:40 AM

I have the same problem on h120. Also, there is a task on flyspray dealing with h300. So it actually seems to be a bug. But you can simply use rolo for reloading rockbox (rolo is working on x5, isn't it?) instead of a complete shutdown - restart.

Very good idea ! I haven't think about it before ;)...

I think also it is a bug in the usb support for coldfire cpu...

As far the official bootloader doesn't support dualboot, I prefer to deal with some expérimental one's which provide that feature :P...
Title: Re: No more playing file after usb unplugged
Post by: RaeNye on September 03, 2006, 01:56:51 PM
I do suggest you'd use the stable version of the dual bootloader (precompiled version available somewhere in the x5-dual-boot thread on hardware forum).

It ain't official, but my "stable" is better than my "quick hack, please test, hope it works".
Title: Re: No more playing file after usb unplugged
Post by: newbeewan on September 12, 2006, 01:19:55 AM
I upgrade the bootloader to your stable unofficial version, and no change, when I unplug my x5, it can't play music any more :(
As suggested by bluebrother, I do a "soft" restart of rb and it work again...

I think, if confirmed, it may be a bug...