Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: ianc911 on April 10, 2016, 07:46:55 PM

Title: 15 sec delay before shutdown with Cip +
Post by: ianc911 on April 10, 2016, 07:46:55 PM
Hi folks,

I've got a Clip + with RB 3.13 and it's working fine in all respects with the exception of one minor annoyance: I need to press and hold the power button down for about 15 - 20 seconds before it will actually shut down.

Not sure why this is. It's connected to a home stereo and is always plugged in to a USB charger, so it's constantly charging, and I believe it's this which is causing the problem. If I disconnect the USB charging cable, it will shut down in about 3 sec, but if I try to power it down while still charging, it takes much longer. I would prefer to just leave it plugged in to the charger to ensure the battery is fully charged, and avoid the repeated stress on the USB connection. It's pretty much a static installation.

I've searched a bit here and looked over the documentation, but can't really find anything specific. Anybody know what might be causing this? Car adapter mode is not enabled.

Thanks for any help,

Ian
Title: Re: 15 sec delay before shutdown with Cip +
Post by: saratoga on April 10, 2016, 08:23:12 PM
Should be fixed in the current build, try updating and see if it works as expected.
Title: Re: 15 sec delay before shutdown with Cip +
Post by: gomezz on April 11, 2016, 04:24:53 AM
I thought it staying alive when on USB power was normal?

Does not holding the Power button down for that long mean you are actually resetting it?
Title: Re: 15 sec delay before shutdown with Cip +
Post by: saratoga on April 11, 2016, 11:00:45 AM
It is normal, but we Mihail recently added the ability to power off while plugged in.  And yes, he is hard resetting his player, which is probably not a good idea. 
Title: Re: 15 sec delay before shutdown with Cip +
Post by: ianc911 on April 11, 2016, 03:02:40 PM
"And yes, he is hard resetting his player, which is probably not a good idea"

Hmmm... So how should I power down the player when it's plugged in then?

I've downloaded the latest dev build for the Clip +. Not sure what version it is; that info doesn't seem available, but I will probably go ahead and try to update it. Any URL that might contain instructions for the upgrade?

Thanks again for the help!

Ian
Title: Re: 15 sec delay before shutdown with Cip +
Post by: saratoga on April 11, 2016, 03:07:03 PM
There is a manual link on the left side of the forums interface. 

Previously you would have had to unplug the player to turn it off. 
Title: Re: 15 sec delay before shutdown with Cip +
Post by: ianc911 on April 11, 2016, 08:52:04 PM
OK, I updated to the Dev build and that cured the problem. Thanks for the tip!

ianc