Rockbox Technical Forums

Support and General Use => Theming and Appearance Customization => Topic started by: Poke on October 19, 2012, 11:14:10 AM

Title: [Solved] Sansa Clip+ - Modifying Standard Status Bar
Post by: Poke on October 19, 2012, 11:14:10 AM
hey guys and girls ;)

I would like to modify the standard status bar (rockbox_failsafe.sbs) so it fit my needs. But i didn't find the code to change it. Even looked in the source code and found only the default wps code which is hard coded in ./rockbox/apps/gui/wps.c . So if anyone could tell me where to find the code for the sbs or just push me to the right direction, I would be happy^^


Greetings from Germany (yes, this explains the bad English :D )
Thank you


Edit: Theme completed and ready to download ( http://themes.rockbox.org/index.php?themeid=1701&target=sansaclipplus )
Title: Re: Sansa Clip+ - Modifying Standard Status Bar
Post by: sockbox on October 19, 2012, 07:06:27 PM
Modify the classic_statusbar.sbs to suit your needs and then load that as your base skin under the theme options.
Title: Re: Sansa Clip+ - Modifying Standard Status Bar
Post by: Poke on October 20, 2012, 05:49:21 AM
Thanks for Reply,

but the classic_statusbar.sbs is not the same as the rockbox_failsafe.sbs. It looks different! Other symbols, no symbol for locking, no reaction to changes to the settings (for example the "Battery Display" is always graphic, even when i change it to numeric in the menu). It also shows to contain some graphic bugs ?

and i really wanted the other symbols :) (I'm making my own theme and I'm perfectionist ;D )

btw. The "Spell Check"-button lead me to "http://en.wikipedia.org/wiki/HTTP_404" ? Yesterday it worked well. Everything fine again.

Edit1: So I've been working on the classic_statusbar. Only problem is to show the lock symbol (I've made one by myself). It seems that the Section for the time is bigger then it should. So the symbol is only displayed half. I've attached a screenshot. There you can see, that only one line is displayed from the lock symbol. :(

Edit2: Ok, it's working now. Stupid alignment :D I think I'm gonna upload it. Would like to hear some feedback :)