Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: audiophilekasi on February 02, 2012, 02:18:10 PM

Title: H340 with MK1214GAH...not working. Going nuts.
Post by: audiophilekasi on February 02, 2012, 02:18:10 PM
Hello to everybody.

Firstly I want to thank you for all the useful hints I found already months ago without having registered, yet. Today I signed in and I truly need your help.

For weeks I studied all the threads here, evaluating which new harddisk would be easy to install, but with enough space for my FLAC-files. Finally I decided to go for a Toshiba MK1214GAH, which I considered as an easy to install solution.

Monday I received my new HDD and also the suitable adapter. After having exchanged the discs I was really curious, if it would work out well. I connected the H340 with my PC and Win7 easily recognized the new disc. Just another formating session and (I thought) I was ready to go. I rebooted my H340 and what happened? Exactly the same as in this thread here (http://forums.rockbox.org/index.php/topic,26853.0.html (http://forums.rockbox.org/index.php/topic,26853.0.html))...one could also say: nothing happened!

Now I'm really desperate and I'm going nuts. With the OEM (40GB) disc just everything works fine: I can listen to the music files, I can boot either RockBox or the original Firmware...and so on. And also with the 40gigs-drive I can easily do Firmware upgrades. After having removed the 40's drive and putting in the 120gb Toshiba nothing works. OK, Win7 recognizes the disc and I'm able to load files on this disc, but neither Rockbox starts (it gets stuck at the voltage information in the bootloader), nor ca I see any music files there then and even the firmware upgrade doesn't work with this disc. When trying to do an firmware upgrade nothing happens, the H340 just returns to ther 'General' menu.

I'm really really desperate...

Hope you guys may have a solution for me.

Many thx already in advance.

Regs,
Kasi

Post Merge: February 02, 2012, 03:27:12 PM
GOT IT....  ::)

In 99,99% of all technical issues, the problem is the idiot sitting in front of the screen. So in this case. Last days I always formatted the harddisc in the Win7 'exFAT' way. Now I downloaded a tool (HPUSBFW_v2.2.3) and formatted the drive as FAT 32 with all correct parameters. And now? It works perfectly - even the RockBox-installation and the Firmware Upgrade runs smoothly with the 120GB drive.

Everything's fine.  ;D

Regs,
Kasi
Title: Re: H340 with MK1214GAH...not working. Going nuts.
Post by: Chronon on February 02, 2012, 11:25:03 PM
Thanks for posting your solution. 
Title: Re: H340 with MK1214GAH...not working. Going nuts.
Post by: christopher on February 06, 2012, 11:43:24 AM
PEBKAC is always almost impossible to self-diagnose ;-) so congrats for figuring out the problem and posting the solution. (thanks also again for updating with the solution, neglected unanswered forum posts are right up there with junk mail and telemarketing calls for me! :D)
Title: Re: H340 with MK1214GAH...not working. Going nuts.
Post by: pirati on March 10, 2012, 06:35:14 AM
Now I downloaded a tool (HPUSBFW_v2.2.3) and formatted the drive as FAT 32 with all correct parameters.

Hi I seem to have the same problem you had, even when the drive was formated FAT 32.
Can you tell me what the other parameters are I should consider when formating ?

Thx

Pieter