Rockbox Technical Forums

Installation / Removal => Manual Installation => Sandisk - Installation/Removal => Topic started by: crazyeric on June 04, 2009, 10:29:44 PM

Title: yet another no sansa detected
Post by: crazyeric on June 04, 2009, 10:29:44 PM
i just got an e260 4g sansa and tried to flash rockbox onto it. Im running windows xp. i have a version 1 sansa bios version 01.02.18a and MSC usb mode. When i connect it to usb it shows up as E: under my computer but when i try and use rockbox utility it wont autodetect and when i select E: from the list and go to install it says "No Sansa Detected" I also tried manual installing it but the bootloader wont detect my sansa either. The only thing i can think of is the roxbox utility is looking for Sansa Sandisk E200 at E:\ but in my computer my sansa shows up at Sansa E260 (E:\) I seem to have some rockbox files on the device itself but when it boots up it just goes to the default UI. Can anyone tell me if im doing something wrong or what id really like to get rockbox working on this.
Title: Re: yet another no sansa detected
Post by: Chronon on June 04, 2009, 10:46:51 PM
The USB mode is labeled MSC in the SanDisk firmware?  (Just trying to make sure it's not a Rhapsody model.)
Title: Re: yet another no sansa detected
Post by: crazyeric on June 04, 2009, 11:13:39 PM
yeah when i go to settings its on msc mode
Title: Re: yet another no sansa detected
Post by: Llorean on June 05, 2009, 12:31:48 AM
First of, "sansapatcher" is not the bootloader. Please, try to make sure to use the same terms for things as we do, to keep things from getting confusing. Sansapatcher is sansapatcher. The bootloader is what it installs.

Does your device show up as two drives, or one?
Title: Re: yet another no sansa detected
Post by: bluebrother on June 05, 2009, 01:46:40 AM
Please post the output of the About / System Info dialog from Rockbox Utility.
Title: Re: yet another no sansa detected
Post by: crazyeric on June 05, 2009, 08:45:57 AM
OS
Windows version 5.1, build 2600 (Service Pack 2)

Username:
Eric

Permissions:
Admin

Attached USB devices:
VID: 04b8 PID: 0005, USB Printer
VID: 04fc PID: 0c25, USB to Serial-ATA bridge
VID: 06a3 PID: 8020, Saitek Eclipse Keyboard
VID: 0781 PID: 7421, Sansa e260

It shows up as 2 drives when i plug it in it shows the G drive also which only has the pmp_usb.cfg  file.
Title: Re: yet another no sansa detected
Post by: bluebrother on June 05, 2009, 02:39:14 PM
Hmm, everything looks fine here. Did you do any modifications to the firmware before? As in installing sansalinux or any other mods?
Title: Re: yet another no sansa detected
Post by: crazyeric on June 05, 2009, 06:28:09 PM
nope, took it out of the box, there were some preloaded songs and videos on it i deleted those and attempted to install rockbox. theres rockbox files on the player like fonts and themes and stuff but i cant get the boot loader to install.
Title: Re: yet another no sansa detected
Post by: crazyeric on June 08, 2009, 08:46:15 AM
is there any way to restore the sansa to factory settings so i can just start clean and maybe it'll work after that?
Title: Re: yet another no sansa detected
Post by: bluebrother on June 08, 2009, 01:09:34 PM
You can check this wiki site:
http://www.rockbox.org/wiki/SansaE200Unbrick

Beware that you can brick your Sansa by ignoring the warnings on that page. Maybe the sansa.fmt method helps you. I still don't get why it doesn't work.