Rockbox Technical Forums

Installation / Removal => Manual Installation => Toshiba - Installation/Removal => Topic started by: Christine Tham on April 15, 2007, 10:25:20 PM

Title: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Christine Tham on April 15, 2007, 10:25:20 PM
I am lucky (???) enough to own two Gigabeats - X60 and F40 - and have Rockbox running on both of them (why two? well, I have so much music I need about 100GB to fit them - and I haven't even ripped my entire CD collection!)

I've noticed that recent builds no longer work on my X60 - the player boots up, then turns blank. Rockbox still seems to be working, as I can just see the Rockbox menu on the screen, but the LCD backlight is off and there doesn't seem to be an easy way to re-enable the backlight. Also, after a few seconds, even the faintly readable screen disappears and become completely blank.

I have tried turning the battery switch off, waiting a minute, then on again. I have also tried reinstalling into a fresh .rockbox directory.

The only way to make the screen work again is revert to an earlier build (I have downloaded one around 28 March that seems to work)

On the other hand, my F40 continues to work fine on the new build, and there's no problems with the LCD backlight.

I am wondering if the recent changes to the ATA and USB initialization and cold start detection "broke" the LCD display code on the X60 but not the F40.

Is it possible for someone else with an X-series Gigabeat to confirm?
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 15, 2007, 10:27:51 PM
It's confirmed. It's not 100% definite those changes caused it, but they're by far the most likely.

But I have to let you know:
1) You put this in the wrong forum. The POSTING IN THIS FORUM post makes it exceptionally clear when you should or shouldn't post in this area.
2) Bug reports don't belong in a forum anyway if you want to do more than just discuss "hey I have this problem" and instead want to actually report it.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Christine Tham on April 15, 2007, 10:33:42 PM
Thanks - I wasn't *completely* sure it was a bug, hence the post here (it is *kinda* an "installation" issue)

Hope the bug gets fixed soon. Till then, I'll live with running the March 28 build.

Is the LCD hardware exactly the same between an F40 and X60? I noticed that my X60 is significantly brighter (even on the same LCD brightness settings) than my F40, and the colours appear more accurate (for example, white looks white rather than slightly yellowish).

Also, Toshiba Australia seems to advertise the X60 as having an "OLED" screen? Is the F40 an OLED screen as well, or just normal LCD?
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 15, 2007, 11:14:10 PM
It is not "kinda" an installation issue. The POSTING IN THIS FORUM post says explicitly that once you've been able to boot Rockbox, the questions belong somewhere else.

How much clearer does it need to be for the remaining doubt to be resolved? If there's some ambiguity that I can clear up, I'd be happy to rewrite the post for more clarity.

They have completely different screens, you may notice that the X series has a larger screen than the normal one. I also notice that you are using an unsupported build. Please do not report problems if you're using an unsupported build except in the thread for that build.

Even though this problem happens to happen in the main build too, that is often not the case, and people will waste time trying to confirm a problem that doesn't exist.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Christine Tham on April 15, 2007, 11:55:29 PM
Llorean, I don't mean to argue with with you, but I wouldn't really regard booting into a blank screen to be a "successful boot". As it stands, it would seem to me anyone who tries to install Rockbox onto an X series currently would get the same issue, no? In other words, a unit that is not operable in a fundamental sense even though the installation instructions were followed precisely and correctly?

I would understand your objection if the problem is something that doesn't affect the player startup or fundamental usability (ie. a problem with mpegplayer not working). Maybe I am confused by your one line guideline post after all, in which case perhaps you should make it clearer.

Anyway, peace. My apologies for not understanding your posting guidelines, and please take my post for what it's intended to be: an attempt to confirm whether or not a problem exists and whether it is related to installation procedures.

Also, let me make it clear - although I like using unsupported builds, my post in this forum pertained to using the main build. If it was a problem with an unsupported build but not present in the main build, I would have emailed the builder directly. At least try and give me credit for verifying that the issue existed in the main build prior to posting.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 16, 2007, 12:07:41 AM
The point is, you're IN Rockbox, and you know that you're in Rockbox. You aren't having problems "Installing" it, you are having problems Running it after the install. You even said you could see the Rockbox interface faintly, and knew that the only apparent problem was the backlight.

You knew the install was fine, because you ran Rockbox prior to this bug being introduced. Your question has nothing to do with the install process.

If Rockbox crashes immediately after boot, it's not an install question. If the screen looks wrong after boot, it's not an install question. Because you've done the install, and now you're booting Rockbox, and Rockbox is failing, not the installation.

How can I make this clear in the post: I wrote the rule, this is the intent of the rule. I understand you think the rule isn't clear enough, so please tell me how to word it so that it may be clearer.

And the only reason I assumed that you hadn't tested in an official build was because it was clear that you weren't familiar with how rules go in these forums (I've made the "Installation" issue as clear as I can without someone telling me how to improve it).

Just to clarify, I'm not upset with you, I'm honestly trying to make it clear and honestly interested in how I can make the rule more clear.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Christine Tham on April 16, 2007, 12:24:32 AM
Well, I would suggest you make the guideline explicit, ie.:

"This forum is only for those who have problems *initially* installing Rockbox. If you have managed to successfully install Rockbox previously, but are having problems with the current build (even to the extent that it no longer boots), please post in XXX forum."

As for my question having nothing to do with the install process, well, I *didn't* really know that when I posted, did I? For all I know, something subtle has changed (or needs to change) in the installation process for recent builds that hasn't made it to the installation instructions, hence my post.

For example, I notice you didn't pounce on movhoven even though he was asking a very similar question, in a very similar style, and context was also similar (previous build worked, current build does not). The only difference is: you *think* you know what the answer to my problem is, but you're not so sure in his case. If that is how you operate, you may perhaps include in the guideline ("Valid posts in this forum may depend on whether the administrator recognises the problem being described as being pertinent to installation or not") :-)

Finally, a suggestion: given that this forum is for newcomers - might be worthwhile putting in an announcement along the lines of "Warning: The current build of Rockbox does not work on the X series at the moment - please refrain from installing until we fix the problem". That could save a lot of potential frustration. You can always remove the announcement once the problem is fixed.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 16, 2007, 12:29:30 AM
Sometimes I tell someone it's in the wrong place at the beginning of a thread, sometimes at the end, sometimes I close the thread and tell them "You've broken guidelines, figure out how yourself by reading the rules."

You'll notice I still helped you with the problem, if you have a problem with *when* I told you, that's fine, but just because I haven't told him yet does not mean I have no intent to.  But his problem explicitly had to do with the bootloader, which is part of the installation process. Your problem occurred after an UPGRADE, not a bootloader installation. To get technical, this section is for questions prior to the bootloader loading the rockbox.gigabeat file.

As well, the initial post explicitly says "Once you have booted Rockbox successfully," which doesn't mean "As long as you can boot Rockbox successfully." You yourself said "Rockbox seems to be working." and showed NO expressed curiosity or suggestion that it had anything to do with the install process. As well, being the "Getting Started" section should give a significant clue. I've updated the POSTING IN THIS FORUM to be a little more clear.

As well, people aren't going to read this forum before installing, so posting it here does no good. If they follow the rules, they'll check the bug reports before bringing it up here, and thus know that it has been reported for the Xs. There's no way to effectively tell people not to update.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Christine Tham on April 16, 2007, 12:45:51 AM
Don't mean to contradict you, but in my original post I stated: "I have tried turning the battery switch off, waiting a minute, then on again. I have also tried reinstalling into a fresh .rockbox directory."

I would have thought that was "evidence" enough that I was actively considering the possibility that somehow I was installing the build incorrectly, hence the reason for me posting here. I also did try installing a new bootloader, and my next question if the problem wasn't confirmed would probably have been "What am I doing wrong? Have something changed?"

At least try and acknowledge that my intent was to comply with your posting guidelines.

As for the announcement, I wasn't necessarily referring to this forum - it could just as easily appear on the main web page. But it would be useful in this forum since if I am a newcomer and having difficulty installing Rockbox on an X series, this would be one of the first forums I will go to.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 16, 2007, 12:51:10 AM
Rockbox hasn't been "released" for the Gigabeat X or F. Sound works on it, but no version should ever be considered stable.

I will definitely acknowledge that you had the intent for it to be in the right place. I'm not assuming you're lying to me. I was merely stating that the intent was not clear to me in your first post, and that I would like to make it clearer in regard to what should be here.

Turning the battery on and off didn't seem "installation" related, and clearing your .rockbox directory didn't really signal to me an installation: many people do that regularly on upgrading (for no apparent reason to me).

I really didn't intend to spark an argument, but being the "Getting Started" section, this really is supposed to be about first-time installs, and it seemed fairly clearly to me from your post that you knew Rockbox was starting and that Rockbox itself was where the problem was.

As it is, I don't have control over the front page of the site, but being as Rockbox hasn't been released on the Gigabeat (there is no Version-numbered edition for it) everyone should consider themselves testers.

This means they should expect problems occasionally.

Is there a reason why posting here in the forums would be better than simply having the bug up on the bug tracker, other than "people won't follow the rules and check the bug tracker before asking about it?" (And by the way, I'm not suggesting you didn't, I know perfectly well it wasn't on the bug tracker yet.)
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Christine Tham on April 16, 2007, 01:10:02 AM
Thanks for the acknowledgement. I was half afraid you were going to close the thread, and then ban me from further postings ...

As for why some people (eg. me) like to post before reporting a bug, personally I hate people who post bugs that are not really bugs, and I didn't want to be one of them just in case my problem was an installation error :-) And yes, I did check the bug tracker prior to posting ... If you want, I can create an entry in the bug tracker, but since you are already aware of the problem ...

The only reason I suggested the announcement was: you mentioned you didn't want people to waste time ... It occured to me that RIGHT NOW would be a very inconvenient time for someone to buy an X60 and attempt to install rockbox :-(

I think most people do realise rockbox is under development. That's why I tend to read forums like this BEFORE I install - to understand what potential problems may exist and to avoid common mistakes. Maybe I'm unusual in that regard.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 16, 2007, 01:22:35 AM
Trust me,  few enough people read any documentation (including the full installation instructions, you might be surprised to hear that the most common install question I get is answered by "read section 2.2.2, titled 'Installing the Firmware' instead of just the 'Installing the Bootloader' section").

If I put it here in the forums as a sticky, odds are that it will help maybe one or two people. If people actually use search, this thread (and the bug report that's in the tracker) will help people, assuming they search the tracker or here.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Christine Tham on April 16, 2007, 01:37:44 AM
LOL, been there, nearly did that (and I'm normally pretty anal about reading instructions).

May be worthwhile inserting in the bootloader install section bold flashing  text that says "Please do not disconnect and reboot your Gigabeat after this step - this is NOT the end of the install process" :-)
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 16, 2007, 01:39:46 AM
The bootloader section is after the firmware install section though. If they get to the end of the bootloader section, it *should* be the end, they just have a bad habit of skipping the prior section. :)
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Christine Tham on April 16, 2007, 01:56:05 AM
Thanks - that probably helps. I don't think the instructions were as clear (or in that order) when I installed in late Dec 06. Maybe people just like jumping to the end, figuring all the early sections must be preamble :-)
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Ivanator on April 16, 2007, 02:38:22 AM
Just to add a bit for info, the latest working build for the X series is the 2007-04-11 daily build. Hope this helps people.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: kkurbjun on April 16, 2007, 07:32:08 PM
Could someone confirm for me whether you are able to access USB with the newer builds?  For example when you upload one of the latest builds and the screen is off can you still plug usb in and connect to the player?
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: kkurbjun on April 16, 2007, 07:53:02 PM
Also, if someone is available to try and work out this problem could they PM me so that I can verify if a patch will fix the problems you are running into?
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Ivanator on April 17, 2007, 12:40:14 AM
Yes, I still have USB access. In fact, that is how I reverted back to a working build. The rescue mode freezes while being loaded, so I can't actually go down that route. I'm not sure if these two are related problems.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: scubacoles on April 20, 2007, 07:45:49 PM
kkurbjun has successfully corrected the error and everything appears to be stable on my X30.
Keep your eye out for his commits to SVN and then grab a bleeding edge build...and the required new bootloader to go with it. Everything should run successfully.
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Ivanator on April 21, 2007, 02:07:59 AM
I can confirm that the latest build and bootloader works on my X60.

Thanks and good work guys!
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Gigabeat_Luv3R on April 21, 2007, 04:52:47 AM
okay i have a question about the new bootloader that you have tested and reported back that it works. when i used to download the bootloader it used to download a file but now when i try and download the 21st of april bootloader it takes me to a webiste with a bunch of weird writting on in.
Am i supposed to save that page and rename it to FWIMG01.DAT? if not what do i do with it
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 21, 2007, 04:56:35 AM
Are you downloading the bootloader from download.rockbox.org? If so, just right click on the file link and choose Save As
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Gigabeat_Luv3R on April 21, 2007, 05:01:29 AM
i am getting the bootloader from here:

http://www.rockbox.org/twiki/bin/view/Main/GigabeatFXPort#Installation_Instructions

and the bootloader link is:

http://www.rockbox.org/twiki/bin/viewfile/Main/GigabeatFXPort?rev=4;filename=FWIMG01.DAT

So just to confirm, i right click on the bootloader link and press 'save as'
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: Llorean on April 21, 2007, 05:02:57 AM
You need to get the bootloader from download.rockbox.org
Title: Re: Help - recent builds disables LCD backlight on Gigabeat X60
Post by: linuxstb on April 21, 2007, 05:09:08 AM
For a few hours this morning, the new bootloader was only available on the wiki, and not on download.rockbox.org, but now everything is as it should be - the version on download.rockbox.org is now the most up to date.