Rockbox Technical Forums

Installation / Removal => Manual Installation => Toshiba - Installation/Removal => Topic started by: Proxima on April 06, 2007, 08:27:01 PM

Title: First Installation: -2 error
Post by: Proxima on April 06, 2007, 08:27:01 PM
    Hello. I am new to rockbox and after spending some time looking over installation instructions and this area of the forums I naively figured I was just capable of installing it. Now when I start my f10 I get the normal gigabeat loading screen until the load bar reaches the end. After that, for a split second what appears to be the intended rockbox startup screen is displayed, and after that a blue screen with the text at the top giving me the -2 error. I went back over the instructions and can't seem to find what I did wrong.
     
     
      If anyone can point me to the right direction I would appreciate it GREATLY. I'm hoping you guys know what the -2 error probably means so you don't have to do the whole detective thing in order to help a newbie.
Many thanks in advance.
                                  -Newbie who now knows he is a newbie

P.S. One thing that may have to do with the problem: I noticed that the wiki instructions never told me to install the bootsplash bmp file (just the .raw file) while the manual doesn't seem to mention either of the bootsplash files...just wondering.
Title: Re: First Installation: -2 error
Post by: RotAtoR on April 06, 2007, 08:54:19 PM
It sounds like you're probably not using the latest bootloader. Are you using FWIMG01.dat from here? http://download.rockbox.org/bootloader/gigabeat/ As for the bootsplash, it's completely unnecessary, Rockbox works fine (and probably boots faster) without it.
Title: Re: First Installation: -2 error
Post by: Proxima on April 07, 2007, 04:30:04 PM
Hey man thanks a million that was it exactly.
Now all I have to do is figure out how to play music on it now  :P as the database doesn't seem to want to go past one number.