Rockbox Technical Forums

Installation / Removal => Manual Installation => Iriver - Installation/Removal/Flashing => Topic started by: user on March 10, 2007, 09:25:45 PM

Title: failed! result: -3
Post by: user on March 10, 2007, 09:25:45 PM
H120 (with 30GB HDD)
With the latest build (11 Mar 01:09),
If I boot from ROM, I get this "failed! result: -3" message at start
If I boot from HDD, I do not get that message

In both cases, text scrolling happens in a offset manner, i.e. scrolling text occurs a couple of pixels above the actual selected item.

These symptoms do not disappear until I roll back to March 9th's daily build, which is what I will be using until this is fixed :(

p.s.
completely unrelated but does anyone know where I can get a not-broken "shell" for h120? Mine's extremely beat up and I have no idea how long this thing will be able to hold itself together :(
Title: Re: failed! result: -3
Post by: CSMR on March 23, 2007, 10:13:51 AM
I also get this error sometimes. This is booting from ROM. Sometimes it's there, sometimes not.
When it's there there I think is more hard drive access on loading (directory cacheing?); only happened a few times (updated everything yesterday) and can't tell for sure.
Doesn't seem to cause any real problems for me. I'd be curious to know what it is.

(This is with an H140.)
Title: Re: failed! result: -3
Post by: user on April 01, 2007, 09:50:38 PM
unfortunately, this seems to happen (though only sometimes) loading from hdd also
Title: Re: failed! result: -3
Post by: CSMR on April 13, 2007, 08:21:31 AM
For me it only happened a few times over a couple of days. No problems now. Don't know what has changed.