Rockbox Technical Forums

Installation / Removal => Manual Installation => Apple - Installation/Removal => Topic started by: greggdecker on January 16, 2007, 06:50:33 PM

Title: Help with my Ipod 60G Video
Post by: greggdecker on January 16, 2007, 06:50:33 PM
I have tried twice to install Rockbox into my Ipod Video.  Both times I had to un-install Rockbox
to get the Ipod to work.  Luckily I had no problem un-installing Rockbox.

I get a quick flash of the Rockbox Logo then it immediately changes to a USB plug image.
After this it says safe to Disconnect and hangs..  The fonts have changed and there are no reoported errors. My Ipod is a 60 Gig Video purchased about a year ago.

Any ideas or suggestions.  I mainly want to be able to use the FLAC codec.

Thanks

Gregg

When you know that you know that you will never know, then you will really know.
Title: Re: Help with my Ipod 60G Video
Post by: Febs on January 16, 2007, 06:56:37 PM
Press and hold Menu + Select until you see the Apple logo.  Describe exactly what happens.
Title: Re: Help with my Ipod 60G Video
Post by: greggdecker on January 16, 2007, 08:16:07 PM
Thanks fir the reply.
What I described is exactly what happens after I see
the Apple logo.  A small screen comes up that is
from the Rockbox install, after that I get a quick
image of the Rockbox logo then it reads (in a smaller font)
than the Apple usses a safe to disconnect.
I hangs here.  I can see the Ipod on in FIle-manager but
cannot access anything via the Ipod unit.  I hope all this
makes sense to you.  I tried resetting it a few times and it
does reset but it ends up back to the do not disconnect
window.

Gregg
Title: Re: Help with my Ipod 60G Video
Post by: GodEater on January 17, 2007, 02:38:33 AM
Try unplugging the USB cable after you've done the install.
Title: Re: Help with my Ipod 60G Video
Post by: greggdecker on January 17, 2007, 10:56:53 AM
Hi
I should of said something before, I already unplugged the usb and it did nothing.  Except said
after the reset "it's all right to disconnect".  I fooled around for several hours and read most of the threads
and the only thing that came up was I read that if you have the brightness adjustment in settings
it means that although it is a Version 5G it it may behaving like a 5.5G which there are no Rockbox mods for yet.

ThanX

Gregg Decker  
Title: Re: Help with my Ipod 60G Video
Post by: PHK Brasil on January 17, 2007, 11:33:11 AM
♪
No Greg, 60gb iPod video are only 5G. Just the iPod video 5.5G 80gb are unsupported officially today.

Which bootloader are you using? The initial screen in black or light blue?

Have you puted the firmware (.rockbox folder and rockbox.ipod file) in the right place?

♪
Title: Re: Help with my Ipod 60G Video
Post by: greggdecker on January 17, 2007, 12:17:03 PM
I am going to try it again and see the results.  I think the initial screen is black, this is where it
shows various info about the Ipod, this is definetly from the Rockbox mod.  Then I get a quick flash screen with Rockbox which I believe is blue (I don't know which screen you mean).  After the ROckbox splash
whis is under a second I get a picture (which is not from the Ipod firmware but from Rockbox)
of a USB cable but its too fast to see any detail.  This is where I get the DO not disconnect or
safe to disconnect (depending on whether the usb is plugged in or not.) and it stops.  i am sure that this is Rockbox because the fonts are smaller and its is  nothing I've ever seen on the Ipod
before I did this mod.  At this point I have to uninstall Rockbox to get the Ipod working again.

I will try again today sometimes and note exactly what happens.  The Ipod directory in disk mode shows all the files in the right places.

Thanx again

Gregg

Title: Re: Help with my Ipod 60G Video
Post by: Llorean on January 17, 2007, 12:23:48 PM
The last screen (Do not Disconnect) is an iPod screen. It's the iPod emergency disk mode. Your assumption that it's Rockbox because you've never seen it before is fallacious. I suspect there are other iPod screens you haven't seen before, but that doesn't make them non-existent.

Rockbox does not have a USB mode, or a "Do not disconnect" screen. The USB plug is a Rockbox screen, but then it reboots to the Apple disk mode. For some reason your iPod thinks it has a USB cable plugged in.
Title: Re: Help with my Ipod 60G Video
Post by: greggdecker on January 17, 2007, 12:30:21 PM
I will try again and pay more attention to the screens. Maybe I am missing something.

Gregg
Title: Re: Help with my Ipod 60G Video
Post by: Llorean on January 17, 2007, 12:32:28 PM
It sounds like your iPod is one of the very small few that for some reason always thinks USB power is connected once Rockbox is installed.

Try booting the Apple firmware, and you'll probably see a charging logo on the battery icon even when it's not plugged in.
Title: Re: Help with my Ipod 60G Video
Post by: greggdecker on January 17, 2007, 12:57:22 PM
Yes, I always thought that this Ipod was a little quirky.  Most times it will only charge when I
have it plugged into a fire wire port.  These are not supposed to use firewire but its the only
way that it will chagre.  I put a new battery in it but that didn't help.  I left the firewire cable home
and the battery is low so I can't do anything until tomorow.  Thanx  for all your help.

Gregg
Title: Re: Help with my Ipod 60G Video
Post by: Chronon on January 19, 2007, 02:04:41 PM
It sounds like a build with the alternate USB behavior might help.  In the main builds the default behavior is for the player to reset into Disk Mode when USB connection is detected.  This resetting can be avoided by holding down Menu when connecting the USB cable.  

There is a patch that switches the behavior so that the player doesn't reboot by default and one has to hold Menu when inserting the cable to get it to boot into Disk Mode.   Maybe this would be helpful in this situation.

Would this be a viable strategy?
Title: Re: Help with my Ipod 60G Video
Post by: greggdecker on January 19, 2007, 02:42:49 PM
I don't know you mean! Sorry.

Gregg
Title: Re: Help with my Ipod 60G Video
Post by: lexicon on January 19, 2007, 04:52:35 PM

I don't know you mean! Sorry.

Gregg


standard behaviour is that plug into usb cable=ipod goes into disk mode, plug in while holding Menu keeps rockbox running and only charges (no disk mode)

the patch allows you to switch this so that plugging in only charges, and you need to hold Menu while p[lugging in to get it into disk mode.

check out senab's build
http://forums.rockbox.org/index.php?topic=7942.new;topicseen#new

d/l from here, and read about the patches he applies:
http://www.senab.co.uk/rockbox/

but if rockbox won't even boot properly, I don't know how this will help...
Title: Re: Help with my Ipod 60G Video
Post by: Chronon on January 19, 2007, 08:53:02 PM
It sounds to me like Rockbox boots but immediately reboots into Disk Mode because for some reason the player thinks it's always connected to a USB host.  If that's the source of this behavior then it seems that this patch would circumvent the immediate reboot and allow Rockbox to stay running.  Just a thought. . .
Title: Re: Help with my Ipod 60G Video
Post by: greggdecker on January 19, 2007, 10:56:03 PM
Thanks for all the help and the info.  I will give this build a try.  ANother ting I noticed
with my Ipod is that it will not charge with the included USB, it only charges with a
Firewire plugged in.  Its a 5G and it comes up with a warning that it doesn't use firewire
but for the past year or so thats the only way I can charge it.  I think it was made with
leftovers.

Thanks Again

Gregg