Rockbox Technical Forums

Support and General Use => User Interface and Voice => Topic started by: Ton on October 01, 2006, 01:13:37 PM

Title: (Not a real) problem with scroll speed
Post by: Ton on October 01, 2006, 01:13:37 PM
When I set the scroll speed I used to see an example at the top of the screen ( a moving text line ).
However recently this does not work anymore. I don't know since which build, but now I see a fixed text line which doesn't move, although changing the scroll speed DOES affect the speed in the wps. So it is only the example that doesn't work and not a big problem because of this.
Is there a way to "repair" this ?
Title: Re: (Not a real) problem with scroll speed
Post by: Llorean on October 01, 2006, 01:15:04 PM
Out of curiosity, why on earth did you post this in the iRiver Installation section?
Title: Re: (Not a real) problem with scroll speed
Post by: bluebrother on October 01, 2006, 01:31:45 PM
If you choose a font that small that it fits in the first line it won't scroll. Simply use a bigger font as workaround.
Title: Re: (Not a real) problem with scroll speed
Post by: Ton on October 01, 2006, 01:40:31 PM

Out of curiosity, why on earth did you post this in the iRiver Installation section?


Sorry, I thought that that section was meant for everything related to iRiver.
Title: Re: (Not a real) problem with scroll speed
Post by: Ton on October 01, 2006, 01:42:32 PM

If you choose a font that small that it fits in the first line it won't scroll. Simply use a bigger font as workaround.
[/quote

I have the "headphones" wps, which uses the snap font which is indeed very small. So this will be the cause ?
Title: Re: (Not a real) problem with scroll speed
Post by: Llorean on October 01, 2006, 02:19:57 PM
The POSTING IN THIS FORUM post explicitly says that it is not for everything iriver related, but only installation and removal questions, and questions relating to flashing. As well, the forum is actually named to include the words Installation and Removal to make it clearer. Please, in the future read the guidelines as it will help prevent posts from ending up in the wrong sections.



Was there a question with your post where you quoted bluebrother, or was that the solution to your problem? (I can't help if I don't know what you're asking any more ;))
Title: Re: (Not a real) problem with scroll speed
Post by: Ton on October 01, 2006, 02:44:46 PM
Sorry again. I apparently made a mistake with quoting.
My answer, respectively question  to his reply was meant to be:
I have the "headphones" wps, which uses the snap font which is indeed very small. So this will be the cause ?
Title: Re: (Not a real) problem with scroll speed
Post by: Llorean on October 01, 2006, 03:24:17 PM
It's very likely yes. You can't scroll a line shorter than the screen, so if the test line is entirely on screen it will not scroll.
Title: Re: (Not a real) problem with scroll speed
Post by: Ton on October 01, 2006, 04:54:46 PM
Thanks Llorean. Tried (temporarily) a bigger font and indeed I got a scrolling example.
Title: Re: (Not a real) problem with scroll speed
Post by: Rincewind on October 01, 2006, 05:50:02 PM
so the real fix is quite simple - somebody with cvs access needs to make the example line longer in the .lang files.

But this can wait until jdGordon has commited his menu rework.