Rockbox Technical Forums

Installation / Removal => Manual Installation => Apple - Installation/Removal => Topic started by: Casej on September 17, 2006, 11:25:41 PM

Title: Having trouble installing on 5g video
Post by: Casej on September 17, 2006, 11:25:41 PM
Hey,
Well i decieded to install rockbox on my ipod after hearing it be discussed on head-fi. It did the step by step install and got the light blue screen then it went to apple firmware. After that i downloaded the new CVS build and opened the folder with winzip and highlighted all the files and told them to extract to my ipod as it stood in my computer e:/jaysonsip. After i did that i got both the folder and seperate ipod file. But when i went to eject my ipod it said "failed to eject volume" and said it failed to eject from my PC. After that went away i restarted my ipod and it went straight to apples firmware.  I cant get into rockbox becuase it goes striaght into apple, and i tired installing differen versions but they all failed. Any ideas on what i should do next? All suggestions are more then welcome!
Title: Re: Having trouble installing on 5g video
Post by: L on September 17, 2006, 11:29:58 PM
Please detail the steps you took to install the boot loader not just the copying of the ROCKbox files.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 17, 2006, 11:41:06 PM
My bad :-\ From step 10 from here http://www.ipodwizard.net/showthread.php?t=8504
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 17, 2006, 11:46:42 PM
Wait, so you started at step 10?
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 17, 2006, 11:50:04 PM
Im sorry through step 10, to the part where you install rockbox. Im taking a screenshot right now of what all i typed in cmd.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 17, 2006, 11:52:09 PM
Well this turned out blurry but its everything i typed

(http://i31.photobucket.com/albums/c398/casej18/rb2.jpg)
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 12:01:30 AM
Okay, and when it goes "Straight into Apple" how are you restarting the iPod?
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 12:08:29 AM
When i did it i went my computer->ipod->Eject. Thanks for your help!
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 12:09:12 AM
How is that supposed to restart your iPod?

Have you tried holding Menu+Select to actually REBOOT it?
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 12:10:57 AM
No i havent, im assuming thats what i shoudl have done  :-\
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 12:11:57 AM
You haven't actually shut down the iPod, which kinda makes it impossible for it to boot into Rockbox, because the only way to leave the Apple firmware is to either
A) change the firmware partition (forces a reboot)
B) let your iPod sit for a few days so it goes into "deep" sleep
C) Menu+Select
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 12:14:28 AM
Well i just wiped the whole thing ( all my music wasnt in apple either and hit panic butten 5 mins ago) If i start from new i take it when i finish extracting rockbox into the ipod i hold those buttons and that boots it in there?
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 12:20:38 AM
Hold Menu+Select until the screen clears and then an Apple logo shows. Then let go, and it should show the Rockbox bootloader, and then if Rockbox is extracted properly, boot Rockbox.

Seriously though, in the future, if you ask for help you shouldn't just go off and do random things while waiting for a response. It often will just mean that it'll take longer to resolve your problem.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 12:24:13 AM
Thanks a ton, Im sorry i didnt mean any disrespect. It was just one of those oh shit i f'd up lol. So after i extract rockbox then i reboot? just making sure this time around  ;D
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 12:28:56 AM
Actually, the *best* way to do it, is right after doing the "ipodpatcher N -w rockboot.bin" step, before disconnecting, copy everything over.

But any time you go into the Apple firmware, you'll have to do the Menu+Select reboot to get back to Rockbox.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 12:35:22 AM
Ok i just finished through the step you are talking about. You are saying to extract rocbox first or reboot first?
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 12:39:10 AM
Extract first, is easier.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 12:41:27 AM
Sweet just extracted it THANK YOU so much for being so patient. In the guide they ask to disconnect it the normal way, is that just pulli the plug or ejecting it in my computer?
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 12:42:33 AM
Ejecting is always better.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 12:46:43 AM
WOooo thanks a ton it works! Is there anything special to putting the music in a folder in the ipod?
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 12:50:19 AM
Nope. Just put it where you want it.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 12:54:46 AM
Well have another stupid question  ::) I added .mp3 and wen t play it and it said codec failure. What am i screwin up now
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 01:07:17 AM
I assume you're running an official Rockbox build, and you have both the rockbox.ipod file and the /.rockbox/ folder on your iPod?
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 01:15:23 AM
Yes i have them both on there. Maybe do i put the music in the rockbox folder or doesnt it matter if it goes in that root?
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 01:16:36 AM
As I said, you can put the music wherever you want.

You didn't answer if you're using an official version.

Also, in the /.rockbox/codecs/ folder, there's one for MP3, right?
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 01:21:20 AM
Well i DL the rockbox latest dl for video ipod v.9-17 Also there is no codec folder you are talking about
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 01:29:21 AM
The official builds don't have a version number. You *are* downloading from Rockbox.org, right?
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 01:31:57 AM
Yes i am. I went to download section then looked for my  video ipod from there then hit the latest tab and DL that. Do i need to download the soure archive instead? Or maybe the CVS build?
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 01:35:22 AM
Then where did you get the v.9-17 number from?

Also, you aren't extracting right if you don't have a /.rockbox/codecs/ folder, as it's in the archive.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 01:39:28 AM
i got the name from when you click the DL and its named after the date 9-17. Do you not hihglight all the files then extract them to ipod? i dont think i specifed a folder for them to go to
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 01:43:31 AM
Woot i installed the CVS build instead of the other and it works now!!! thanks for helping the biggest noob ever  :o
Title: Re: Having trouble installing on 5g video
Post by: Llorean on September 18, 2006, 01:45:34 AM
The download is actually named 20060917 (or 20060918 now) so there's no - in it. Because you told me a different number from what it actually said, I thought you'd gotten it somewhere else.
Title: Re: Having trouble installing on 5g video
Post by: Casej on September 18, 2006, 01:50:06 AM
Hey you got it to work, thanks a ton man. Sorry about all the confusion i wasent trying to do that at all i jsut really wanted it to work!
Thanks for your time,
Jayson