Rockbox Technical Forums

Installation / Removal => Manual Installation => Cowon - Installation/Removal => Topic started by: culhane on July 12, 2006, 02:53:03 AM

Title: Unable to get rockbox running properly on iAudio x5Hi,
Post by: culhane on July 12, 2006, 02:53:03 AM
Hi,

I've just installed  the  latest daily build of rockbox on my iAudio x5 player along with the   x5_fw.bin which I downloaded about 2 weeks ago.

The player starts up fine, but the  following problems then  occur:

1.  the main menu cannot be accessed.  I  tried holding  the play button for several seconds, but no joy.

2.  When playing an audio  file  I get 'illegal instruction' errors and  'access address'  errors  when  starting and stopping mp3 files.

3.  I get no speech output when navigating the file  viewer.

As I'm blind I need the speech output in order to operate  the player.

Can anybody suggest what I need to do  in order to get rockbox  operational in a less unstable manner?

Thanks,

Tim
Title: Re: Unable to get rockbox running properly on iAudio x5Hi,
Post by: Jon_ on July 13, 2006, 10:41:44 PM
Hi,

I've just installed  the  latest daily build of rockbox on my iAudio x5 player along with the   x5_fw.bin which I downloaded about 2 weeks ago.

The player starts up fine, but the  following problems then  occur:

1.  the main menu cannot be accessed.  I  tried holding  the play button for several seconds, but no joy.

2.  When playing an audio  file  I get 'illegal instruction' errors and  'access address'  errors  when  starting and stopping mp3 files.

3.  I get no speech output when navigating the file  viewer.

As I'm blind I need the speech output in order to operate  the player.

Can anybody suggest what I need to do  in order to get rockbox  operational in a less unstable manner?

Thanks,

Tim

Did you try reinstallation?
Title: Re: Unable to get rockbox running properly on iAudio x5Hi,
Post by: RaeNye on July 14, 2006, 07:19:32 AM
1. The REC button is used to enter the main menu on X5; the PLAY button pauses and resumes playback.

2. Maybe related to 3, I'm not sure.

3. You need to install the voice data file. More information on this on the Wiki, which is currently unfortunately down, but the following link may help you --
http://daniel.haxx.se/twiki/VoiceFiles/ (http://daniel.haxx.se/twiki/VoiceFiles/)