Rockbox Technical Forums

Installation / Removal => Manual Installation => Iriver - Installation/Removal/Flashing => Topic started by: rpleak on August 20, 2017, 03:15:43 PM

Title: No iriver_flash plugin displayed with the 'Open With' command
Post by: rpleak on August 20, 2017, 03:15:43 PM
I'm trying to change over from a hard drive to a CF card in my iHp 140, but have hit a roadblock. I've followed all the instructions so far to try to flash the version 7-pre4 bootloader, but when I 'Open With' the bootloader, iriver_flash isn't in the list of plugins. Can anyone help?

Thanks!
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: saratoga on August 20, 2017, 06:16:57 PM
Looking at the code, the iriver_flash plugin works on .iriver files.  Is that what you are trying to open?
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: rpleak on August 20, 2017, 06:32:37 PM
Yes. The file I'm trying to use iriver_flash on(if it would show up as a plugin) is bootloader.iriver.

This is the procedure I'm trying to follow, as cut and pasted from the Iriver firmware flashing direction:

    "Set "Show Files" to "All".
    Through the Files entry in the Rockbox menu, navigate to the .rockbox directory, enter it and scroll down to bootloader.iriver,
    Place cursor over bootloader.iriver and long press joystick, (navi), then select "Open with...".
    From the list of plugins, select iriver_flash and execute it.
    If the check requirements are met, a confirmation message is displayed,
    Press PLAY to confirm, the bootloading flashing starts, this usually takes a few seconds, don't touch your player during this process, as any interruption could brick the player
    If everything went fine, you should see, "Success" displayed briefly.
    Now you can either reboot your player and use it like before, or continue to the next section and flash Rockbox over the original firmware."

My problem is, when I try to 'Open With' on the bootloader.iriver file, iriver_flash isn't among the list of plugins displayed....
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: __builtin on August 20, 2017, 08:06:37 PM
Seems to be a bug. CATEGORIES has iriver_flash installed under apps/, but viewers.config expects it to be in viewers/. For now try copying the iriver_flash.rock file from .rockbox/rocks/apps to .rockbox/rocks/viewers.

1. https://git.rockbox.org/?p=rockbox.git;a=blob;f=apps/plugins/CATEGORIES;h=929788f826bacf2cca989e367dbfe30933cf9f5c;hb=HEAD#l41 (https://git.rockbox.org/?p=rockbox.git;a=blob;f=apps/plugins/CATEGORIES;h=929788f826bacf2cca989e367dbfe30933cf9f5c;hb=HEAD#l41)
2. https://git.rockbox.org/?p=rockbox.git;a=blob;f=apps/plugins/viewers.config;h=c938eeb275456daaee5dd5ccbdf7b4b541b0cb34;hb=HEAD#l78 (https://git.rockbox.org/?p=rockbox.git;a=blob;f=apps/plugins/viewers.config;h=c938eeb275456daaee5dd5ccbdf7b4b541b0cb34;hb=HEAD#l78)
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: rpleak on August 20, 2017, 10:40:23 PM
In my Rockbox installation, there is no apps directory in the .rockbox/rocks directory, in fact, there are no subdirectories at all in the .rockbox/rocks folder.

Judging from all the other people who have successfully flashed their Iriver ROMs, I'm wondering where I went wrong. Rockbox is working just fine on my iHP 140, so I'm assuming the installation must be correct. Very frustrating.
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: saratoga on August 21, 2017, 01:19:07 AM
Do any plugins at all work? Sounds like your install never finished copying or you deleted part of it.
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: rpleak on August 24, 2017, 05:10:58 PM
I formatted the hard drive and reinstalled Rockbox, using Rockbox Utility v1.4.0. I then copied the file bootloader.iriver to the .rockbox directory(one difference, now I see the rambox.iriver and rombox.iriver files, they weren't present before doing a fresh install). However, now when I long click on the bootloader.iriver file and try 'Open With' I get a message that says 'no viewers found'....
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: __builtin on August 24, 2017, 07:52:59 PM
Are there any plugins listed under the "Plugins" item on the main menu?
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: rpleak on August 24, 2017, 10:03:44 PM
No. Shouldn't they have been installed during the new install?
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: __builtin on August 24, 2017, 10:20:57 PM
Yes, they should have been. Did you properly unmount and eject the player after installing Rockbox?
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: rpleak on August 25, 2017, 12:49:15 AM
After reformatting, reinstalling the iRiver firmware, and reinstalling RockBox, I was finally able to install the CF card compatible bootloader. I don't know what I did wrong the first 4 times, but it seems to be working now.

Thanks for trying to help me, it is very much appreciated...
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: rpleak on August 25, 2017, 02:10:34 AM
Seems I'm not out of the woods yet. My iriver sees the CF card just fine, everything seems to be just great---except none of my music files will play. They start to load for an instant, then stop. If there are multiple songs in a directory, you can see the titles flash by, then it stops. If I try to resume play, it says nothing to resume. I connected the player via USB, and my files play just fine on my computer. I don't think Rockbox likes me very much....
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: __builtin on August 25, 2017, 10:54:16 AM
It might be due to codecs not being installed for some reason, which might be the same reason why plugins weren't installed right. Can you check that the .rockbox/codecs directory is populated?
Title: Re: No iriver_flash plugin displayed with the 'Open With' command
Post by: rpleak on August 25, 2017, 03:10:22 PM
Only some of the codecs were installed. I downloaded the manual install, copied all the codecs over to my player, now everything is working fine. Thanks again!!!