Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: Graham1 on March 03, 2016, 05:16:12 PM

Title: [Sansa Clip v2] - Blank Display [RESOLVED]
Post by: Graham1 on March 03, 2016, 05:16:12 PM
Hi

Installing the development version (5138995) on my sansa clip v2 displays a blank screen straight after applying the firmware. Rockbox seems to be running in the background as the clip lights up when buttons are pressed and occasionally the screen re-appears. I'll edit this post again if I can confirm which buttons worked. Btw, the stable release (version 3.13) works without any problems.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 03, 2016, 05:57:50 PM
Can you post your config.cfg file contents?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 03, 2016, 07:02:07 PM
Can you post your config.cfg file contents?

Hi saratoga

Please see my config.cfg below

:)


# .cfg file created by rockbox 5138995-160216 - http://www.rockbox.org

volume: -24
selector type: pointer
scrollbar width: 5
time format: 12hour
sbs: /.rockbox/wps/classic_statusbar.sbs
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 03, 2016, 07:46:03 PM
Try this build:

www.mit.edu/mgg6/www/rockbox-clipv2_noscaling.7z

Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 03, 2016, 08:09:49 PM
Try this build:

www.mit.edu/mgg6/www/rockbox-clipv2_noscaling.7z

Same blank screen I'm afraid :'(.

When I switch on the clip, the rockbox logo appears briefly and then the screen goes blank. Shortly after this, the arrow keys and circle light up blue and then turn off after a couple of seconds.

:)

EDIT: Btw, booting into Sandisk's firmware (left arrow + power) loads fine.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 04, 2016, 11:35:50 AM
Ok so its probably not my recent frequency scaling changes.  I'm not sure then, have you tried any builds since 3.13 but before this month?  A lot has changed over the last few years.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 04, 2016, 12:55:24 PM
Ok so its probably not my recent frequency scaling changes.  I'm not sure then, have you tried any builds since 3.13 but before this month?  A lot has changed over the last few years.

No, I haven't tried any of the previous builds. I have been using the Rockbox utility to pull down the stable and development versions. Is it just a case of unzipping these builds and then copy/paste onto the root of the clip? (deleting the previous version first).

I'll test a few and report back which is the latest working version.

:)

EDIT: I have tested the latest builds of each Rev (2016-02-16, 12, 7 and 6) and all show a blank screen.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 04, 2016, 01:00:24 PM
Unfortunately we don't provide binaries for old development builds so you would have to compile them yourself. I was hoping you had tried some builds in the past and could give some clues.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 04, 2016, 01:25:50 PM
Unfortunately we don't provide binaries for old development builds so you would have to compile them yourself. I was hoping you had tried some builds in the past and could give some clues.

Sorry, I only joined the other day :). Not to worry, I'll put the stable version back on. Thanks for all your help. Appreciated.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: zeon on March 08, 2016, 11:04:30 AM
Installing the development version (5138995) on my sansa clip v2 displays a blank screen straight after applying the firmware.

Me too. This happens with 5138995 build only.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 08, 2016, 11:44:34 AM
What was the last build that worked? 
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 08, 2016, 03:16:10 PM
Try this build:

www.mit.edu/mgg6/www/rockbox-clipv2_noscaling.7z

In this build you just disable scaling or reverting whole patch? Possibly we still have some timing issue on cliv2 with new frequency.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 09, 2016, 01:33:23 PM
No, I just disabled scaling.  Here is the last version before any changes (1015088d90275336e7b999624d2524800b8aa3e8):

www.mit.edu/mgg6/www/rockbox-clipv2-beforeScaling.7z
www.mit.edu/mgg6/www/rockbox-clip+-beforeScaling.7z
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 09, 2016, 03:11:19 PM
No, I just disabled scaling.  Here is the last version before any changes (1015088d90275336e7b999624d2524800b8aa3e8):

www.mit.edu/mgg6/www/rockbox-clipv2-beforeScaling.7z
www.mit.edu/mgg6/www/rockbox-clip+-beforeScaling.7z

Hi saratoga

Just letting you know that this version works with my Sansa Clip v2. I'm not sure if I did the right thing buy moving the existing ".rockbox" folder to my harddisk and then extracting the file above onto my SCv2. Displays the new version when booting Rockbox now so I guess all went well.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 09, 2016, 04:16:29 PM
In lcd-clipv2.c we have #define LCD_DELAY 10 and  while(i<LCD_DELAY) i++;
Probably we should change it or replace with udelay.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 09, 2016, 04:33:25 PM
http://www.mit.edu/mgg6/www/rockbox-clipv2-lcddelay_25.7z

Longer LCD delay (25, and frequency scaling enabled since that doesn't seem to be the problem). 
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 13, 2016, 12:03:29 PM
If someone with a display problem on the clip could test that it would be very helpful.

Mihail:  sorry I haven't been working on this lately, I still want to get your patches committed. How do you want to proceed?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 13, 2016, 01:01:49 PM
IMHO first we should add gui boost - we already have many reports about it. Also we can commit simple bug fix: g#1269, g#1271, g#1273, g#1274, g#1275. Wait for week or two and commit g#1272 and enable voltage scaling.

For g#1270 we need more testing, especially on AMSv1.
g#1276 should be good for commit, but please test it on your players before commit.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 13, 2016, 07:21:14 PM
If someone with a display problem on the clip could test that it would be very helpful.

Still showing a blank display after boot.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 13, 2016, 07:46:51 PM
Probably we need much bigger delay (>=50) as it was in case fuze v2.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 13, 2016, 07:56:38 PM
Occasionally, the screen displays after pressing a button but doesn't display instantly like 3.13 did. It's a bit trial and error but usually the longer you leave the clip without pressing a button, the more chance you have of the screen appearing. If you press a button and the screen doesn't display, it doesn't after that.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 18, 2016, 10:36:19 AM
Here are two longer delays.  Do either of them work?

http://www.web.mit.edu/mgg6/www/rockbox-clipv2-lcddelay_50.7z
http://www.web.mit.edu/mgg6/www/rockbox-clipv2-lcddelay_100.7z
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 18, 2016, 03:04:11 PM
Here are two longer delays.  Do either of them work?
http://www.web.mit.edu/mgg6/www/rockbox-clipv2-lcddelay_50.7z
http://www.web.mit.edu/mgg6/www/rockbox-clipv2-lcddelay_100.7z

Blank display on both. Could you confirm I'm applying the correct actions.

1. Use Rockbox Utility 1.4.0 to install boot loader only (development version). Boots as 5.0
2. Extract zip and copy ".rockbox" folder to root of Sansa Clip v2.
3. Waited 50 and 100 secs after each installation.

Pressing the play button after these times did display menu on both these installations.

:)

Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 18, 2016, 03:16:46 PM
You don't need rockbox utility, just to copy the build to the player.  Is that what you were doing?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 18, 2016, 04:08:50 PM
saratoga: I am very unsure is it related, but can you also add big delay in button_hold (as it was for fuze v2)?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 18, 2016, 04:23:24 PM
You don't need rockbox utility, just to copy the build to the player.  Is that what you were doing?

Just wanted to make sure I was using the correct firmware (development, rather than stable) or does that not matter? I usually just delete the ".rockbox" folder on Sansa Clip v2 and then replace (copy/paste) with newer builds.

:)

Edit: Just so I am sure, should these fixes display the menu straight after the Rockbox logo? (like with 3.13).

Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 23, 2016, 03:50:54 AM
saratoga: I am very unsure is it related, but can you also add big delay in button_hold (as it was for fuze v2)?

Or you have better idea?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 23, 2016, 12:29:10 PM
saratoga: I am very unsure is it related, but can you also add big delay in button_hold (as it was for fuze v2)?

Or you have better idea?

Sorry no, just busy.  Could you give me a patch?  I'm not too familiar with that delay. 
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 23, 2016, 01:14:25 PM
Ok.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 23, 2016, 02:43:12 PM
http://web.mit.edu/mgg6/www/rockbox-clipv2-button_hold.7z

Let us know if this works any better.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 23, 2016, 05:12:59 PM
http://web.mit.edu/mgg6/www/rockbox-clipv2-button_hold.7z

Let us know if this works any better.

Blank screen after logo. No display after keypress now.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 24, 2016, 02:54:14 AM
Another build for test: http://knk.square7.ch/rockbox-0.zip
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 24, 2016, 04:27:02 PM
Another build for test: http://knk.square7.ch/rockbox-0.zip

Still a blank display.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 25, 2016, 04:42:43 AM
Ok ;) I disable hold and power button to be sure that not related.
http://knk.square7.ch/rockbox-1.zip
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 25, 2016, 03:15:17 PM
Ok ;) I disable hold and power button to be sure that not related.
http://knk.square7.ch/rockbox-1.zip

Blank after boot. Not sure if you were joking about hold and power buttons being disabled but both are working. Pressing hold and sliding up again shows display each time. Interface navigation is very sluggish.

Edit: Straight after boot, sliding down (hold) and back up again displays screen instantly.

Edit2: The same above applies to the latest development build and navigation is still sluggish.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: C0da on March 25, 2016, 03:21:15 PM
I have the same problem wist the broken screen. Tried all files without success.

Can someone walk me through the music folder to play at least the songs without the screen? Which buttons do I have to press?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 25, 2016, 03:33:42 PM
Also, once the display is working but then times out (backlight off), the same problem with the blank screen which can only be resolved by sliding down and up again.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 25, 2016, 04:21:30 PM
Blank after boot. Not sure if you were joking about hold and power buttons being disabled but both are working. Pressing hold and sliding up again shows display each time. Interface navigation is very sluggish.

Very strange.

saratoga: Can you test hold and power button on your clip v2 with this (http://knk.square7.ch/rockbox-1.zip) build?

I have the same problem wist the broken screen. Tried all files without success.

Can someone walk me through the music folder to play at least the songs without the screen? Which buttons do I have to press?

Probably better revert rockbox to version 3.13.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 25, 2016, 04:31:10 PM
saratoga: Can you test hold and power button on your clip v2 with this (http://knk.square7.ch/rockbox-1.zip) build?

Power button is completely disabled, but the hold switch works.  Otherwise the build is completely normal on my device. 
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 25, 2016, 04:43:59 PM
I have the same problem wist the broken screen. Tried all files without success.

Can someone walk me through the music folder to play at least the songs without the screen? Which buttons do I have to press?

Hi C0da

Does sliding down (hold) and up again work on your Sansa Clip v2?

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 25, 2016, 04:45:23 PM
Another build, should disable hold and power button.
http://knk.square7.ch/rockbox-2.zip
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 25, 2016, 04:47:11 PM
Power button is completely disabled, but the hold switch works.  Otherwise the build is completely normal on my device.

Hi saratoga

Does the display turn on instantly after the Rockbox logo on your Sansa Clip? I'm using original firmware 02.01.35 if that helps.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 25, 2016, 04:50:47 PM
Another build, should disable hold and power button.
http://knk.square7.ch/rockbox-2.zip

Is that for me to test or saratoga?

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 25, 2016, 04:51:38 PM
For both.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 25, 2016, 05:02:38 PM
Another build, should disable hold and power button.
http://knk.square7.ch/rockbox-2.zip

Hold doesn't work now but power still does.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 25, 2016, 05:06:57 PM
You still have problem with display?

If power button work, it should power off after 3 sec. If not, it still can force hardware power off after > 10 sec.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 25, 2016, 05:11:21 PM
You still have problem with display?

If power button work, it should power off after 3 sec. If not, it still can force hardware power off after > 10 sec.

Ok, thanks. Must have been doing a force hardware power off as still on (blue lights) after 4 secs but no display with this build.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: C0da on March 26, 2016, 01:44:00 AM
I have the same problem wist the broken screen. Tried all files without success.

Can someone walk me through the music folder to play at least the songs without the screen? Which buttons do I have to press?

Hi C0da

Does sliding down (hold) and up again work on your Sansa Clip v2?

:)

Yes every button works only the display is black. I'm back at 3.13 again.

Can someone post which buttons I need to press in order to get in the music folder?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 26, 2016, 03:50:04 AM
Yes every button works only the display is black. I'm back at 3.13 again.

Can someone post which buttons I need to press in order to get in the music folder?

You back to 3.13 and still have black display?


Graham1: http://knk.square7.ch/rockbox-3.zip
Title: Re: [Sansa Clip v2] - Blank Display
Post by: C0da on March 26, 2016, 06:54:57 AM
Yes I have black screen with every version.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 26, 2016, 07:26:59 AM
Yes I have black screen with every version.

Are you see rockbox logo at startup?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: C0da on March 26, 2016, 07:35:17 AM
Yes I have black screen with every version.

Are you see rockbox logo at startup?

No I don't see anything but I know the player is still working because I accidently turned on the radio. I just don't know which combination I have to press to access the music folder.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 26, 2016, 08:06:58 AM
No I don't see anything but I know the player is still working because I accidently turned on the radio. I just don't know which combination I have to press to access the music folder.

In answer to your question and given that you haven't changed any of the default settings (hopefully). The structure should look like this.

Files
---##MUSIC#
---##PORT#
---ARCHIVE
---AUDIBLE
---AUDIOBOOKS
---MUSIC

I would imagine pressing the home button will take you back to the "Files" section. As the hold and return to normal position (slider switch) doesn't work for you, maybe using the voice file will help with speaking the folders to you.

Does the original Sansa firmware work for you?

Edit: If you use the "Home" button you will need to select (middle button) to enter the Files section.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: cereal_killer on March 26, 2016, 09:11:55 AM
Yes I have black screen with every version.

Is your LCD display dead then? Using the standard settings you should be in the main menu when turning the player on. Pressing the home button should bring you to the WPS. Now pressing the select button brings you to the file browser then. You could edit the config.cfg file on your player to start playing music after boot to at least listen to music.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 26, 2016, 09:23:34 AM
Graham1: http://knk.square7.ch/rockbox-3.zip

Blank screen.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 26, 2016, 12:43:24 PM
C0da: you can install voice (http://www.rockbox.org/wiki/VoiceHowto) file:
for latest dev: http://download.rockbox.org/daily/voices/sansaclipv2-20160326-english.zip
or for 3.13: http://download.rockbox.org/release/3.13/sansaclipv2-3.13-english.zip

Graham1: http://knk.square7.ch/rockbox-4.zip
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 26, 2016, 01:04:28 PM
I have the same problem wist the broken screen. Tried all files without success.

Can someone walk me through the music folder to play at least the songs without the screen? Which buttons do I have to press?

Hi C0da

Does sliding down (hold) and up again work on your Sansa Clip v2?

:)

Yes every button works only the display is black. I'm back at 3.13 again.

Can someone post which buttons I need to press in order to get in the music folder?

Does the screen work in the Sandisk firmware?
Title: Re: [Sansa Clip v2] - Blank Display
Post by: C0da on March 26, 2016, 01:26:29 PM
C0da: you can install voice (http://www.rockbox.org/wiki/VoiceHowto) file:
for latest dev: http://download.rockbox.org/daily/voices/sansaclipv2-20160326-english.zip
or for 3.13: http://download.rockbox.org/release/3.13/sansaclipv2-3.13-english.zip

This helped me out.


Does the screen work in the Sandisk firmware?

No because I'm unable to install it. The Sansa Updater doesn't find the Clip and when I put the m30pa.bin in the root directory nothing happens. Did I miss something?

Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 26, 2016, 01:46:47 PM
No because I'm unable to install it.

The sandisk firmware is always installed.  Hold left when powering on to boot it.
Title: Re: [Sansa Clip v2] - Blank Display
Post by: C0da on March 26, 2016, 02:00:28 PM
No because I'm unable to install it.

The sandisk firmware is always installed.  Hold left when powering on to boot it.

Thanks blank screen as well with original firmware. :(
Title: Re: [Sansa Clip v2] - Blank Display
Post by: saratoga on March 26, 2016, 02:06:04 PM
No because I'm unable to install it.

The sandisk firmware is always installed.  Hold left when powering on to boot it.

Thanks blank screen as well with original firmware. :(

It sounds like your player has a broken screen.  Start a new thread if you have questions, this one is about fixing a problem with clipv2 frequency scaling builds. 
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Graham1 on March 26, 2016, 03:05:48 PM
Graham1: http://knk.square7.ch/rockbox-4.zip

Blank screen.

:)
Title: Re: [Sansa Clip v2] - Blank Display
Post by: Mihail Zenkov on March 27, 2016, 04:49:19 AM
I think now it should work :)
http://knk.square7.ch/rockbox-5.zip
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: Graham1 on March 27, 2016, 06:17:07 AM
I think now it should work :)
http://knk.square7.ch/rockbox-5.zip

Yes, you are correct. Many thanks for your help :). May I ask what the problem was and how you resolved it?

@saratoga: Thanks for your help also.

:)
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: Mihail Zenkov on March 27, 2016, 01:24:24 PM
After adding frequency scaling we have overclocked display port.
http://gerrit.rockbox.org/r/#/c/1281/
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: saratoga on March 27, 2016, 02:46:04 PM
Looks good.  Do you think it's time to put in the voltage changes and do this all over again when things break :)
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: Mihail Zenkov on March 27, 2016, 03:08:35 PM
 :) I commit g#1272 as it can help got less bug reports. So if you want enable voltage scaling - do that.
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: saratoga on March 27, 2016, 03:53:55 PM
http://gerrit.rockbox.org/r/#/c/1282/

If this looks good to you I'll push it.
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: Mihail Zenkov on March 27, 2016, 04:09:23 PM
Yes, good solution.
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: saratoga on March 27, 2016, 04:20:40 PM
Fixed a dumb mistake and then pushed.
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: Mihail Zenkov on March 27, 2016, 04:30:01 PM
I also overlooked and we still have same mistake in rockbox code :)
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: saratoga on March 27, 2016, 04:47:28 PM
Yes, current build is broken.  What am I missing?

Edit:  I don't see anything obviously wrong and don't have time to dig into this right now.  I'll just disable it again until its fixed.
Title: Re: [Sansa Clip v2] - Blank Display [SOLVED]
Post by: Mihail Zenkov on March 28, 2016, 03:27:17 AM
I mean another code, not related to voltage/frequency scaling. IMHO for lebellium report we just should rise voltage. I have made test build and I wait for him in IRC.
Title: Re: [Sansa Clip v2] - Blank Display [RESOLVED]
Post by: boxbot on March 14, 2017, 05:48:51 PM
I also have the same problem with a Sansa Clip Zip; buttons work fine, the display is fine on the firmware load, but on Rockbox I get a black screen, no loading page or anything. Every now and then in a dim room I can see the display is on, but very faintly.

http://knk.square7.ch/rockbox-5.zip might fix my problem but the link is broken. Does anyone have a reupload?
Title: Re: [Sansa Clip v2] - Blank Display [RESOLVED]
Post by: Mihail Zenkov on March 14, 2017, 05:59:47 PM
I also have the same problem with a Sansa Clip Zip; buttons work fine, the display is fine on the firmware load, but on Rockbox I get a black screen, no loading page or anything. Every now and then in a dim room I can see the display is on, but very faintly.

Can you try reset config (just remove .rockbox/config.cfg)?

http://knk.square7.ch/rockbox-5.zip might fix my problem but the link is broken. Does anyone have a reupload?

We already commit this changes to rockbox.