Rockbox Technical Forums

Support and General Use => Audio Playback, Database and Playlists => Topic started by: alexweissman on December 05, 2015, 01:18:58 AM

Title: Still having issues with resuming playback in the middle of a playlist
Post by: alexweissman on December 05, 2015, 01:18:58 AM
This is for my Sansa Clip+ device, with playlists and mp3s stored on an external card.  I am using build 95a4c3a.

I'm still experiencing the seemingly random problem where Rockbox sometimes restarts my playlist from the very beginning when I use "resume playback" after the device has been powered off and on again (both manually and via the idle shutdown feature).  See http://forums.rockbox.org/index.php/topic,48232.30.html (http://forums.rockbox.org/index.php/topic,48232.30.html).

I've started over with a fresh install of Rockbox, without fiddling with any of the bookmarking features (which I thought might have been part of the problem earlier). 

It's important to note that this is an intermittent problem.  Sometimes, I will pause in the middle of the playlist (think, stopping for gas), the device will shut itself down, and then I'll turn it back on and be able to resume playback right where it left off.  Other times, I will do the exact same thing, but when I turn it back on it starts all the way from the beginning of the first track in the playlist.

In my experiments, I've tried varying things like:

- Manually turning it off, vs idle shutdown
- Skipping through tracks before/after pausing
- Amount of time after shutdown before I power it on again

No matter what, there seems to be no rhyme or reason to when playback resumes correctly, vs starting over at the beginning.

This smells like a race condition to me.  How and where does Rockbox keep track of the playback resume point?
Title: Re: Still having issues with resuming playback in the middle of a playlist
Post by: rgrounds on December 10, 2015, 06:29:00 PM
Not sure if this is the same situation I had. I have a Sansa e200 and could NOT get playlists to resume anywhere but at the first track. I got around it by playing from the database, but then decided to try tinkering with the settings to get playlists to work as I wanted, as I'd like to hear the album in track (not alphabetic) order.

Nothing worked. So I deleted my playlists so I wouldn't try to use them. These had been created externally using EasyTag and dropped in the /Playlist directory and they worked in all respects save for the resume issue.  Then, with a few minutes to spare, I created a playlist on the Sansa using the rockbox playlist creation function, which was actually much easier than I had thought.

Oddly enough, THESE playlists now resume correctly.  So I looked at the format of the information in the files and found them identical to my externally created playlists.  Only thing I can think of is some sort of rights issue, which doesn't make sense.  But all playlists I create with rockbox now resumes as expected.

So it may not be your exact circumstance, but I'd suggest creating a playlist using rockbox and seeing how that works for you.
Title: Re: Still having issues with resuming playback in the middle of a playlist
Post by: [Saint] on December 10, 2015, 10:22:18 PM
I got around it by playing from the database, but then decided to try tinkering with the settings to get playlists to work as I wanted, as I'd like to hear the album in track (not alphabetic) order


Out of interest, am I parsing this incorrectly, or do you seem to think that the Database limits you to only viewing tracks in alphabetical order and/or building playlists as such?

Because that is quite simply not the case.


[Saint]

Title: Re: Still having issues with resuming playback in the middle of a playlist
Post by: rgrounds on December 10, 2015, 10:34:37 PM
I got around it by playing from the database, but then decided to try tinkering with the settings to get playlists to work as I wanted, as I'd like to hear the album in track (not alphabetic) order


Out of interest, am I parsing this incorrectly, or do you seem to think that the Database limits you to only viewing tracks in alphabetical order and/or building playlists as such?

Because that is quite simply not the case.


[Saint]
Every time I've selected an artist or genre from the database, the tracklist is in alphabetical order. How do I put that tracklist in album/track order?
Title: Re: Still having issues with resuming playback in the middle of a playlist
Post by: alexweissman on December 11, 2015, 12:32:02 AM
I use playlists essentially as mixtapes, combining tracks from various albums.  It makes more sense to do this on my PC, which is an easier interface than the Clip+ buttons - plus it allows me to use those playlists in other contexts as well.

But coming back to my issue, I haven't experienced it ever since I changed my config.cfg to the following:

Code: [Select]
# .cfg file created by rockbox 95a4c3a-151205 - http://www.rockbox.org

volume: -20
idle poweroff: 1
autoresume enable: on
start in screen: wps
playlist catalog directory: /<microSD1>/Playlists

Could it somehow have something to do with the modified idle poweroff time?