Rockbox Technical Forums

Support and General Use => User Interface and Voice => Topic started by: saydee on May 12, 2015, 02:15:20 PM

Title: Can't edit without issues
Post by: saydee on May 12, 2015, 02:15:20 PM
I've only dabbled in custom Themes and about a year ago I made one for my personal use and enjoy it.

Recently I wanted to make a small change to my theme and it seems to "crash", as when I load it the custom default generic plain Rockbox theme opens. If I change the change back it loads fine.

The change can be as small as replacing text that is displayed from an upper case to a lower case, and its not just my theme but any theme that I make a single one character change. To test I grabbed the cabbiev2 and changed the "Next Track:" text to read "next Track:" and it fails to load instead using the generic Rockbox default theme. I am using the UIsimulator, however the issue shows up if I load it on my iPod Video 5.5th gen. Another possible clue is that if I edit non text in the theme that is displayed, such as variables and settings, for example I can change the %pE from say 15 (seconds) to soemthing else, like 14, then the theme accepts those settings and works fine.

This leads me to believe that it has something to do with my editor, or setup. In the past year I went from Windows 7 to 8.1 and have a new Surface tablet. I've always used Notepad++ as my editor and it is setup for UTf-8 w/o BOM encoding.

What am I overlooking?
Title: Re: Can't edit without issues
Post by: saratoga on May 14, 2015, 01:48:17 PM
Post one of the files ?
Title: Re: Can't edit without issues
Post by: saydee on May 14, 2015, 03:23:59 PM
OK, I've posted the cabbiev2 wps file. Note that this is all original expect I've edited line 77 from "Next Track" to "next track". This attached .wps causes both my iPod and the UISim for the iPod Video to not load the Cabbie theme and instead defaults to the generic plain theme.

Let me know if you spot something.