Rockbox Technical Forums

Installation / Removal => Manual Installation => Iriver - Installation/Removal/Flashing => Topic started by: irishroze on June 29, 2006, 10:13:30 PM

Title: HELP!!! I followed the directions but no dice!
Post by: irishroze on June 29, 2006, 10:13:30 PM
I did what the site says but my h320 will not upgrade the firmware!  It just goes back to the music screen.  When I open the files on my desktop I can see files that my PC won't open and files that it will open with pictures in them!?  Did I screw up?  HELP!
I don't know if this helps, but I am using U.S. version 1.02 (that is what it says after I turn on my player).
I thought this whole thing was pretty self-explainitory but appearently I'm an idiot, 'cause it doesn't work for me!  Please tell me what I did wrong (if anyone can even understand my ramblings).
Thanks,
~irishroze  ???
Title: Re: HELP!!! I followed the directions but no dice!
Post by: ego on June 29, 2006, 11:29:39 PM
make sure the patched firmware file is named h300.hex. any other name won't be recognized when you run the firmware upgrade.
Title: Re: HELP!!! I followed the directions but no dice!
Post by: irishroze on June 30, 2006, 06:46:44 AM
Hey ego, thanks for responding!  The firmware is correct, I used the EU version for my H320 because site said that there is not a US version for this model.  After I got everything unzipped on my desktop, I ran the patch as directed and a window came up that said something about the patch being successful.  then I transferred everything to my H320 and tried to do the firmware upgrade but nothing happened.  Should I use something other then the 1.30 EU version(I noticed that there were several for this model)?  Should I start over again?  Should I just stop messing with things I don't understand? ;)  Anyway, Thanks for helping out, I really appreciate it.
~irishroze
Title: Re: HELP!!! I followed the directions but no dice!
Post by: ego on June 30, 2006, 08:59:36 AM
try with 1.29E or 1.29K. i can vouch for the Korean version personally, and i think but am not sure people have had trouble with the E versions, or at least 1.30
Title: Re: HELP!!! I followed the directions but no dice!
Post by: Febs on June 30, 2006, 09:17:29 AM
Are you absolutely certain that the h300.hex file is in the root directory of your player?

f:\h300.hex

(or whatever letter your player happens to be)
Title: Re: HELP!!! I followed the directions but no dice!
Post by: irishroze on June 30, 2006, 02:53:21 PM
Hi Febs, Thanks for responding. I am pretty sure. I can only tell you that when I look at the drive on my desktop that I see all my music folders, my text folder, my picture folder and so forth. I created another folder and named it Rockbox and put the files in there. Is that ok, or is there a different way that I should have done it? Also, should I try using a different version(i.e. 1.29E or 1.29K)? Please advise.
Thanks,
~ irishroze
Title: Re: HELP!!! I followed the directions but no dice!
Post by: Febs on June 30, 2006, 05:06:33 PM
No, that's not right.  You didn't follow the directions.  Put the h300.hex file in the ROOT of your directory.  In other words, don't put it in any folders, just put it on the drive.  THEN do the firmware upgrade procedure.
Title: Re: HELP!!! I followed the directions but no dice!
Post by: gearheadE34 on July 01, 2006, 10:46:03 AM
root meaning not in any folders, in case that wasn't clear
Title: Re: HELP!!! I followed the directions but no dice!
Post by: irishroze on July 02, 2006, 10:21:37 PM
 :D ;D :D ;D
Yeah, I did it!  Thanks for all the help!!!
~irishroze :P
Title: Re: HELP!!! I followed the directions but no dice!
Post by: Mad Big Sausage on August 21, 2006, 11:21:39 AM
Had I seen this earlier I'd have sent you here (http://www.rockbox.org/twiki/bin/view/Main/PluginDice).

;)