Rockbox Technical Forums

Installation / Removal => Manual Installation => Apple - Installation/Removal => Topic started by: quorn23 on April 16, 2014, 05:02:09 AM

Title: Updated Rockbox (160gb) - now empty disc in Windows 8.1
Post by: quorn23 on April 16, 2014, 05:02:09 AM
Hi there,

yesterday i took the Rockbox Utility and updated my very old Rockbox Version (~ a year old) with the latest version.
Now when i hook up my iPod to my Pc (Windows 8.1) i only get a empty removable drive. I found a workaround (on head-fi.org)

Sadly this is not working for me. Anyone with a solution? I also have Windows 8.1 at home (at work atm) and i am afraid now that i don't have any possiblity anymore to access my iPod...


After installing Windows 8, my Rockboxed iPod Classic isn’t recognized any more!
Only an empty generic removable drive will show up when you plug it in.
1. Right click the 'Removable Drive', Properties, then Hardware tab
2. (Hopefully) you'll see your ipod, something like Apple ipod classic usb device listed under All disk drives. doubleckick it.
3. At the bottom of the Properties popup, click Change settings. There will be a new Properties popup. Choose the Driver tab.
4. Click Update driver > Browse my computer... > Let me pick from a list... > Choose 'Disk drives' and click Next. Click Next again.
You'll get a message that Windows successfully updated the driver.
The root folder of the ipod should pop up in the file explorer in a few seconds.
Title: Re: Updated Rockbox (160gb) - now empty disc in Windows 8.1
Post by: [Saint] on April 16, 2014, 09:13:04 AM
emCORE main menu -> Tools -> Run Rockbox fallback image

Report back success or fail.


[Saint]
Title: Re: Updated Rockbox (160gb) - now empty disc in Windows 8.1
Post by: quorn23 on April 17, 2014, 03:48:28 AM
emCORE main menu -> Tools -> Run Rockbox fallback image

Report back success or fail.


[Saint]

Hi,

First time i loaded the fallback image, plugged it my iPod and it crashed. Second time i rebooted with the iPod plugged in (emCORE - fallback) and it appeared for 30seconds (filesystem visible) and then it disappeared and window popped up with "usb device not recognized" error. Also i see constantly for a split second the "Sandglas" next to my cursor. Rebooted once again, now the device is visible (with failback image) but the sandglas issue remains. It's like it tries to recognize it still completely. 
Does this info help, or are there any kind of logs i may supply?
Title: Re: Updated Rockbox (160gb) - now empty disc in Windows 8.1
Post by: [Saint] on April 18, 2014, 08:05:42 AM
The only thing I could suggest at this stage is formatting the device storage partition using emCORE.

Doing so will force the disk into a known good state and cause emCORE to boot the Rockbox fallback image, which absolutely should work. It did in the past. This is entirely similar to the state it was in when you first installed emCORE.

If it were to fail to work now, after having done so in the past, this would point to a problem on your host (out of scope for support here), as nothing has changed with the fallback image that must have worked for you at least once.

Please keep in mind that anything on the disk you don't have backed up will be lost.


[Saint]
Title: Re: Updated Rockbox (160gb) - now empty disc in Windows 8.1
Post by: quorn23 on April 30, 2014, 02:53:38 AM
Hi Saint,


Will probably do so, as my emCORE version is probably outdated (as stated in first post, after a year ago i set the ipod up) and will retry.
My point is, with this old Rockbox version it was working fine, only thing i changed is updating Rockbox to the most recent version. Even with the fallback image i have troubles now. Is the fallback image also updated when i update Rockbox? If not i'm puzzled, as updating Rockbox the only chance was.
Title: Re: Updated Rockbox (160gb) - now empty disc in Windows 8.1
Post by: [Saint] on April 30, 2014, 08:58:31 PM
Even with the fallback image i have troubles now. Is the fallback image also updated when i update Rockbox? If not i'm puzzled, as updating Rockbox the only chance was.

No. The fallback image revision does not change.
The fallback image from a current build is identical to the fallback image in the build you updated from, and every other emCORE image since its inclusion.

If it suddenly stopped functioning this would seem to suggest a problem with the host or interconnecting hardware.


[Saint]