Rockbox Technical Forums

Installation / Removal => Manual Installation => Cowon - Installation/Removal => Topic started by: vitsch on May 22, 2006, 11:15:55 PM

Title: problems installing the bootloader
Post by: vitsch on May 22, 2006, 11:15:55 PM
Hi everyone
I have a major problem: I tried installing the bootloader on my iAudio X5v 60Gb, just as explained on this homepage (copy in FIRMWARE folder and plug it in to charge), but it doesn't update by itself, it just starts charging!!! I tried again and again without any luck - this drives me insane. Can please someone explain to me what I'm doing wrong, and what to do differently?
Thanks very much - I appreciate it
Vitsch
Title: Re: problems installing the bootloader
Post by: Llorean on May 22, 2006, 11:18:21 PM
Are you sure you've got an X5v, and not an X5L?
I didn't think the V was available in 60gb...
Title: Re: problems installing the bootloader
Post by: vitsch on May 22, 2006, 11:36:18 PM
I wasn't aware that there's a X5L (I just read about it and it really just holds a stronger battery, right?) Anyway I'm pretty sure now, that my device is an x5L, because of it's measurements.
The question remains however: What did I do wrong, or now better, is it not possible to install the bootloader (and therefore RockBox) on an x5L at this moment?
Thanks for the replies.

Vitsch
Title: Re: problems installing the bootloader
Post by: Llorean on May 22, 2006, 11:37:00 PM
You went wrong by using the X5V bootloader, when you should be using the X5 bootloader. X5L is an X5 with a larger battery.
Title: Re: problems installing the bootloader
Post by: uwbufu24 on August 07, 2006, 08:01:12 PM
I'm having the same problem as the original poster, but I actually used the correct bootloader.  It just goes to the charging screen.  I've read all the directions about ten times and can't figure out why it won't install.  For what it's worth, I have the same model, a 60 GB iAudio x5.
Title: Re: problems installing the bootloader
Post by: Llorean on August 07, 2006, 08:01:53 PM
Which bootloader file, specifically, did you use, and what exactly were the steps you took?
Title: Re: problems installing the bootloader
Post by: uwbufu24 on August 07, 2006, 09:13:19 PM
I used the standard x5 fw.bin file.  I did everything by the book as far as I can tell.  I did it wrong a couple of times and used the other bootloader file a couple of times, but then I took all the rockbox-related files off and followed the correct directions exactly as written. 

I especially paid attention to the part where you put the bootloader in the directory with the AC unplugged, then disconnect the USB from the hub and plug in the AC until the flash is supposed to upgrade itself.

Thanks for your speedy reply.  I don't know where I am going wrong.  What mistakes can be made so that the flash will not upgrade itself?
Title: Re: problems installing the bootloader
Post by: Llorean on August 07, 2006, 09:19:45 PM
And when you unplug and start the player, the bootloader doesn't load?
Title: Re: problems installing the bootloader
Post by: uwbufu24 on August 07, 2006, 09:22:02 PM
No, it charges to completion and when I turn it on or unplug and turn it on it just shows the Cowon splash screen and loads the traditional firmware.

Edit:  I'm going to try the latest beta firmware (which happen to install ok) and then try rockbox.
Title: Re: problems installing the bootloader
Post by: Llorean on August 07, 2006, 09:33:30 PM
Okay, so the FIRMWARE directory already existed on your player, and you just downloaded the x5_fw.bin (and kept it named exactly that) and copied it into the FIRMWARE directory, then turned off the player, removed the USB cable, and inserted the  charger, exactly in that order, and without doing ANYTHING else?
Title: Re: problems installing the bootloader
Post by: uwbufu24 on August 07, 2006, 09:36:55 PM
I just realized I'm a total retard and should not be allowed near computers, because I can't read and I saved the .htm file rather than the .bin .  I'm going to go stab myself.  Thanks for patrolling this mess of a thread bump.
Title: Re: problems installing the bootloader
Post by: Llorean on August 07, 2006, 09:41:14 PM
Hehehe. It happens. ;)
Title: Re: problems installing the bootloader
Post by: ion on December 25, 2006, 03:01:12 PM
Edit: Excuse me... i solved my problem.
Title: Re: problems installing the bootloader
Post by: canned soup on May 04, 2007, 09:03:16 PM
Well, I didn't.

I have the same symtpom but trying to load the OF instead.  I am runing the latest build and firm ware for the x5 and have the same problem.  When I finsh the loading, safetly disconnect with the power never on then plug in the power, it charges instead of loading.  

To make it interesting, I can load the rockbox boot loader FW again and again but OF won't try.  Could it be the size?

Wanted to convert back to OF since I have a RMA number for repairs.

Any thoughts?

thanks
dave