Rockbox Technical Forums

Third Party => Unsupported Builds => Topic started by: Debug on April 19, 2013, 03:21:02 PM

Title: iPod calssic 6 with emcore - no more USB support
Post by: Debug on April 19, 2013, 03:21:02 PM
Hi Gys

I Really love Rockbox on my iPOD classic 6 with emcore.  I loaded the original 2012 rockbox-ipod6g.zip - and its great.

But when I update to the latest version there's no more USB support - only a generic "USB mass storage device" which one cannot access :(

Why is this?  Am I doing something wrong?  The 2012 rockbox version is sooo buggy :(

Thanks
D
Title: Re: iPod calssic 6 with emcore - no more USB support
Post by: Gravylake on April 25, 2013, 03:30:51 PM
Same here.   I had the same problem months ago and thought I would try back again and see if they fixed it yet.  When I install the latest rockbox-ipod6g build, and connect to usb, it comes up as a generic "Removable Disk" with no contents.  I guess it's back to the buggy 2012 build :(
Title: Re: iPod calssic 6 with emcore - no more USB support
Post by: [Saint] on April 25, 2013, 05:57:37 PM
There's no need to revert to an older build just to maintain USB functionality. That is overkill. Besides . . . you'll miss out on features, fixes, etc.

The way to do this is to use a little bit of forethought and boot into the fallback image when you require USB disc access:

emCORE Main Menu --> Tools --> Run Rockbox Fallback Image

The iPod will now boot a fallback image giving you the very best chance of being able to mount over USB. Transfer the file(s) you need to transfer or do whatever it is you needed to do, and then reboot and go about your business as normal.



[Saint]
Title: Re: iPod calssic 6 with emcore - no more USB support
Post by: Gravylake on April 27, 2013, 05:32:07 PM
I didn't think of that... thanks, I'll give it a try.
Title: Re: iPod calssic 6 with emcore - no more USB support
Post by: Debug on April 29, 2013, 11:18:19 AM
Why not just add USB by default ?!

I restored my Ipod ... bleghhh
Title: Re: iPod calssic 6 with emcore - no more USB support
Post by: [Saint] on April 30, 2013, 09:19:14 PM
Well...I'm very sorry that you jumped to conclusions and restored your iPod, but that is not the fault of anyone here.

You also seem to be missing the fact that USB *is* "added by default" and works for more people than it fails. Additionally, emCORE provides a fallback image for just this very case - we cannot dual-boot on this device presently, so using the Apple OF's Disk Mode feature is out of the question.

However, due to the fact that this is a work in progress and currently classed as an unusable port there should be no expectation that any feature will work as intended and you as a user knowingly took this risk when you installed it.


[Saint]