Rockbox Technical Forums

Support and General Use => User Interface and Voice => Topic started by: bobtatersaladsmith on September 27, 2011, 05:39:00 PM

Title: Clip+ wont connect to my pc any more.
Post by: bobtatersaladsmith on September 27, 2011, 05:39:00 PM
Things have been great with my clip+. Installation and everything else has been successful. Everything has worked great until now. I went to remove/add new songs, and when I plugged it in via usb, it would not connect. Instead of going to the connect/writing screen it turns on with the original hardware and starts charging. I have done nothing differently since the last time that I transferred songs and now it will not properly connect. I am at a complete loss.

Using the most recent version of rockbox. Did I leave anything out? Post in the wrong place? I am new :/
Title: Re: Clip+ wont connect to my pc any more.
Post by: bertrik on September 28, 2011, 03:35:55 AM
It's normal that rockbox boots to the original firmware to do USB transfers, because USB transfer not work completely right for this player on rockbox yet.
Rockbox should have no effect on USB transfer in the original firmware, so if that's not working, there could be a hardware or USB connection issue.

Are you sure it's really charging? Perhaps the original firmware is just refreshing its internal database (that also has a progress bar kind of thing)?
From experience I know that the original firmware is not responsive over USB when the database refresh is in progress. In that case, just wait a bit until the refresh is done. To shorten the database refresh, it helps to remove the uSD card from the player.