Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: richdebc on October 27, 2010, 02:57:14 PM

Title: Sansa clip v1: can't use MTP after uninstalling rockbox
Post by: richdebc on October 27, 2010, 02:57:14 PM
I'm not sure if this is the right forum, but I've got a strange problem. I tried to install rockbox, it didn't work (said there was a file missing, and to connect via usb) so I uninstalled it. My clip works fine again except that it will only connect in MSC mode (regardless of whether I set ti to connect in MTP, MSC or Auto mode). I don't know if this is a recognised problem, or if anyone has any ideas what to do? All my files are stored via MTP, and I'd prefer not to lose them if possible.

Cheers,

Richard
Title: Re: Sansa clip v1: can't use MTP after uninstalling rockbox
Post by: saratoga on October 27, 2010, 03:01:50 PM
I'm not sure if this is the right forum, but I've got a strange problem. I tried to install rockbox, it didn't work (said there was a file missing, and to connect via usb) so I uninstalled it.

FWIW this means you stopped the installation half way through and put a bootloader but not rockbox on your player  (see the manual if you need the install directions).

My clip works fine again except that it will only connect in MSC mode (regardless of whether I set ti to connect in MTP, MSC or Auto mode). I don't know if this is a recognised problem, or if anyone has any ideas what to do? All my files are stored via MTP, and I'd prefer not to lose them if possible.

This is probably an issue with your computer's MTP driver.  I would try another PC.  But bugs in Windows or the OF aren't on topic here so until you actually install rockbox, you should probably go ask for help on the sandisk forums.