Rockbox Technical Forums

Rockbox General => Rockbox General Discussion => Topic started by: Tchno on October 22, 2010, 04:29:08 AM

Title: Sansa Fuze V2 Startup Issues
Post by: Tchno on October 22, 2010, 04:29:08 AM
After buying my Sansa Fuze a little less than a year ago, I came across the Rockbox community, and thought it would be interesting to see how it worked.  ::)

However, to my dismay, when I tried to install it onto my device, the logo showed on the screen upon startup, but that is all I got out of it.  :-\

I have spent many hours on the IRC chat, trying to obtain troubleshooting for this, and after many hours of redoing and even having builds hand-crafted for me, I never got past that logo page.  ???

If anybody who is Sansa savvy is willing to provide insight onto this, please let me know.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on October 22, 2010, 10:54:18 AM
No one named Tchno has been on #rockbox, so you're going to have to provide a link to the chat logs if you want anyone to know what happened.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: gevaerts on October 22, 2010, 10:56:17 AM
No one named Tchno has been on #rockbox, so you're going to have to provide a link to the chat logs if you want anyone to know what happened.
http://www.rockbox.org/irc/log-20101021#09:59:07 ?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on October 22, 2010, 10:58:22 AM
Ah its todays logs, which I guess have been indexed by search yet. 

Edit:  I see in the logs that you originally tried to install rockbox for a different player on your device.  What happens if you format the player in the OF, then do a full reinstall in rockbox utility?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Tchno on October 23, 2010, 03:28:46 PM
I did a full reformat, and installed the correct version.
It still, however, did not load, just stuck on the logo screen.

http://www.rockbox.org/irc/log-20101021
http://www.rockbox.org/irc/log-20101022

Those were the days I was on.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Tchno on October 28, 2010, 01:39:11 AM
Anybody have any suggestions? Still not sure what's wrong exactly.

Bootloader works, as the title screen comes up, but all the versions of rockbox I have tried have not worked thus far.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: mc2739 on October 28, 2010, 06:11:44 AM
Do you have a microSD card in the slot? 

If yes, try removing it to see if you can then boot properly.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Tchno on October 28, 2010, 11:37:42 PM
I don't have a microSD card, anything else you can think of that could be wrong?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Isaac on November 04, 2010, 02:50:16 AM
exactely the same problem here. (Fuze V2 8GB)
i have installed with and without SD card in the sansa
i have removed all music files before install
no success
after rockbox start, i see the yellow logo and the player freezes, cant turn off, i have to reset
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Matoridi on November 04, 2010, 11:23:24 AM
Same here.

I've got a Sansa Fuze V2, and I just installed RB 3.7. Installation goes fine, but when I try to boot with RB, the splash screen appears but it stays there forever.

- I tried uninstalling everything (including the hiden .rockbox directory), installing the Sansa 2.03.033 firmare, then install automatically RB3.7, same result;

- I tried the same thing exept installing manually RB 3.7, same result;

- I tried installing fw 2.03.026, automatic installation of RB 3.7, same result.

Anyone has succeded?

Meanwhile, I'm going to revert to the previous version...

Stable port?  I seriously doubt it.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: evilnick on November 04, 2010, 11:54:06 AM
It's kinda difficult to fix bugs like this if the relevant devs aren't having the same issues.

Quote
Stable port?  I seriously doubt it.

Isn't helpful either.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on November 04, 2010, 11:54:30 AM
Can you figure out which revision broke it?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: sss on November 04, 2010, 06:21:19 PM
Running 28424 on a couple V2 fuzes and not having any problems except no USB connectivity in rockbox.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: mc2739 on November 04, 2010, 06:36:24 PM
Running 28424 on a couple V2 fuzes and not having any problems except no USB connectivity in rockbox.

Rockbox USB connectivity is not really a problem, it is disabled until it is considered to be stable.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Matoridi on November 04, 2010, 07:59:28 PM
It might not be helpful to say that 3.7 is not stable on Fuze V2, but it is still true, and you should not indicate that is stable.

I tried the official Release from Rockbox site, the same installed with the utility (in Windows and Linux);

I tried yesterday's daily build (is it really refreshed daily?);

I tried using the last fw from sansa 2.0.03.33 and an older one 2.02.26.

I tried starting from fresh, erasing everything, reinstalling the sansa fw, then the rockbox software and bootloader.

The result is always the same.  The player works well in its native Sansa system, and it hangs on startup in Rockbox.

Funny things, sometimes the player starts, but if I shut it down and power it up again, it goes back to hanging...

If you have constructive suggestions, I would happy to try them.


 
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Chronon on November 04, 2010, 09:25:22 PM
It is possible that there is an undocumented hardware revision.  At least this might explain why some units seem to have a problem booting and others have no problems with the same firmware.

saratoga already asked people to find which revision introduced the problem.  This would be a great place to start.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Matoridi on November 04, 2010, 09:39:33 PM
Well, I was not doing daily updates before.  It all worked with the previous 3.6 release, although the radio was not always functional ...

Frankly, I'm beginning to wonder whether there is a hardware defect related to this problem...  The sansa firmeware also has problems with the radio in my case.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: AlexP on November 05, 2010, 05:27:58 AM
This is what stable means:

http://www.rockbox.org/wiki/TargetClassifications

And yes, it meets those criteria.  The vast majority of fuzes do not have the problem yours has, and none of the developers with a fuze has this problem.  This makes it rather hard to fix.  Someone with a problem fuze needs to do a binary search to find which revision introduced the problem, without this nothing can be done.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Matoridi on November 05, 2010, 07:08:01 AM
I'd like to help, but I have no idea how to proceed to do a binary search...

Meanwhile I am investigating the possible hardware problem.  I'll comment here as things develop.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: AlexP on November 05, 2010, 08:28:57 AM
A binary search is the quickest way to find the problem revision, as described here: http://en.wikipedia.org/wiki/Binary_search_algorithm

Basically if you know that revision x works and revision z doesn't, then try revision y half way between them.  If that one works, now try half way between y and z.  Very quickly you home in on the problem revision.  To do this you need a build environment set up so you can build old versions of Rockbox.

Until someone with the problem does this, it won't/can't be fixed.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Matoridi on November 05, 2010, 10:15:20 AM
Simply said, I would have to find which revision creates the problem.

Isn't there no archive of the old built versions of RB?  I guess not, since you're mentioning the necessity to build these versions.  Sorry, but I don't have the time to learn how to this...


Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on November 05, 2010, 10:39:32 AM
Works for us, one less problem we have to fix ;)
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Matoridi on November 05, 2010, 11:11:31 AM
If it's a hardware problem, then ok, it's not yours to solve.

But if my hw problem is solved and sansa and I still can't use rb, it's still a problem, even if decide to abandon using this firmware.

We'll see...
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Isaac on November 05, 2010, 11:15:29 AM
First, as i said before, i have the same problem.

so, forgive me if i am inquire, my english is not really that good, so i want to be sure.

as far as i understand now, i can try to install an older version of RB from here:
http://download.rockbox.org/bootloader/sandisk-sansa/

and if this works, we are one step further?

but i have to install manually? mean there is no installer or so?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: gevaerts on November 05, 2010, 11:53:27 AM
Has anyone who's having this problem successfully reverted to a previous version?

Can you try checking the filesystem?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Isaac on November 05, 2010, 12:08:07 PM
i am sorry, please dont think i am an idiot (maybe i am), but what you mean with "check the filesystem"

i am not an technician, but if you give me a kind of "checklist" i will follow step by step

EDIT:
if you mean chkdsk, there is no problem

C:\Windows\system32>chkdsk /x g:
Der Typ des Dateisystems ist FAT32.
Volume SANSA FUZE erstellt 01.01.1980 00:00
Volumeseriennummer : 0123-4567
Dateien und Ordner werden überprüft...
Die Datei- und Ordnerüberprüfung ist abgeschlossen.
Das Dateisystem wurde überprüft. Es wurden keine Probleme festgestellt.
    7.729.280 KB Speicherplatz auf dem Datenträger insgesamt
           64 KB in 2 versteckten Dateien
          800 KB in 25 Ordnern
      290.624 KB in 44 Dateien
    7.437.728 KB sind verfügbar

       32.768 Bytes in jeder Zuordnungseinheit
      241.540 Zuordnungseinheiten auf dem Datenträger insgesamt
      232.429 Zuordnungseinheiten auf dem Datenträger verfügbar

C:\Windows\system32>
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on November 05, 2010, 12:36:48 PM
as far as i understand now, i can try to install an older version of RB from here:
http://download.rockbox.org/bootloader/sandisk-sansa/

and if this works, we are one step further?

but i have to install manually? mean there is no installer or so?

Those are bootloaders, not rockbox.  We don't provide older builds for your player, so you'll have to compile them yourself.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Isaac on November 05, 2010, 12:45:50 PM
, so you'll have to compile them yourself.
i am afraid thats the point where i must give up and hope somebody else here can do this
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Chronon on November 05, 2010, 01:35:15 PM
There are instructions in the docs index on how to set up a build environment, check out a given revision of the code and compile it.  It may seem foreign right now, but if you go through the information step by step you should be able to get everything set up without much trouble.

Some links to get anyone who is interested in testing started:
http://www.rockbox.org/wiki/SimpleGuideToCompiling
http://www.rockbox.org/wiki/UsingSVN

If you are interested in trying to set up an environment for compiling and help track down this issue then you can start a new topic in the compiling subforum.

The simple fact is that only those people who experience a bug can do the testing.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Isaac on November 05, 2010, 01:46:54 PM
thank you for your belive that i am good enogh to do this.
but i am old on years, english is not my language, and i am a kind of... i think you say in english "digital immigrant"  :P

i need RB for the voice menu, my eyes are not so good anymore.

anyway, i will try to follow the hints you wrote here.

Thanks
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Nichlas on November 07, 2010, 04:53:43 AM
I tried to update to 3.7 today, and are having the same problem.
Ill try a previous build and see if that fixes the issue

-> OK I'm back on build r25904-100508 but i had to change to an earlier version of mkasmboot to.
Otherwise i got the whitescreen loop. It still says that its version 1.4 but something must have changed cause the new one just wouldn't work.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: pedalhead on November 08, 2010, 08:02:16 PM
Having the same problem here.  I have a Fuze V2 that I Rockboxed about 2 weeks ago...worked great untill a few day ago...stops at the Rockbox screen, I have to wait untill the battery dies before I can try anything.  I have updated rockbox but same thing.  The only thing I recall doing before this happened was running "Battery Bench" program to test batteries..not sure if that has something to do with my problem.   Now tho only way to use my Fuze is to load into original firmware...if I forget to hold the left key in, I have to wait for batteries to die and try again.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on November 08, 2010, 08:05:08 PM
You can reboot a crashed fuze by holding the power button for about 30 seconds.  Once you're in the original firmware, try checking the disk for errors and/or reformatting it.  It sounds like the file system is corrupt.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Nichlas on November 10, 2010, 01:43:32 PM
Strange, after charging the player to full, Rockbox 3.7 boots! :)
And now it wont boot again :(

Thanks for all the hard work, rockbox is superior!

/Nichlas

OK, i can get rockbox to boot each time, by plugging in the USB-cord during boot up.
Any ideas?
..Nope that only workes sporadicly too.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Super_Dork_42 on November 12, 2010, 01:05:48 AM
Yeah, I have the same problem. I have sent an email to the dev mailing list offering to send my Fuze to a dev if it would help find a solution, since the biggest problem to finding a solution seems to be that no dev has access to a player that is afflicted. I'll post the response once I get one. I wish there was a list if all devs, listed by country and timezone. That way we with problems could email them directly.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: torne on November 12, 2010, 05:03:14 AM
It's much better to email the dev mailing list, which we are all subscribed to... contacting lots of people individually is less useful and less desirable (not everyone wants to be bothered with stuff).
Title: Re: Sansa Fuze V2 Startup Issues
Post by: crescentfresh on November 12, 2010, 10:43:35 AM
Is it normal that during the rockbox bootup, I get a screen that says I'm on version 3.0, then it changes to another screen that says 3.7?  I'm having no problems playing files at all, but have never seen that behavior on other devices I have rockbox on before, so I'm curious.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on November 12, 2010, 10:47:28 AM
Is it normal that during the rockbox bootup, I get a screen that says I'm on version 3.0, then it changes to another screen that says 3.7? 

IIRC it actually says "bootloader ver. 3.0", which is just the bootloader you're running.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: crescentfresh on November 12, 2010, 11:08:49 AM
Cool, thanks for clearing that up for me.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Tchno on November 16, 2010, 01:05:48 AM
I recently tried installing version 3.7 of rockbox onto my sansa, however, it is still stuck on the rockbox bootloader screen, and will not go any farther.

I have: reformatted the player, taken out all microSD cards

Any idea why mine still ceases to work?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: mc2739 on November 16, 2010, 07:35:52 AM
It is possible that there has been a minor hardware change that needs to be addressed with the Rockbox firmware.

This will not be easy to fix unless a developer gets a Fuze that is experiencing this failure.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: AlexP on November 18, 2010, 03:26:30 AM
Yeah, I have the same problem. I have sent an email to the dev mailing list offering to send my Fuze to a dev if it would help find a solution, since the biggest problem to finding a solution seems to be that no dev has access to a player that is afflicted. I'll post the response once I get one. I wish there was a list if all devs, listed by country and timezone. That way we with problems could email them directly.

By the way, no such email has been sent to the dev list.  Did you subscribe to it before sending?  It won't work if you didn't.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Super_Dork_42 on November 18, 2010, 04:48:54 PM
My email address is different than my username. And I got a response from Michael Chicoine about it. He worked on the V1 port and is interested, so I'm going to send him my player. Maybe we can finally have an answer to this problem.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: pedalhead on November 18, 2010, 09:15:19 PM
Waiting on results..I'm  having same issues with my Fuze V2.  I have been running my original Fuze firmware for the last 2 weeks.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Dec on November 19, 2010, 07:14:32 PM
I have been reading both the Sansa support forums and the RockBox forums since before I bought my first Fuze. So far, the OF on the V2 Fuze gives me exactly what I need, no more and no less, so I have been lazily waiting for RB on Fuze to get more stable before installing it.

I recently got a second Fuze V2 (possibly the last ever retail Sansa Fuze in Ireland), as the price was too low to ignore, even without the 10% off for "non-pristine" condition (it was the last one in the shop, but thanks to the non-standard USB cable it was also the least shop-stained player on the shelf), and so I'll probably try RockBox on one or both of them. If I do have an "afflicted" Fuze or I manage to brick it, at least I'll have the spare Sansa USB cable for the other one. Hopefully I'll be able to build older RB versions and help other owners of "afflicted" Fuzes to know what older version to run.

The supplied OF version on my new Fuze is different, and the retail packaging was completely different (with a different copyright year). I haven't done any firmware upgrades yet.

Has anyone asked SanDisk about this possible minor hardware change? They support FLAC in the OF (unlike most manufacturers), and they seem to be quite friendly to RockBox, or at least they are not outright hostile to it...
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on November 19, 2010, 07:20:50 PM
Has anyone asked SanDisk about this possible minor hardware change? They support FLAC in the OF (unlike most manufacturers), and they seem to be quite friendly to RockBox, or at least they are not outright hostile to it...

You're probably about the 10000th person to suggest this, but no, they don't give out information about their players.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Super_Dork_42 on December 03, 2010, 01:03:31 AM
Michael Chicoine, a dev in Texas, has my Fuze. He's working on it. I'll post updates as I receive them. Go to my thread for the updates.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: mc2739 on December 03, 2010, 07:21:17 AM
I have opened a bug report for this issue here: FS#11791 (http://www.rockbox.org/tracker/task/11791)
Title: Re: Sansa Fuze V2 Startup Issues
Post by: rianon on December 05, 2010, 02:46:20 PM
When you install complains that the wrong version.
my version: 02.33.33F
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on December 05, 2010, 03:00:03 PM
When you install complains that the wrong version.
my version: 02.33.33F

That means you either downloaded the wrong firmware file, or told the installer you had a different player then you actually have. 
Title: Re: Sansa Fuze V2 Startup Issues
Post by: rianon on December 05, 2010, 04:06:42 PM
f you install without the boot, there is no load Rockbox. If a boot that says that is not the firmware.
[ERR]  Original firmware unknown, please try an other version. Tested Fuzev2 versions are : 2.01.17, 2.02.26, 2.03.31, 2.03.33

Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on December 05, 2010, 04:13:21 PM
[ERR]  Original firmware unknown, please try an other version. Tested Fuzev2 versions are : 2.01.17, 2.02.26, 2.03.31, 2.03.33

That means you didn't provide it with a valid fuzev2 firmware.  Go back to the sandisk site and download one. 
Title: Re: Sansa Fuze V2 Startup Issues
Post by: rianon on December 05, 2010, 04:18:42 PM
Find a theme to my problem, but found no solution ...
http://forums.rockbox.org/index.php?topic=25068.0
I tried to revert to the old firmware 31, did not help the system will not start.

Post Merge: December 05, 2010, 04:30:55 PM
Спасибо, после очередных манипуляций с шаманским бубном все удалось запустить. Сработала  скачанная родная прошивка.  :) :)

Post Merge: December 05, 2010, 04:31:24 PM
Thank you, after the next manipulation shamanistic tambourine all failed to start. Fired downloaded native firmware.  :) :) :)
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on December 05, 2010, 04:44:12 PM
Find a theme to my problem, but found no solution ...

No thats not your problem because it was fixed ages ago.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Nichlas on December 29, 2010, 04:38:49 PM
I have followed the bug report on this problem and it seems that i have a problem with a defective radio to.
It wont work in OF, and thus the cause of rockbox hanging seems to have been identified.
However before the bootloader changed to be able to work with the new rockbox the radio worked fine.
Might there be a problem with the new bootloader and some fm-chips? Or alternatively a lot of radiochips are failing.
Can someone suggest a way to investigate further?

Thanks for all the hard work
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on December 29, 2010, 04:55:29 PM
However before the bootloader changed to be able to work with the new rockbox the radio worked fine.
Might there be a problem with the new bootloader and some fm-chips? Or alternatively a lot of radiochips are failing.
Can someone suggest a way to investigate further?

Patch an old bootloader (or even just an unmodified sandisk firmware) and see if the radio starts working again.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Nichlas on December 30, 2010, 02:27:09 PM
Thanks for the idea.
Tried an old sansa firmware, and the radio refuses to work.
So it seems as if the FM-chip has gone bad for me and several others.
Maybe others with the freeze problem can test and see if there radio works in OF?
And if others have the same problem, maybee there is a way to make rockbox boot without the radio?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: saratoga on December 30, 2010, 02:37:43 PM
And if others have the same problem, maybee there is a way to make rockbox boot without the radio?

You can probably disable initializing the FM radio by commenting out the line "#define CONFIG_TUNER (SI4700|RDA5802)" and maybe the line with "SRC_CAP_FMRADIO" in firmware/export/config/config-fuzev2.h.  No idea if that'll actually fix the startup problem though.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Nichlas on December 30, 2010, 03:28:26 PM
thanks, will set up a new build enviroment  and try next weekend.
Happy new year in advance!

I now have my own working build of rockbox.
I used the trick the guy mc2739 did in his bug report.
Seems like rockbox cant handle a bum fm-chip.

Thanks for the help and support!
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Misha on January 05, 2011, 03:27:43 PM
thanks, will set up a new build enviroment  and try next weekend.
Happy new year in advance!

I now have my own working build of rockbox.
I used the trick the guy mc2739 did in his bug report.
Seems like rockbox cant handle a bum fm-chip.

Thanks for the help and support!


Could you possibly upload this build? I'm having the same issue.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Nichlas on January 05, 2011, 03:39:21 PM
Sure, pleas tell if it works.

http://ul.to/yo57v9

Regards

Nichlas
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Misha on January 05, 2011, 03:53:46 PM
Sure, pleas tell if it works.

http://ul.to/yo57v9

Regards

Nichlas

Works like a charm! First time I've been able to get into Rockbox in months! Thanks a ton, everyone.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Nichlas on January 06, 2011, 04:12:45 AM
Great to hear it works.

Something strange happend since disabeling the rockbox radio, now the radio works fine in OF!
Why?
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Chronon on January 06, 2011, 06:09:13 PM
It sounds like an observation that should be shared on the bug report.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: Misha on July 10, 2011, 03:53:20 AM
Has this problem since been fixed in official Rockbox builds? I've been using that test build since it was uploaded and have been a little afraid to update.
Title: Re: Sansa Fuze V2 Startup Issues
Post by: [Saint] on July 10, 2011, 06:53:19 AM
Has this problem since been fixed in official Rockbox builds?

Yes, as of r29378~9 ( 3.8 )


[St.]