Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: some-xtc on July 27, 2010, 05:21:04 AM

Title: Sansa AMS: Musepack (SV8) issue?
Post by: some-xtc on July 27, 2010, 05:21:04 AM
Hello Guys,

I've already opened a task here:
http://www.rockbox.org/tracker/task/11476

My assumption is that this is a Sansa AMS specific problem, because it only occurs on my two rockboxed Samsas (and not on a e260v1 or M:robe 100 for example).
If this is true (hopefully some of you could check this with other models), then it should be at least mentioned in the wiki.
Title: Re: Sansa AMS: Musepack (SV8) issue?
Post by: some-xtc on July 31, 2010, 10:47:18 AM
No suggestion?
No one can reproduce this bug?
(try this samples: http://samples.mplayerhq.hu/A-codecs/musepack/sv8/ )

I think, this is a quite serious issue, because FuzeV1 was promoted on 3.6 to stable with SV8 ...
Title: Re: Sansa AMS: Musepack (SV8) issue?
Post by: AlexP on July 31, 2010, 07:34:45 PM
I doubt many people use musepack to be honest.  While we of course want to eliminate bugs, I wouldn't put this at the top end of serious :)
Title: Re: Sansa AMS: Musepack (SV8) issue?
Post by: some-xtc on August 01, 2010, 05:34:57 AM
Well, a changelog is like a promise :D


I can understand, that this is not at the top end, but - like I already said - this should be at least mentioned in the wiki (if my assumption is true):
http://www.rockbox.org/wiki/SansaAMS#Specific_problems
Title: Re: Sansa AMS: Musepack (SV8) issue?
Post by: Chronon on October 02, 2010, 12:49:42 PM
This was just committed and the bug report is now closed:
Quote
r28197: Finally fix FS #11476 (data abort when playing some sv8 mpc files on lowmem targets like Clip+/Fuzev1/Fuzev2). This fix disables loading of seek tables from the sv8 bitstream. Those table are located at the end of sv8-files. When playing sv8 files this resulted in seek to filebegin, then fileend, then back to filebegin. Such seeking behaviour results in heavy rebuffering when playing files on targets with low RAM.

Posting this for those who find this topic via a search, since some-xtc got the news of the fix already via the Flyspray task.
Title: Re: Sansa AMS: Musepack (SV8) issue?
Post by: florin on October 03, 2010, 02:41:14 PM
I'm too having a problem with Musepack, but with SV7. I hope it's ok to post here though.

So, the problem is with Clip+ only (Fuze v1 seems ok): when a SV7 mpc file ends and the next song uses a different codec I get "Codec failure" and the song is skipped. The next song, whatever the codec (even the same as the skipped one) plays just fine - the transition is smooth. SV8 is OK, no "codec failure". The skipped song is ok, it plays just fine if I play it manually, or if I change the playlist so that it's not after a SV7 MPC. A few examples:

MPC SV7 >> plays
MPC SV7 >> plays
OGG /FLAC/MP3 >> codec failure
OGG /FLAC/MP3 >> plays

MPC SV7 >> plays
MPC SV8 >> plays
MPC SV7 >> plays

MPC SV8 >> plays
OGG/FLAC/MP3 >> plays
OGG/FLAC/MP3 >> plays

I've tried resetting configuration, formatting the player & reinstalling Rockbox, nothing seems to help. It's the same on internal memory as on microSD. It only happens when the SV7 MPC is on the microSD, the next song doesn't matter where it is.

LE: formatting the card seems to have fixed the problem.
Title: Re: Sansa AMS: Musepack (SV8) issue?
Post by: saratoga on October 03, 2010, 03:03:25 PM
Open a ticket on the bug tracker.  Its much less likely to be noticed here then on the tracker since most people don't follow the forums that closely.

Also, make sure to list which version of rockbox you tested when filing a bug report.