Rockbox Technical Forums

Installation / Removal => Manual Installation => Apple - Installation/Removal => Topic started by: jimbob on September 29, 2008, 10:48:57 PM

Title: Ipod 5.5g 80gig, rockbox 3.0, sncviewer
Post by: jimbob on September 29, 2008, 10:48:57 PM
Alright, new to the rockbox but have been using media monkey along with miniyrics for a while and love it.  Stumbled upond the rockbox and can't wait to get it all set up on my ipod. 

Anyways, the problem is that i have used the rockbox utility and installed the complete new build, downloaded the sncviewer.rock from http://yxz0123.yx.funpic.de/rockbox/build/  and loaded a song along with the .lrc file in the E:/ directory next to .rockbox, but when going to sncviewer in apps i get the "invalid model error"   

I have looked into compiling my own build using colinux, but i have been slightly lost.  i've also looked at unsuported builds and adding the sncviewer.rock manually but still get the same error.  Not sure if there is a differnent .rock file i can download or perhaps try using the 2.5 version of rockbox.

Any help is awesome cuz i can't wait to get this all set up.
Title: Re: Ipod 5.5g 80gig, rockbox 3.0, sncviewer
Post by: Llorean on September 29, 2008, 10:51:29 PM
Please don't use things like "cuz" here, as they won't translate if our non-native users try to read your posts. This is covered in the forum guidelines.

.rock files have to be compiled directly against the version you're using. That means the one you downloaded won't work unless it was compiled for your player, for a version near enough to 3.0.

You'll basically need to learn how to compile for yourself if you want one that's sure to work.
Title: Re: Ipod 5.5g 80gig, rockbox 3.0, sncviewer
Post by: jimbob on September 29, 2008, 10:59:13 PM
Yeah, that's what I gathered, but the site had a .rock file supposedly for the ipod video, although there wasn't a difference between the 30 or 60/80g. I'm guessing that it must not be close enough to version 3.0 as the current instructions state to place sncviewer.rock into the .rock/rocks folder and not .rock/rocks/apps.  Will probably try using the 2.5 download of rockbox and see if that solves anything.  Just wasn't sure as the error turned back was "invalid model"

Title: Re: Ipod 5.5g 80gig, rockbox 3.0, sncviewer
Post by: Llorean on September 29, 2008, 11:03:15 PM
There is no 2.5 download for the iPod 5G. 2.5 was only released for the Archos targets.
Title: Re: Ipod 5.5g 80gig, rockbox 3.0, sncviewer
Post by: jimbob on September 29, 2008, 11:06:04 PM
Ah, I remember that now.  Well, thanks for the help, looks like i'll start looking at how to compile this thing.  I suppose i have been looking for some excuse to get into linux.  Next is the MyBook World in my closet.
Title: Re: Ipod 5.5g 80gig, rockbox 3.0, sncviewer
Post by: GodEater on September 30, 2008, 04:09:01 AM
Linux isn't a requirement for building Rockbox - it builds fine under cygwin (windows) and Mac OSX.