Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: AustinMarton on June 06, 2008, 11:35:35 PM

Title: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 06, 2008, 11:35:35 PM
Hi there, I have been trying to install Rockbox on my ipod photo 40gb (bought for this purpose). It is formatted to fat32, and the install has worked fine, but the colours are all wrong.
It looks like trying to display a picture with higher resolution than the monitor.

The colours are also wrong in Rockboy, instead of monochrome it's orange and black and white, it's kind of inverted looking. I have tried a number of different skins and the basic ones display fine (blue background black text) but no pictures or icons display correctly. Is there another version of Rockbox for ipod photo I could try? An older build? I tried to use the grayscale ipod version but it says bad checksum.

Any help or suggestions you can give will be much appreciated, I really hope I can use this instead of the apple firmware :D

Thanks,
Austin.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Chronon on June 07, 2008, 01:04:16 AM
I would try extracting a fresh build.  Apparently it's not displaying bitmaps properly, but I don't know why this should happen.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 07, 2008, 01:15:45 AM
Hi thanks for the quick response. What do you mean by a fresh build? Do I need to compile from source? I've got the latest version of rockbox from the website.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Chronon on June 07, 2008, 01:38:15 AM
It's possible that some corruption occurred due to a bad extraction.  I don't really have a good explanation for what you're seeing.   Still, I think it's worth redownloading the current build and doing a fresh extraction to your player just to eliminate that possibility.

Does the Jpeg viewer work properly?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 07, 2008, 02:10:05 AM
Okay I have tried extracting and reinstalling and no luck (even on a different computer). The jpg viewer works but has the same issues with colours. Is there somewhere you can change the LCD screen type in the theme config files or something?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: MarcGuay on June 07, 2008, 08:54:06 AM
I hate to ask, but have you checked to see if the problem exists in the Apple firmware as well?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 07, 2008, 05:53:59 PM
That's a fair point but yes I have checked and the colours work perfectly in the apple firmware.

I'm just trying to backup all the music off it now so I can try install ipodlinux and see if I still get the same problem, but this is taking a while since my ipod seems to unmount itself once I've copied about a gig.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Didgeridoohan on June 09, 2008, 04:03:30 AM
Okay I have tried extracting and reinstalling and no luck (even on a different computer).

But did you download a fresh copy? Might be that you have a bad copy...
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 09, 2008, 08:43:51 PM
Yep I have downloaded various fresh copies, even tried an older build but it did not behave any differently. :(

The ipodlinux website has been down for days and so I can't install that to see if it has the same problem! Could reformatting the ipod with the apple firmware updater thing be wise?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: yapper on June 09, 2008, 09:01:38 PM
Going back to your original post, you said
Quote
"The colours are also wrong in Rockboy, instead of monochrome it's orange and black and white, it's kind of inverted looking. I have tried a number of different skins and the basic ones display fine (blue background black text) but no pictures or icons display correctly."
That makes me think that your problem is related to either a bad WPS/theme or incorrect installation. If you can post a sample screendump, it may give someone a clue what is going on. This explains how to capture a screendump: http://www.rockbox.org/twiki/bin/view/Main/ScreenDump
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Chronon on June 10, 2008, 01:54:22 AM
Yes, a screen dump will give us something concrete to look at.  But I don't think it has to do with any broken theme.  It sounds like all image rendering is broken, as the user mentioned that the Jpeg viewer also suffers from the same defects.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: bascule on June 10, 2008, 02:09:25 AM
It's a long shot, but try looking at the setting:

Settings > General Settings > Display > LCD Settings > LCD Mode

If it is set to 'Inverse', then that's your problem...
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Didgeridoohan on June 10, 2008, 04:52:28 AM
Correct me if I'm wrong, but doesnt the LCD Mode only exist for players with a monochrome LCD? I know I don't have it on my H340 (only for the remote).
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: bascule on June 10, 2008, 06:16:03 AM
Well, I have it on my Sansa e200 and it does what it says on the tin, it just simply inverts all colours; menus, icons, WPSs, Album Art etc.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 10, 2008, 09:54:12 PM
Settings > General Settings > Display > LCD Settings > LCD Mode
Nope I don't have LCD mode in that menu.

I took a screenshot using the method described but asoundingly, it comes out looking perfect!? :S So I guess rockbox thinks its sending the right thing to the screen?
(http://boyle.austin.googlepages.com/11June_Rockboxdump1.bmp)
(http://boyle.austin.googlepages.com/11June_Rockboxdump3.bmp)

I will take some photos to show how it actually looks when I get home, but the ipod firmware still displays all colours and pictures perfectly, so I know the screen definitely is not broken.

Thanks again for your continued help everyone :)
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: bascule on June 11, 2008, 03:56:09 AM
Mmm... interesting!

I'm kind of struggling now, but if the screendumps are OK, then the screen image in memory must be OK and it is getting scrambled between there and the hardware, but we know the hardware's OK, because the OF works, so, with my limited knowledge, that leaves the actual LCD driver or some other intermediary as the culprit.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 11, 2008, 06:13:33 AM
Okay here are the photos of what the screen looks like:
(http://boyle.austin.googlepages.com/IMGP0390.JPG)
(http://boyle.austin.googlepages.com/IMGP0391.JPG)
(http://boyle.austin.googlepages.com/IMGP0392.JPG)
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: pixelma on June 11, 2008, 06:28:45 AM
The photos are quite helpful so you not have to guess how it looks like... :)
Could you check the following: in the "Debug" menu > "View HW Info", look for the "LCD type:" line and tell us the number behind it?

You may also have more luck finding someone with the right knowledge if you join in in IRC (see left hand side menu), not all developers read the forums regularly. I already tried to draw someone's attention to this with an half-educated guess which led to my question (something along the lines of what bascule said). Many developers are in Europe and usually the best time to catch someone is during the European evening hours.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 11, 2008, 04:48:47 PM
HW info:
Quote
HW rec: 0x00060000
LCD type: 0
PP version: PP502E

Thanks I will try check out the IRC, will post here if it reveals any developments.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: amiconn on June 12, 2008, 01:10:45 AM
I've just committed some missing init code for iPod Photo gleaned from ipodlinux that hopefully fixes the colour problem. Please install a current build of r17715 or later, and try again.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 12, 2008, 01:22:57 AM
Hi there, I've just installed the current build (rev17715-080612) and it hasn't changed the problem. Thanks for your effort still.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: linuxstb on June 12, 2008, 02:12:55 AM
AustinMarton,

Out of curiousity, which version of the Apple firmware is running on your ipod?  (I think you can find out by looking somewhere within the Settings menu in the Apple firmware).  Have you ever upgraded it since your first bought the ipod?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Llorean on June 12, 2008, 12:42:18 PM
Does he need a new bootloader too?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 12, 2008, 05:26:55 PM
In 'About' it says "Version: 1.0" and "Model M9585B".

I purchased the ipod second hand recently to install rockbox on, so I don't know if they've ever updated the firmware before, it seems not judging from the version number?

Which bootloader should I download? I was going to try that 'loader2' but the website is still down.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AlexP on June 13, 2008, 02:14:38 AM
Which bootloader should I download? I was going to try that 'loader2' but the website is still down.

iPodlinux, and by extension their bootloader, are unsupported* here.  If a new bootloader is required, it would involve using ipodpatcher to install one other than the included one.

*unless a dev requests you try loader2 to see if it fixes the issue, and then imports the code into Rockbox, but we will leave that for a dev :)
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Llorean on June 13, 2008, 12:30:35 PM
It would involve using ipodpatcher to install a Rockbox bootloader, specifically.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: robin0800 on June 13, 2008, 01:04:10 PM
There appears to be at least version 1.1 of apple firmware out though the only way to really find out is to install the latest version of I-Tunes. I don't expect this will fix your problem though equally if a new rockbox bootloader is needed can't see that's going to change anything either,
My recommendation would be
Install itunes
Restore the Ipod
Reload rockbox using the utility

If none of that works I would Format the player
Then reload rockbox
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AlexP on June 13, 2008, 06:04:00 PM
If none of that works I would Format the player
Then reload rockbox

er, why?

Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: AustinMarton on June 15, 2008, 08:50:09 PM
I haven't been able to update my apple firmware because I couldn't get itunes running under wine.

There doesn't appear to be a newer version of the rockbox boot loader, but I downloaded it again and tryed reinstalling, no change.

I tried to install ipodlinux and it works without any issues with the colour, to confirm that it is not an issue with the device.

Would formatting the player do anything?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Llorean on June 15, 2008, 09:02:15 PM
To get a newer version of the bootloader, you'd have to compile a new one from SVN.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: direcow on June 15, 2008, 09:11:26 PM
I'm also getting the same problem, after upgrading from a much older version (I forget which, but the older version was about 2 weeks older...) Basically the screen has the same garbled colours.

update: patch 17627 works, so something has happened in between. I'll try to work incrementally if I get the time.

update 2: 17694 works too.

update 3: 17704 works, 17722 does not.

update 4: 17713 works.

update 5: 17714 works -  beginning to suspect my problem is different from the original problem in the thread, and might be related to the ipodlinux code.

update 6: 17715 does not work, that's where it breaks for me. looks like the ipodlinux code makes things whacky for those without the problem. I'm going back to 17714 for now.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: linuxstb on June 16, 2008, 01:13:52 AM
I think I understand this now.

Some background - there are two types of LCD used in the ipod Color/Photo, known as "type 0" and "type 1", with "type 0" being the older version, and Apple switched them around the time they renamed the ipod from "Photo" to "Color" (but not exactly).

The LCD is 16-bit, so Rockbox has a choice of sending words as little-endian or big-endian.

The situation seems to be the following:

1) Version 1.0 of the original Apple firmware (OF) initialises the type 0 LCD to be little-endian
2) Version 1.1 and later of the OF initialises the type 0 LCD to be big-endian
3) The code added in r17715 configures the type 0 LCD to be little-endian
4) The type 1 LCD is big-endian

Rockbox has always treated both LCD types as a big-endian, which has worked fine until Austin came along with his 1.0 firmware.   r17715 then broke Rockbox for all other type 0 LCDs.

The IPL kernel LCD driver treats both type 0 and type 1 LCDs the same - so is also broken (but probably only displays either black or white text, which means the byte order doesn't matter).

The LCD driver in the IPL "hotdog" library treats the two types differently - byte-swapping the data before sending it to the "type 1" LCD.

What would be useful is if we could try to understand the code in r17715 (which we've blindly taken from IPL), and try and determine how to set a type 0 LCD to big-endian mode.  This requires someone with such a "type 0" LCD to do some experimenting.

But the first thing I would test would be to change the following line in firmware/export/config-ipodcolor.h:

Code: [Select]
#define LCD_PIXELFORMAT RGB565SWAPPED /* rgb565 byte-swapped */

to

Code: [Select]
#define LCD_PIXELFORMAT RGB565

This will make Rockbox send all bytes in the opposite order - and confirm that this is indeed what's happening.  You should do a "make clean" before doing this, to ensure all bitmaps are recreated with the new byte ordering.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: het_yak on June 16, 2008, 11:30:14 AM
Hi All,

I just tried to load rock box onto my Ipod photo and ran into the same problem. Not possible to install with the utility nor manually on my mac. manged to install under windows but the colors are off. I do not mind experimenting a bit, where can I read up on how to change the suggested line?

Thanks, friendly regards

Leon
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Chronon on June 16, 2008, 01:39:16 PM
There is a bunch of documentation if you follow the "index" link on the left.  Scroll down to the "For Developers" section.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: LambdaCalculus on June 16, 2008, 07:24:24 PM
I decided to try linuxstb's suggestion above and edited my firmware/export/config-ipodcolor.h as he said. I ran "make clean", and then compiled.

I compiled against SVN trunk r17727, and the result? It works... sort of.

The menu and WPS appear correct, but most of the bitmaps are still corrupt. So we partially solved the problem, but we need to find out what else has to be changed.

My 4G color's LCD is also Type 0, for the record.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: linuxstb on June 17, 2008, 01:02:40 AM
The menu and WPS appear correct, but most of the bitmaps are still corrupt. So we partially solved the problem, but we need to find out what else has to be changed.

OK.  For the bitmaps, I forgot to say that you also need to change the following line in tools/configure (line 1056) from:

    bmp2rb_native="$rootdir/tools/bmp2rb -f 5"

to:

    bmp2rb_native="$rootdir/tools/bmp2rb -f 4"

You then need to do a make clean, then re-run tools/configure

But that isn't a solution - a version of Rockbox compiled with these changes will work on the type 0 LCDs, but won't work on the type 1 LCDs...  What we (or rather someone with a type 0 LCD - I don't have one) need to do is to determine the lcd init sequence to make the existing code work again, and on all type 0 LCDs (i.e. including firmware version 1.0).

Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: LambdaCalculus on June 17, 2008, 07:06:47 AM
OK.  For the bitmaps, I forgot to say that you also need to change the following line in tools/configure (line 1056) from:

    bmp2rb_native="$rootdir/tools/bmp2rb -f 5"

to:

    bmp2rb_native="$rootdir/tools/bmp2rb -f 4"

You then need to do a make clean, then re-run tools/configure

This indeed works. The RB bitmaps are displaying correctly now.

I've been poking through the code a little bit to determine what the proper LCD init sequence should be for type 0 LCDs. No luck yet, but I'll keep looking.

By firmware version 1.0, you're talking about the Apple firmware, am I correct? My 4G color has Version 1.2.1 on it, so this should be checked on various other Apple firmware versions.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: het_yak on June 20, 2008, 11:30:38 AM
Hi LambdaCalculus379

Is it possble to put the correted "0 screen" version up somewhere? I am not up to changing the code.

Friendly regards

Leon
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: biiig-red on June 20, 2008, 01:15:40 PM
I had the same problem with IPod Photo 20GB and could solve it with your hints. Thanks a lot for that.
If you need some information about my hardware or something else, just tell me where I can find it.

Have a nice day,

biiig-red
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: undo on June 20, 2008, 06:36:29 PM
Is it possble to put the correted "0 screen" version up somewhere? I am not up to changing the code.

I have uploaded my build from this morning at http://www.chillt.de/rockbox.zip and will leave it up there for a while. This is a vanilla build with commit 17715 reverted. I have verified that this fixes colors on my type 0 LCD iPod Color/Photo.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: LambdaCalculus on June 21, 2008, 08:51:22 AM
Thanks for that, but I'm still going to upload a patch to Flyspray that will fix the bitmap corruption. I just haven't had a chance to, being sick yesterday and Real Life issues taking over as well.

Keep your eyes peeled for the patch.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: biiig-red on June 22, 2008, 12:25:47 AM
yesterday I noticed that  videos are in wrong colors, although i made the corrections of the two files linuxstb told. Cause I don't know anything about the IPod Hardware and anything about the Rockbox software, I didn't try out if a change in a file can correct the failure.

Quote
being sick yesterday
Hope you'll get well soon!

Quote
Real Life issues taking over as well

I think that RL sucks...  ;)

Have a nice day!

biiig-red
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: xxbatman94xx on June 25, 2008, 10:19:02 AM
Is it possble to put the correted "0 screen" version up somewhere? I am not up to changing the code.

I have uploaded my build from this morning at http://www.chillt.de/rockbox.zip and will leave it up there for a while. This is a vanilla build with commit 17715 reverted. I have verified that this fixes colors on my type 0 LCD iPod Color/Photo.

Hey i tested your version its working correctly even on videos :D
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: undo on June 25, 2008, 10:12:38 PM
Hey i tested your version its working correctly even on videos :D

All I did was revert the commit direcow identified as the likely offender. This is just a quick workaround, not a proper fix. It works for me, but all I use are the Rockbox menus and WPS. Some apps/games/plugins may be doing more fancy stuff with the LCD that will require a proper fix. As you can read in this thread, LambdaCalculus379 is working on a patch. Until then, I fear this build or simply an older version of Rockbox before the breakage is as good as it gets.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: LambdaCalculus on June 26, 2008, 05:22:34 AM
The patch is up; see FS#9122 (http://www.rockbox.org/tracker/task/9122).
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: undo on June 26, 2008, 07:19:38 AM
The patch is up; see FS#9122 (http://www.rockbox.org/tracker/task/9122).

I have updated the build at http://www.chillt.de/rockbox.zip to vanilla sources + patch from FS#9122. As pointed out in Flyspray, mplayer remains broken.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Llorean on June 26, 2008, 07:28:47 AM
Mpegplayer. It is not a port of, or affiliated with, the project mplayer.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: undo on June 26, 2008, 10:46:07 AM
Sorry, "mpegplayer" of course. I never even use the plugin, so I was not sure of its name.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: direcow on June 28, 2008, 01:06:09 AM
I'd like to report that the patched build 17801M uploaded by undo works for me, but would like to add that I too do not use my player to watch videos, but basic functionality is fine.

Thanks to all who helped!
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Chronon on July 01, 2008, 02:49:50 PM
That build is basically just a reversion to an older version where this problem had not become evident.  It's not a proper fix to the problem for all iPod Photo owners.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: het_yak on July 09, 2008, 09:45:44 AM
Hi All,

great news, I will give it a go.

Regards

Leon
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: murrer on July 10, 2008, 02:33:34 PM
I was having the same problme and fixed with this version that Adam West  compiled its r17803

heres a rapid share link
http://rapidshare.com/files/125714326/rockbox_ipod_color_patch.zip.html
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: WildmanCAL on July 11, 2008, 10:02:09 PM
The last file download works for me as well but has the fix been implemented in the daily builds?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: LambdaCalculus on July 12, 2008, 09:31:36 PM
Not yet, as the fix is more of a kludge than anything, and is not really meant for SVN.

What needs to be done is we have to figure out how the Apple firmware inits the LCD, but having two types of LCD doesn't help too much, either.

When a proper solution is found, then we can finally lay this bug to rest.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: undo on July 15, 2008, 08:48:03 AM
For those interested in a more recent build, I just updated http://www.chillt.de/rockbox.zip to a fresh SVN checkout (plus the iPod color fix, of course). Enjoy.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: konkon on July 16, 2008, 09:58:34 AM
FS #9122 comment 7

I send the new patch file (fs9122.patch).

Please report  the new patch applied Rockbox.


P.S.

My patch applied Rockbox  can be downloaded from 

http://www.zshare.net/download/154624096b509b80/

Please confirm your  iPod color/photo.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: linuxstb on July 17, 2008, 05:45:01 AM
I've hopefully identified the LCD init code that fixes this problem, and have committed the change to SVN.

So can users with a "type 0" LCD please test the latest "Current Build" - r18079 or later and report if all is well again?

Also useful would be if anyone running the old 1.0 Apple bootloader (which started this problem in the first place) could confirm that Rockbox now works for them?
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: LambdaCalculus on July 17, 2008, 07:04:55 AM
linuxstb, I just updated my build to r18082 and would like to announce that the LCD is now properly working and everything is displaying correctly. Great work! ;)
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: undo on July 17, 2008, 07:11:13 AM
the LCD is now properly working

Seconded. I have pulled my custom build from www.chillt.de so people are not tempted to install the old hack. Great work. Thanks!
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Chronon on July 17, 2008, 10:21:05 AM
The Flyspray task has been closed so I just updated the Current Status page to reflect this.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: crescentfresh on July 21, 2008, 03:21:37 PM
An unfortunate byproduct of this patch being implemented I just realized is that for some reason the DGT themes don't seem to display correctly at all anymore while playing music.  It's a very minor price to pay to have the screen back, but doesn't make a whole lot of sense to me.  Anyone know why this might happen???  If I go back to the 6-12 build referenced as the last good build before the original problem, the WPS starts working again.
Title: Re: Ipod photo 40gb has bad resolution, all the colours are wrong
Post by: Chronon on July 21, 2008, 03:59:11 PM
It sounds like that build does not comply with the current WPS syntax.  There were changes on June 23 that required all themes to update progress bar and margin tags.  If this theme works with a June 12 build then this seems to suggest that it shouldn't work with a current build.