Rockbox Technical Forums

Installation / Removal => Manual Installation => Sandisk - Installation/Removal => Topic started by: oranges2 on September 17, 2007, 02:39:40 AM

Title: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 17, 2007, 02:39:40 AM
I just purchased a Sansa e260 today, and went through the following steps:

1. Switched the device to MSC mode.

2. Downloaded the daily build (which I only did because build.rockbox.org was down at the time) and extracted the archive to the root of the drive.

3. Ran the sansapatcher.exe tool. The program said it was installed correctly, but the device continued to display "Writing", I wasn't sure if this was normal or not, so I waited a minute or so then just disconnected it.

4. Booted into RockBox. Everything seemed to be working fine.

5. Tried to boot into the original firmware by holding the <- (rewind) key. Some text was displayed (the topline being "Rockbox Boot Loader"), and the device froze and the screen proceeded to change colors (from white, to red, to black). Did this several times, receiving the same result each time.

6. Restored the firmware using the instructions in the Wiki.

7. Repeated steps 1-4 exactly the same (except this time I was using the Current Build since the site was back up, don't think this would affect my issue).

8. Now instead of the screen freezing and changing colors when I try to boot the original firmware, it just reboots.

Any help would be appreciative. here's a video of the first color changing issue (790kb, 40 seconds):

http://www.sendspace.com/file/hrrcho

I would also like to clarify that I do not have a Rhapsody model, this is just the e260.

Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 17, 2007, 02:43:48 AM
What version of the original firmware did you have, you know?

R model owners, is this looking like the same way it doesn't work for you?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 17, 2007, 02:45:38 AM
I don't know what version the player came with, but when I recovered it I used the 1.00.12 file from this site: http://daniel.haxx.se/sansa/mi4.html
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 17, 2007, 02:48:51 AM
Eh, you used that? I don't see how that is covered by the sansapatcher instructions. Can you elaborate? Did you install the 1.00.12 first and then use sansapatcher?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 17, 2007, 02:50:30 AM
No, I used sansapatcher first (step 3), then when I couldn't boot to the original firmware (step 5), I recovered with that file (step 6).

After that I tried using sansapatcher again (step 7), and now I'm posting here.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 17, 2007, 02:55:21 AM
So you have no idea what version it used originally?

I'm thinking that if it was a somewhat newer firmware version (and thus bootloader), it uses a newer mi4 key and thus it can't boot/run older mi4 files. What speaks against that is that the bootloader usually says something about a bad image when there's a bad mi4 in there, it doesn't just reboot...
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 17, 2007, 02:58:37 AM
Should I try flashing one of the older files from that site?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 17, 2007, 05:31:53 AM
Yeah, trying to put one of the older bl.rom files on your player is a good idea indeed.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: [cc] on September 17, 2007, 12:01:37 PM
I am also having difficulty dual-booting my E260R (this one is a Rhapsody model).  I've followed the instructions at http://www.rockbox.org/twiki/bin/view/Main/SansaE200RInstallation precisely.  I can boot into Rockbox fine, and I can use recovery mode to revert to the Rhapsody firmware (http://daniel.haxx.se/sansa/e200/rhapsody/rhapsody-1.0.2.31.zip) without any trouble, but when I try to boot to that same firmware using the |<< back button, I get the oft-repeated white meltaway screen of death.

Transcribed boot loader message:
Code: [Select]
Rockbox boot loader
Version: r14725-070915
Sandisk Sansa e200
Partition 0: 0x0B 3814 MB
Partition 1: 0x04 20 MB
Loading original firmware...
Trying firmware partition
BL mi4 size: EC00
Can't load from partition
Invalid file format
Trying /System/OF.mi4
mi4 size: 57B000
CRC32: 28EBB55C
Model id:
Binary type:
Calculated CRC32: 28EBB55C
Searching for key:
rhapsody...found
rhapsody key used


Original version.txt on the device before any toying:
Code: [Select]
Version Info: Product Rev.: PP5022AF-05.51-S301-01.01-S301.0.1.47-D
Base Code: 05.51-S301-01.01-S301.0.1.47-D
ODM Ver.: S301-01.01-S301.0.1.47-D
OEM Ver.: S301.0.1.47-D
Build Type: -D
Build Date: 2006.10.07
Build Number: (Build 169.31)


For reference, I am running Slackware 12.0.0 with linux kernel 2.6.22.6.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 17, 2007, 03:14:46 PM

when I try to boot to that same firmware using the |<< back button, I get the oft-repeated white meltaway screen of death.


I take it it looks exactly like oranges2's video shows then?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: [cc] on September 17, 2007, 03:45:02 PM

I take it it looks exactly like oranges2's video shows then?


Just checked the video to be sure... yep, looks just like that.  The pixels wash across the screen in white (the text becomes inverted), then they gradually die away through various shades of red until ultimately it's all black.  Basically it just looks like someone stomped their heel down on the screen.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: open on September 17, 2007, 04:38:19 PM
It seems that I have the same problem. RB works as promised but the player wouldn't load into the sandisk's shell. Instead I see the same sympthoms as described by oranges2.
I have sansa e260 (not R) with firmware upgraded to ver. 1.02.18A prior to installing RB and patching the loader. I've patched the loader using sansapatcher.exe.
Thanks you for your help.

UPD
1. Downgraded to the 1.02.15a version - nothing changed.
2. When I connect the USB cable to the player, it turns ON and tries to load with the sandisk's firmware. It seems that now I can't upload new files to the player.
3. To upload new files onto the player I had to  do a firmware reset.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 17, 2007, 06:31:41 PM

Yeah, trying to put one of the older bl.rom files on your player is a good idea indeed.

It turns out that 1.00.12 is the oldest firmware for my model.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 18, 2007, 01:28:47 AM
I've tried sansapatcher once again, and still receive the same rebooting problem.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Dima on September 18, 2007, 01:35:43 AM
I'm having the same problem (as in the video) with my e280...
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: ghoti on September 18, 2007, 05:22:03 PM
i just installed rockbox on my new e280 and unfortunately have the same problem now, too... rockbox works, but booting into the original firmware fails with the strange display.
as far as i see, i can't even uninstall the bootloader because the sansapatcher does not find it anymore... (sansa dies when attached to the usb with the same symptoms as described for 'simple' booting.)
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 18, 2007, 05:31:13 PM

i just installed rockbox on my new e280 and unfortunately have the same problem now, too... rockbox works, but booting into the original firmware fails with the strange display.
as far as i see, i can't even uninstall the bootloader because the sansapatcher does not find it anymore... (sansa dies when attached to the usb with the same symptoms as described for 'simple' booting.)

Boot into recovery mode by turning on the device with the lock switch on, and holding record.

Then put the BL.rom file for your model on the device: http://daniel.haxx.se/sansa/mi4.html
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: DavidGWRawson on September 18, 2007, 06:01:11 PM
I have the bootloader that will solve the problem. However, I don't know how to post it. I will have to e-mail it to you somehow. It fixed my player when it di It's only for rhapsody editions. I just learned it the hard way...
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 18, 2007, 08:44:49 PM
Heres the text when it tries to boot the OF

Code: [Select]
  Rockbox boot loader
      Version: *something really long*
      Sandisk Sansa e200
      Partition 0: 0x0B 3814mb
      Partition 1: 0x84 20mb
      Loading original firmware...
      Trying firmware partition
      BL mi4 size: EC00
      OF mi4 size: 52B400
      CRC32: 578F184B
      Model id: e200
      Binary Type: RBOF
      Calculated CRC32: 578F184B
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: justWOOT on September 19, 2007, 10:24:16 AM
I'm having the same problem with my e270. Mine is a fairly new one bought in May and shipped with firmware 1.02.15A- then upgraded to 1.02.18A. The bootloader fails to load the orginal firmware; I get the same weird screen wash and displayed text. I've tried different sansa bootloader roms (thinking perhaps there was an incompatibility with the newest one) and differnet RB builds- so I think there's something wrong with the sansapatcher. Anyone knows what the sansapatcher actually does, and where it stores/links the original firmware?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 19, 2007, 02:44:33 PM
sansapatcher just puts the bootloader in place and obviously it works since it boots and it can load rockbox.

I'm leaning towards that some of the (newer) mi4 firmwares want more magic done by the bootloader, like the newly added stuff for the c200 OF.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: justWOOT on September 19, 2007, 05:42:20 PM
I tried rolling back to earlier firmwares but it produced the same error.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: infirit on September 19, 2007, 05:53:41 PM
Got my e280 yesterday and have the same problem. The version of the OF is the latest available from sandisk 01.02.18e. Using any of the .mi4 files from http://daniel.haxx.se/sansa/mi4.html results in the same issue as described in the first post.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 19, 2007, 05:57:37 PM
And for the record, I'm still using RockBox, and just using a MicroSD to transfer new files to the flash memory.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: justWOOT on September 19, 2007, 06:38:13 PM
Anyone have any new suggestions? I don't have a MicroSD card, and I like to load daily podcasts- so I had to restore the original firmware.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: larcon10 on September 19, 2007, 07:47:29 PM
Has anyone submitted a bug report? I have the exact same problem with my e270.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 19, 2007, 11:38:08 PM
UPDATE

I installed the unofficial reverse bootloader (loads OF first, hold select to load RockBox), and it works great. I'd prefer that I could load RockBox first, but I think I can live with this.

Located here:
http://e200.digerati1338.googlepages.com/reversebl
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: nunobett on September 20, 2007, 06:02:53 AM

I'm having the same problem (as in the video) with my e280...


Hello everyone? today I also tried to install rockbox on my e280 and had the same problem as in the video and cannot boot to original firmware.

I think my original firmware version was also the v01.02.15E but I did not make any backup of it. Does anyone got that firmware version file?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: nunobett on September 20, 2007, 06:21:09 AM

UPDATE

I installed the unofficial reverse bootloader (loads OF first, hold select to load RockBox), and it works great. I'd prefer that I could load RockBox first, but I think I can live with this.


Good news!!! I did exactly the same and it works. Nevertheless I would rather prefer to have RB as my 1st boot.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: justWOOT on September 20, 2007, 06:56:35 AM

sansapatcher just puts the bootloader in place and obviously it works since it boots and it can load rockbox.

I'm leaning towards that some of the (newer) mi4 firmwares want more magic done by the bootloader, like the newly added stuff for the c200 OF.


I (among others here) went back to the oldest firmwares, and still had the same problem. So no, there's nothing new.
Seeing as how most of us have tried to install RB within the last week- there's a current problem with the bootloader being able to load the OF.
I'm also using an alternate bootloader as a temporary solution.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Freedom_XXXX on September 20, 2007, 11:40:56 AM

UPDATE

I installed the unofficial reverse bootloader (loads OF first, hold select to load RockBox), and it works great. I'd prefer that I could load RockBox first, but I think I can live with this.

Located here:
http://e200.digerati1338.googlepages.com/reversebl


oranges2 ...  fairly a newbie here. Have the white screen of death when i try to boot up my OF. I tried to follow the procedure mentioned in the site, but without much success.

The problem is my sansa is not at all recognized on the first hand (when i'm in Rockbox firmware and obviously I'm unable to boot the OF) . Can you explain in detail what you exactly did?

I'm really worried that I could not transfer any files in my rockbox mode.


Here is the instructions from the site you mentioned.
Download the ReverseBL below.
Download sansapatcher.
Run "sansapatcher.exe -a ReverseBL.mi4"
Reboot your player to update the bootloader.

Do I have to be in any recovery mode or something? By stating  ' Run "sansapatcher.exe -a ReverseBL.mi4" ' what does it exactly mean? Do I have to run my sansa patcher first and then click on the mi4 file? My sansa patcher says that my my player is not connected:

[err] no e200s found, aborting
[err] please connect your sansa and ensure it is in ums mode
[err] please refer to the Rockbox manual if you continue to have problems.


can some guru out here help me?


Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Freedom_XXXX on September 20, 2007, 11:44:59 AM


sansapatcher just puts the bootloader in place and obviously it works since it boots and it can load rockbox.

I'm leaning towards that some of the (newer) mi4 firmwares want more magic done by the bootloader, like the newly added stuff for the c200 OF.


I (among others here) went back to the oldest firmwares, and still had the same problem. So no, there's nothing new.
Seeing as how most of us have tried to install RB within the last week- there's a current problem with the bootloader being able to load the OF.
I'm also using an alternate bootloader as a temporary solution.


Can yo please tell me how to use /load alternate boot loader?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: open on September 20, 2007, 01:25:11 PM
Reverse BL doesn't work with my player. Pressing left button during the boot puts me into the manufacturer's firmware.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: infirit on September 20, 2007, 01:37:31 PM

Got my e280 yesterday and have the same problem. The version of the OF is the latest available from sandisk 01.02.18e.
Using the older version 0.2 of the sansapatcher I got this working so it is pretty obvious the patcher is at fault here. You do get the funky screen but then it starts the sansa firmware. I used the same OF version as I stated above.

PLEASE DO NOT SEE THIS AS AN OK TO DO THE SAME!! And wait for an actual developer to comment.

UPDATE: FS#7806 (http://www.rockbox.org/tracker/task/7806)
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: ghoti on September 20, 2007, 02:02:24 PM

UPDATE

I installed the unofficial reverse bootloader (loads OF first, hold select to load RockBox), and it works great. I'd prefer that I could load RockBox first, but I think I can live with this.

Located here:
http://e200.digerati1338.googlepages.com/reversebl


thanks oranges2, first of all for your hint how to restore the original firmware ... and then for this great hint. it does work perfectly.

thanks again.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Freedom_XXXX on September 20, 2007, 02:34:27 PM


UPDATE

I installed the unofficial reverse bootloader (loads OF first, hold select to load RockBox), and it works great. I'd prefer that I could load RockBox first, but I think I can live with this.

Located here:
http://e200.digerati1338.googlepages.com/reversebl


thanks oranges2, first of all for your hint how to restore the original firmware ... and then for this great hint. it does work perfectly.

thanks again.


ghoti,

can you please tell me how you installed? please...........
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Dima on September 20, 2007, 03:15:34 PM
@Freedom_XXXX:

I haven't tried the reverse bootloader. But in any case, you'll need to be running the OF first - otherwise, the USB doesn't really work at all.

And yes, you do need the recovery mode. The official instructions aren't that clear, I guess. Basically, get the PP5022.mi4 from http://daniel.haxx.se/sansa/mi4.html, and put it on the partition in the recovery mode. It should install the OF.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: ghoti on September 20, 2007, 03:21:05 PM
hello freedom_xxxx,

i think you have to reinstall the original firmware as described in the wiki article on unbricking the sansa (http://www.rockbox.org/twiki/bin/view/Main/SansaE200Unbrick)
then the OF should boot again and you can switch the usb-mode to msc and the sansa should be recognized again by your pc (and thus by the sansapatcher later)

to run the sansapatcher as proposed (sansapatcher.exe -a ReverseBL-2007-07-31.mi4)  you have to say good-bye to your mouse for a moment and go into good old command shell window and cd to the directory in which the sansapatcher.exe is living.
assuming windows (xp) you get a command shell by typing windowskey-r and then entering 'cmd ' (without the quotes) into the execute dialogbox. then you have to do a cd to the directory where the sansapatcher is living (so assuming it is in C:\Documents and Settings\Administrator\Desktop you have to type
'cd C:\Documents and Settings\Administrator\Desktop' (without the quotes))
beware that the ReverseBL-2007-07-31.mi4 file has to live there too of course.
then you can type sansapatcher.exe -a ReverseBL-2007-07-31.mi4 and that should be that....

it has worked with my player and so there is real hope you get it running again ;)
good luck.


update: yes dima is right, i forgot to mention that, it should not worry you that usb is not working under rockbox because it is not (yet) supposed to.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: ghoti on September 20, 2007, 03:27:58 PM

Reverse BL doesn't work with my player. Pressing left button during the boot puts me into the manufacturer's firmware.


yep, you should try holding the "select"-button (that's the big one in the middle) as it says on the reversebl website.

good luck
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Freedom_XXXX on September 20, 2007, 05:40:15 PM

hello freedom_xxxx,

i think you have to reinstall the original firmware as described in the wiki article on unbricking the sansa (http://www.rockbox.org/twiki/bin/view/Main/SansaE200Unbrick)
then the OF should boot again and you can switch the usb-mode to msc and the sansa should be recognized again by your pc (and thus by the sansapatcher later)

to run the sansapatcher as proposed (sansapatcher.exe -a ReverseBL-2007-07-31.mi4)  you have to say good-bye to your mouse for a moment and go into good old command shell window and cd to the directory in which the sansapatcher.exe is living.
assuming windows (xp) you get a command shell by typing windowskey-r and then entering 'cmd ' (without the quotes) into the execute dialogbox. then you have to do a cd to the directory where the sansapatcher is living (so assuming it is in C:\Documents and Settings\Administrator\Desktop you have to type
'cd C:\Documents and Settings\Administrator\Desktop' (without the quotes))
beware that the ReverseBL-2007-07-31.mi4 file has to live there too of course.
then you can type sansapatcher.exe -a ReverseBL-2007-07-31.mi4 and that should be that....

it has worked with my player and so there is real hope you get it running again ;)
good luck.


update: yes dima is right, i forgot to mention that, it should not worry you that usb is not working under rockbox because it is not (yet) supposed to.


Ghoti,

That will help me a lot. I'm sad that I had to reformat my player and loose all my songs....but hey therez hope. Lemme try it and see if it works. Thanks for the info.

Edit1: Succesfully brought back my sansa to OF. BTW is the latest sansapatcher ok to use for reverse BL? I don't want to mess it up again.

Edit2: Got rockbox to load by holding the select button.loaded a couple of themes. 'Rockbox' rocks!!

Wish I could make rockbox to load by default and change to OF when needed...but hey I cannot complain :)

Thanks again Ghoti :)
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: dana7 on September 20, 2007, 09:47:46 PM
Hello, I am very new here.  I successfully loaded and ran RockBox on my brand new e280 -  and I would very much like to do so again, but after experiencing the subject  problem and having to  use the "recovery mode" to install a .mi4 file that I hoped would work was about all my poor heart could take.

Thanks to the information in this forum and on the Wiki I now can boot the original firmware.  RockBox seems to still be installed, but I do not have a way to boot into it anymore.

In the one day I was able to run RockBox, I became its biggest fan.

I do not want to do anything stupid, and frankly a lot of the discussion here is a bit cryptic and hard  for me to follow.  If I can get this problem fixed, a donation surely follows!

Questions:

1)  How will I know when the bug in the sansapatcher has been identified and fixed?


2)  Once that happens, and I rerun the sansapatcher, will Rockbox boot normally again, or do I have to reinstall it?

Thanks!

Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Dima on September 21, 2007, 11:22:30 AM

1)  How will I know when the bug in the sansapatcher has been identified and fixed?

Looks like infirit filed a bug: http://www.rockbox.org/tracker/task/7806
So watch for changes there... And also read this thread :)


2)  Once that happens, and I rerun the sansapatcher, will Rockbox boot normally again, or do I have to reinstall it?

Rockbox should boot normally. That is, installing Rockbox involves creating the .rockbox folder, and installing the bootloader using sansapatcher. So unless you deleted .rockbox, you just need to rerun the sansapatcher.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: infirit on September 21, 2007, 12:58:50 PM


1)  How will I know when the bug in the sansapatcher has been identified and fixed?

Looks like infirit filed a bug: http://www.rockbox.org/tracker/task/7806
So watch for changes there... And also read this thread :)


I was hoping a dev to confirm the problem and suggest to use the 0.2 patcher in the mean time but that has not happened. So I will post a link to the version 0.2 patcher so people at least can get their sansa running rockbox.

win32 (http://download.rockbox.org/bootloader/sandisk-sansa/e200/v0.2/win32/sansapatcher.exe)
Linux x86 (http://download.rockbox.org/bootloader/sandisk-sansa/e200/v0.2/linux32x86/sansapatcher)
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: alaron on September 21, 2007, 01:03:04 PM
Hey Oranges,

Is it working the same way with a Rhapsody version of the player (E280R) with regards to the reversible bootloader?

I tried it and wasn't booting at all :(

ty
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 21, 2007, 02:38:27 PM

Hey Oranges,

Is it working the same way with a Rhapsody version of the player (E280R) with regards to the reversible bootloader?

I tried it and wasn't booting at all :(

ty

You have to disable the security present on the R version before installing the bootloader.

http://www.rockbox.org/twiki/bin/view/Main/SansaE200RBootloaderPatching
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Freedom_XXXX on September 21, 2007, 03:29:28 PM



1)  How will I know when the bug in the sansapatcher has been identified and fixed?

Looks like infirit filed a bug: http://www.rockbox.org/tracker/task/7806
So watch for changes there... And also read this thread :)


I was hoping a dev to confirm the problem and suggest to use the 0.2 patcher in the mean time but that has not happened. So I will post a link to the version 0.2 patcher so people at least can get their sansa running rockbox.

win32 (http://download.rockbox.org/bootloader/sandisk-sansa/e200/v0.2/win32/sansapatcher.exe)
Linux x86 (http://download.rockbox.org/bootloader/sandisk-sansa/e200/v0.2/linux32x86/sansapatcher)



Thanks for posting the version 0.2. Rockbox loads and works perfect. Original firmware also loads perfect. Just what I need.

BTW very nice themes available for download. Does anybody know if we can set custom visual setting when a song is playing(like windows media player visual optons!)?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 21, 2007, 04:02:26 PM
Ok, so at some point during the last few months the bootloader stopped working fine.

It would be really helpful if someone could take some time to binary-search down to when exactly it stopped working.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: oranges2 on September 21, 2007, 04:09:24 PM
Whats the difference between the two versions? (aside from 0.3 not working correctly)
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 21, 2007, 04:15:01 PM
They're identical, but back when we did the 0.2 version of the bootloader for e200 (which is reported to still work to dual-boot) we didn't have the correct keys for e200R added so the 0.2 can't decrypt the e200R OF image.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: infirit on September 21, 2007, 04:27:19 PM
It would be really helpful if someone could take some time to binary-search down to when exactly it stopped working.

I would love to help figuring this out but how do I go about doing this?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: dana7 on September 21, 2007, 07:35:06 PM
OK, after just one day without RockBox, I got tired of waiting and ran the .2 version of the sansapatcher, and I am happy to report that it seems to have worked fine.

Thanks to infirit for the link.

          You people are great.  

                     I think I'm gonna like it here.  ;D
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 22, 2007, 06:45:26 AM

It would be really helpful if someone could take some time to binary-search down to when exactly it stopped working.

I would love to help figuring this out but how do I go about doing this?


Pick a date between now and July 31st. Build a bootloader with the sources from that date and try that. Did it work? If so, pick another date between that and the date it doesn't work and continue.

In the end you should hopefully be able to point out the exact day the bootloader broke, and then you can continue to figure out the exact rev number...
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: infirit on September 22, 2007, 09:38:09 AM
I can already say the actual patcher application is not the problem. Using the v0.3 patcher with an older bootloader (global rev 13315) works. Now try and get the version of bootloader that is causing the problems.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: infirit on September 22, 2007, 10:59:36 AM
Found the commit that broke the bootloader. Not sure how it could have but that is up to the devs to find out ;-)
----
Rev: 14654
Firmware "hacker" code for the e200r install so the full bootloader rom doesnt need to be written.
Requires a custom version of e200tool which isnt available yet.

* Causes the complete lockup of the sansa e200. Before it would just reboot.

Rev: 14424

FS#7634: Add support for high capacity microSD cards (SDHC). We now support SD specification Version 2.00 which covers cards up to 32GB in size.

* breaks the bootloader. It just reboots trying to load the OF.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Bagder on September 22, 2007, 02:49:30 PM
Sorry, I don't understand. "the commit" that broke the bootloader is a single commit, and then you list two different ones that have problems?

Are you saying that both of these independently prevent the bootloader from working fine?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: infirit on September 22, 2007, 02:57:27 PM
The 14424 commit is what is causing the failure.

It just found it really strange that before commit 14654 the sansa reboots and after it would lockup and needs a reset.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: alaron on September 22, 2007, 11:08:45 PM
Cool...if that's the change that broke the bootloader maybe we can have that fixed soon :)
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: scharkalvin on September 23, 2007, 04:31:11 PM
can somebody supply a download link to files that
work?  I have an E270 coming in the mail this week and would
like to install rockbox.  Until this problem gets fixed for good, I'd like to just
install and older version of the boot loader (how?) that doesn't have
the problem.  Is the bootloader part of the rockbox binary, or is it a
separate file?  
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: dana7 on September 23, 2007, 08:17:18 PM
There is already one in this thread.  Look back a page or two for a post from infirnt on Sept 21, 2007.  He has a link to the 0.2 bootloader in his post that I copied to my 280 that I had loded up with bad software before I got smart.


Be fearless, and G'luk
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: scharkalvin on September 24, 2007, 06:48:56 AM
Quote
There is already one in this thread.  Look back a page or two for a post from infirnt on Sept 21, 2007.  He has a link to the 0.2 bootloader

He did post a link to sansapatcher 0.2.  Is that the same thing as the boot loader?
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: GodEater on September 24, 2007, 07:30:26 AM
Sansapatcher installs the bootloader, it is not the booloader.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: scharkalvin on September 24, 2007, 03:24:34 PM
Quote
Sansapatcher installs the bootloader, it is not the booloader.

That's what I thought.  I looked back through this thread but i did not find a posted link to the previous version of the boot loader.   Perhaps it is part of an archived build?
If so, what version should I look at?  
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: cpchan on September 24, 2007, 04:11:15 PM

I looked back through this thread but i did not find a posted link to the previous version of the boot loader.  


Here:

http://download.rockbox.org/bootloader/sandisk-sansa/e200/v0.2/

or here:

http://www.anythingbutipod.com/forum/showpost.php?p=145608&postcount=809

Charles
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: scharkalvin on September 24, 2007, 05:45:23 PM
quote]Here:

http://download.rockbox.o.../sandisk-sansa/e200/v0.2/

or here:

http://www.anythingbutipo...hp?p=145608&postcount=809[/quote]

Thanks.
The first link is dead.  the second link requires me to register with the forum.
I'll try it again when I get home and can read my email.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: cpchan on September 24, 2007, 05:57:30 PM
The first link is dead.
 

Try this link, it works fine for me:

http://download.rockbox.org/bootloader/sandisk-sansa/sansapatcher/old/v0.3/

Quote
the second link requires me to register with the forum.


You might consider joining use here:

http://www.anythingbutipod.com/forum/forumdisplay.php?f=72

Charles
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: scharkalvin on September 24, 2007, 08:20:27 PM
actually those links are for sansapatcher NOT the bootstrap.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: cpchan on September 24, 2007, 08:25:32 PM

actually those links are for sansapatcher NOT the bootstrap.


I might have misunderstood you guys- which bootloader are you look for? The Rockbox bootloader has been embeded in sansapatcher for quite some time now.

Charles
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: cpchan on September 24, 2007, 08:28:44 PM

Sansapatcher installs the bootloader, it is not the booloader.


True. However, the bootloader has been embeded in sansapatcher for quite some time now.

Charles
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: GodEater on September 25, 2007, 02:15:44 AM
Yes - but it's still not "the bootloader", and calling it such is misleading.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: scharkalvin on September 25, 2007, 06:40:09 AM
Quote
Sansapatcher installs the bootloader, it is not the booloader.

I might have misunderstood you guys- which bootloader are you look for? The Rockbox bootloader has been embeded in sansapatcher for quite some time now.


ARRGGG!  Ok, so I actually DID want to just get the previous version of sansapatcher!
Thanks for clearing that up!  BTW I'm running Linux amd64 and the ONLY version of sanspatcher I could find WAS 0.02 since 0.03 has NEVER been released (in binary) for Linux on AMD64.  So maybe I am ok after all!
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: alaron on September 25, 2007, 11:16:12 AM
Hey guys,

I understand that using the old version of sansapatcher (v0.2) works fine, but what would be the alternative for people who have Rhapsody version of the player?

Thanks!
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: Freedom_XXXX on September 25, 2007, 07:34:19 PM

Hey guys,

I understand that using the old version of sansapatcher (v0.2) works fine, but what would be the alternative for people who have Rhapsody version of the player?

Thanks!


be patient until bug in rev 0.3 is fixed. I'm not an expert , but hopefully some pro out here should fix it
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: alaron on September 26, 2007, 09:31:47 AM
Hye, I'm patient :).

Just wanted to find out if there's a solution for Rhapsody players other than converting to non-R or not.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: disasm on October 10, 2007, 10:14:33 PM
Works for me too. Anyone find a way to default boot to rockbox and work though?

Sam

EDIT: I didn't see the extra pages on the left side. Working now with 0.2 version. I'm used to forums having pages numbers on right at bottom. Thanks everyone.
Title: Re: e260 boots into RockBox fine, but won't boot into original firmware
Post by: barrywardell on October 13, 2007, 06:28:25 AM
There has been a new version of sansapatcher (0.5) released on download.rockbox.org a few days ago which should fix all the problems with loading the Sansa firmware that you were having.