Rockbox Technical Forums

Installation / Removal => Manual Installation => Toshiba - Installation/Removal => Topic started by: knives26 on July 30, 2007, 09:53:32 AM

Title: Followed instuctions and nothing tosh gigabeat f40
Post by: knives26 on July 30, 2007, 09:53:32 AM
I'm new never used rockbox and I really wanted to. I followed the online instructions and the pdf instructions and then on the step where you unplug the player and restart it nothin happened. Ohh yeah i have a tosh gigabeat f40. Can anyone help?
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: LambdaCalculus on July 30, 2007, 09:56:12 AM
You installed both the bootloader AND a software build, correct?

Do you have a .rockbox folder in the root of your Gigabeat's drive? And did you make sure to copy the bootloader file to the correct folder?
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: knives26 on July 30, 2007, 09:58:22 AM
I'm using windows and I unzipped it to the partition. it created a file .rockbox.
and i replaced the file FWIMG00. its that on the reboot nothing happens.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: LambdaCalculus on July 30, 2007, 10:03:21 AM
.rockbox is not a file. That's the system folder.

And you copied FWIMG01.DAT to the \GBSYSTEM\FWIMG folder, correct?

Did you at least rename the original FWIMG01.DAT to something else before you did so, just to make sure it was backed up?
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: GodEater on July 30, 2007, 10:05:40 AM

I'm using windows and I unzipped it to the partition. it created a file .rockbox.
and i replaced the file FWIMG00. its that on the reboot nothing happens.


I do hope you didn't really replace FWIMG00.DAT - that wouldn't have been clever :(
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: LambdaCalculus on July 30, 2007, 10:10:09 AM

I do hope you didn't really replace FWIMG00.DAT - that wouldn't have been clever :(

That pretty much means "you borked it" in several languages.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: knives26 on July 30, 2007, 10:26:09 AM
i backed up the file
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: knives26 on July 30, 2007, 10:26:49 AM
maybee its where i downloaded it from or the file and or files i was trying to use?
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: GodEater on July 30, 2007, 10:30:07 AM
Firstly - please combine your posts if no-one has responded before you wish to add something else. This is what the "modify" button is for. This is required by the forum rules.


i backed up the file


Secondly, what file are you referring to here - you still haven't said ?
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: LambdaCalculus on July 30, 2007, 10:38:34 AM
Please be specific about what it is you're talking about on these forums. I don't think any of us are psychics on these boards.


maybee its where i downloaded it from or the file and or files i was trying to use?


If you downloaded from the "current build" link over on the left hand side, then you shouldn't be having issues. Those zip files already have the proper file and folder structure Rockbox needs to run.

Also, where did you get the bootloader file from?
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: knives26 on July 30, 2007, 10:39:38 AM
okay sorry about that the file i backed up was the .dat file. I think my problem is the build i have downloaded can i get a suggestion on where and what to use?
I got it from this site http://download.rockbox.org/bootloader/gigabeat/
there are two options and i tried both
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: GodEater on July 30, 2007, 10:41:10 AM
WHICH .dat file?!?!?!?!
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: knives26 on July 30, 2007, 10:41:54 AM
FWIMG01.DAT is the file i backed up and then replaced
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: GodEater on July 30, 2007, 10:45:47 AM
Just the .DAT file is the correct one. Ignore the one with the date on the end of it.

Did you switch off the battery after you'd installed both that and the .zip file as the manual tells you to ?

EDIT:

I apologise, I thought the manual said that - but apparently it doesn't. We'll get that changed.
Title: solved Re: Followed instuctions and nothing tosh gigabeat f40
Post by: knives26 on July 30, 2007, 10:51:02 AM
thank you so much i didnt see that step... I got my tosh f40 last christmas and I got a ipod video 80g at the same time so the tosh hasn't even been turned on till this morning. and for this being my first forum post (ever) i just wanted to say thank you.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: GodEater on July 30, 2007, 01:18:22 PM
Glad to be or service.

Someone is fixing the manual now to include the missing steps!
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 02:02:11 PM
please make sure I understand...as I have tried to load rockbox on my f40 5 times with no luck..yes I have followed the instructions to a tee! The only thing I am confussed about is:

Am I suppose so shut it down turn off the battery switch twice?Once after I download the zipfile and unzip it to the root directory , and get the bootloader downloaded and  installed?

Thats one shut down....if I am suppose to shut down twice when do I do the second one?  

Maybe I am just not going to get it installed, but thought I would try one more time...it sounds like a very cool program......


Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: GodEater on August 28, 2007, 02:10:56 PM
No - there is no requirement for a second "battery off" shutdown. You only do it after you've install both rockbox (by unzipping rockbox.zip) and installing the bootloader. That's why only one restart is mentioned in the install process.

How has your install failed previously ?
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 02:13:58 PM
3 times it came up with a white screen and said couldn't fine firmware ..I think and twice I got nothing on HHD......got it back to the original firmware everytime....but thats all I seem to be able to do...
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: GodEater on August 28, 2007, 02:19:40 PM
Post some screen shots of the file/folder layout on your Gigabeat - and pay particular attention to the GBSYSTEM\FWIMG folders.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: Llorean on August 28, 2007, 02:24:58 PM
If you're in windows, open a command prompt (start->run, type cmd.exe and hit enter).

Then, type the drive letter of your player (like D: or E:) and hit enter. Then type "dir /a /s > list.txt" without the quotes. Wait for that to finish and then close the window. Go to explorer and find your player, it should have a file called list.txt on it. This will show ALL the files and folders on your drive. If there's anything you don't want seen, feel free to remove it, but don't change anything beyond any necessary removals.

Then attach it to a post here.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 02:30:15 PM
ok I am an idiot...how do I do that?  
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: Llorean on August 28, 2007, 02:31:06 PM
"That" being which step?
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 02:43:07 PM
Ok I got all that done, but still am not sure how to send them but the are listed like this

FWIMGOO.DAT
Dat file
2KB

FWIMGO1.Dat
Dat File
1,172 KB

FWIMGO2.Dat
Dat File
2753 KB



Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: Llorean on August 28, 2007, 02:45:53 PM
One option is to try using this: http://www.rockbox.org/twiki/bin/view/Main/RockboxUtility
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 06:56:37 PM
I'm going to tell you how I installed roxbox ...5 different times and could not get any of them to work...maybe you will see something I am missing...

1. I downloaded the zip file "the current Build" I then extracted it over my f40 gigabeat..I confermed that I had a file in there labeled  .rockbox

2. I downloaded the fonts and unziped them over my gigabeat (DriveE)

3. I went into the Gigabeat folder opened the FWIMG folder and saved and then renamed the FWIMGo1.dat file to FWIMG01.DAT.ORIG

4. I then downloaded the bootloader for my gigabeat and I moved it to the FWIMg folder.....

I pulled out the power supply for my gigabeat, disscontected the usb cable powered it down shut off the battery switch . I waited probally a minute turned the battery switch back on powered it up, and got the error messege. This happened to me 5 different times..I am probally doing something obvious butI sure don't know what...

Thanks for your help.




Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 07:11:48 PM
any help would sure be appreciated...I am not real good with computers but I think I am navigating around by f40 fine ....I got it back and running 5 times.... :)
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 07:22:51 PM
ok, I guess no help here....rockbox looks like a very cool system that is why I keep trying to get it.  If someone would be patient and give me some ideas I would be gratefull! I will be the first to admit I am not the greatest with the p, but I think I know enough to get this done with a little help.

Thanks
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: AlexP on August 28, 2007, 07:31:47 PM
1)  Please do not double, let alone triple, post.  This is in the posting guidelines.

2)  You have waited all of 26 minutes.  Please have some patience.

3)  What error message?  Things like that are quite important.

4)  You should have a .rockbox folder not file in the root of your player.

5)  Try rockbox utility as Llorean suggested.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 07:40:24 PM
I have no idea what to do with Laureens suggestion a little more detail would be helpful.

the errors were..no firmware found three times and nothing on HHD the nest couple times.


Yes I had a folder named .rockbox not a file
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: AlexP on August 28, 2007, 07:43:46 PM

I have no idea what to do with Laureens suggestion a little more detail would be helpful.


Have you read he page he linked?  If so, what on it was unclear?

P.S. It is Llorean
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 07:46:11 PM
yeah sorry I didn't get the name correct.....yeah I got the link then what?  I mean there are all kinds of things mentioned.....thats what I meant about a little more detail...
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: AlexP on August 28, 2007, 07:47:31 PM
Download rockbox utility for windows (I assume) from the link on that page and run it.  Follow the instructions in it.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 07:48:21 PM
ok, thanks will try that....
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 07:52:18 PM
I don't get it...I am not trying to uninstall rockbox...I am trying to get it loaded! I uninstalled it......I want to load it. Guess I will just stick with the original gigabeat software
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: AlexP on August 28, 2007, 07:54:49 PM
1)  Again, please do not double post.

2)  Rockbox utility is both for installing and uninstalling rockbox.


Guess I will just stick with the original gigabeat software


3)  That is probably best.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: dylstar on August 28, 2007, 07:59:31 PM
Thanks for you "help" I won't double post whatever that is...I was telling you what I needed.  I appreciate what you are doing here and it looks like a great system as I have said before..I probally double posted again. I will try that link.
I won't bother you anymore..I will try the link and if it doesn't work..I will be happy with the gigabeat firmware, as you tech's on here have all the patience of a buzard.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: AlexP on August 28, 2007, 08:02:24 PM
Double posting is posting again rather than modifying your previous post if no-one has posted inbetween.

I don't know how patient buzzards are, but I'm guessing you mean not very.  I'm sorry if I came across as testy as I didn't intend to, but you are not being very helpful.

I'm not a mind reader - what link did you try, which link doesn't work?  You need to say EXACTLY what you have done, with any EXACT error messages.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: elborak on August 28, 2007, 09:57:16 PM
dyslar,

Many, many people have installed Rockbox on a Gigabeat following the instructions in the manual. Therefore it is very likely that your problem is pilot error. Therefore it is vital, if you want help, to describe exactly what you did, leaving out no steps or details.

As an example, you say you "extracted it". How? What program did you use to unpack the zip file?

And be patient. You are asking for free help from volunteers. It's poor manners to get so impatient. You originally posted less than 8 hours ago and already have 10 posts trying to help despite the fact that you continue to ignore the posting guidelines you agreed to read when you signed up for the forum. I'd say people are being admirably patient with you.
Title: Re: Followed instuctions and nothing tosh gigabeat f40
Post by: Febs on August 28, 2007, 09:59:05 PM
Dylstar, you haven't provided enough information to allow us to help you. If you want help, be polite, follow the instructions people give and, and provide information to us when we request it. Otherwise, I will close this thread.