Rockbox Technical Forums

Support and General Use => Audio Playback, Database and Playlists => Topic started by: neofix on April 18, 2017, 06:31:33 AM

Title: YP-R0 Dont show names
Post by: neofix on April 18, 2017, 06:31:33 AM
Hi, I do not see the names of the folders and files in the Explorer on the microsd.
How can I solve this problem if the font is cyrilic1251 or utf-8 and the language of Russians
(https://pp.userapi.com/c836120/v836120939/2fbd0/XewQ4CdbgtY.jpg)
(https://pp.userapi.com/c836120/v836120939/2fbd9/dtKNeJGDN_4.jpg)
(https://pp.userapi.com/c836120/v836120939/2fbe2/3bVpL3VDzs0.jpg)
Title: Re: YP-R0 Dont show names
Post by: lebellium on April 18, 2017, 01:37:03 PM
Try my build attached here: http://www.anythingbutipod.com/forum/showpost.php?p=656604&postcount=1212
Title: Re: YP-R0 Dont show names
Post by: neofix on April 18, 2017, 04:55:19 PM
nfx, you do not have permission to access this page. This could be due to one of several reasons:

Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.
Title: Re: YP-R0 Dont show names
Post by: neofix on April 18, 2017, 06:13:19 PM
Try my build attached here: http://www.anythingbutipod.com/forum/showpost.php?p=656604&postcount=1212
I can not download, says there is no access
Title: Re: YP-R0 Dont show names
Post by: skip252 on April 18, 2017, 06:34:33 PM
I see a nfx that has registered at ABi recently. I have given that account registered member status and it is now be able to access the download. If you have any further issues please send me a pm there.
Title: Re: YP-R0 Dont show names
Post by: neofix on April 19, 2017, 05:44:03 AM
Try my build attached here: http://www.anythingbutipod.com/forum/showpost.php?p=656604&postcount=1212
Link to the assembly does not work, the picture opens very small
Title: Re: YP-R0 Dont show names
Post by: cereal_killer on April 19, 2017, 10:56:00 AM
The anythingbutipod website has some technical problems, this might be the reason that the attachment can not be downloaded.
Title: Re: YP-R0 Dont show names
Post by: lebellium on April 19, 2017, 01:37:48 PM
Oh indeed the attachment doesn't work because of the current ABI technical issues

I just reuploaded it there, enjoy! :)
https://drive.google.com/open?id=0B7z2DypmySvnS1p3YmZ0NUFUd0k
Title: Re: YP-R0 Dont show names
Post by: neofix on April 19, 2017, 01:55:12 PM
 lebelliumThank u very match , love u
Title: Re: YP-R0 Dont show names
Post by: lebellium on April 19, 2017, 02:01:44 PM
If you confirm it fixes your issue, I may compile a new build with the unicode fix. The one I uploaded is a bit "old" (20160818) although I can't say by heart if there was any useful and interesting commit for YP-R0 since then.
Title: Re: YP-R0 Dont show names
Post by: neofix on April 19, 2017, 03:05:16 PM
Yes, it helped! And what file is responsible for the encoding? I would just like it to work on new assemblies
Title: Re: YP-R0 Dont show names
Post by: lebellium on April 19, 2017, 03:11:42 PM
Here some detail about the unicode fix:
http://www.anythingbutipod.com/forum/showpost.php?p=655910&postcount=1208

=> https://git.rockbox.org/?p=rockbox.git;a=blob;f=firmware/target/hosted/samsungypr/ypr0/system-ypr0.c;h=2544174252f895a8f3e91bd7ece1f4ffc5eb0630;hb=d6eefbb

So if you want you can modify this file and compile your own build based on the latest commits :)
If you don't know how to, as said in my previous post, I can do it for you.
Title: Re: YP-R0 Dont show names
Post by: neofix on April 19, 2017, 03:44:59 PM
lebelliumYes, it would be great :)
Title: Re: YP-R0 Dont show names
Post by: lebellium on April 20, 2017, 03:54:35 PM
There was an issue with RDS in the latest builds. I reported it yesterday and jhMikeS nicely fixed it immediately https://git.rockbox.org/?p=rockbox.git;a=commit;h=4ffa052

I also noticed that there is some problem with the keymapping (stop playback, power off and softlock). While I'm trying to understand the issue and get it fixed, I think you'd better stick to the build (August 2016) I provided. You may miss some new settings or plugins but at least this build is stable and works properly :)
Title: Re: YP-R0 Dont show names
Post by: neofix on April 20, 2017, 05:57:01 PM
Thanks!
Yes, I noticed problems with locking on the last build  :-\