Rockbox Technical Forums

Support and General Use => User Interface and Voice => Topic started by: kokoko3k on July 25, 2016, 08:53:57 AM

Title: Voice does not work at startup (font related !?)
Post by: kokoko3k on July 25, 2016, 08:53:57 AM
Hi, i'm using the dev build 9e284c1-160526 and this is the first time i try to make the voice to work.
Player is a sansa clip zip if that matters.

First time i tried with the pre-built voice downloaded from the stable release, next i generated my own voices via festival and rockbox-utility.

Both the methods failed in the sense that rockbox is completely mute at startup.

<EDIT>
See my own Reply #2
</EDIT>

My interface is in english and to make the voice work, i've to switch to another language, then back to english, and it says "new language".
From that time on, the voice keep saying things; but after i switch off the player and then back on, i've to switch language again. This happens every time.

Is there something i'm missing here?

Thanks for your attention.
Title: Re: Voice does not work at startup
Post by: kokoko3k on July 25, 2016, 09:18:55 AM
Mmh, resetting settings make the voice to work as expected, i've to do some sort of bisect now :D
Title: Re: Voice does not work at startup
Post by: kokoko3k on July 25, 2016, 11:58:34 AM
Ok, done.
It seems that it works good with the default 08-rockfont.
If i select 08-Namil, the voice still work until i power-cycle the player.
Back on, voice is not functional to make it work again, i select 08-rockfont and poweroff/on the player again.
Other fonts i tested so far:

##-font: voice menu works?
07-fixed: yes
08-rockbox-propfont : no
08-nedore : no
08-fixed : yes
08-namil: no
08-sazanami-mincho : yes
08-shumacher clean: no
08-atadore : no
08-atadore.dfkt : no
09-fixed: yes
09-nedore: no
09-sazanami-mincho : yes
10-nimbus: yes
12-sansation-bold: yes

Weird!
Title: Re: Voice does not work at startup (font related !?)
Post by: Jason Arthur Taylor on January 18, 2017, 11:46:31 PM
kokoko3k, I want to thank you for your post.  I noticed the same problem but had no idea it was fixable via removing the namil font.  Some searches sent me here.  I posted the bug here https://www.rockbox.org/tracker/task/13090 .

I was wanting to download an alternative set of fonts, or to remove the fonts that cause the issue.  So, I went to http://dl.dropbox.com/u/30204410/Rockbox%20as%20an%20Application/Font%20Pack/font-pack.zip , which is a listed url for an alternative set of fonts on the rockbox extras page clickable on all pages under the rockbox.org domain.  However, this url did not work for me. 

I also emailed Hayden Pearce since it is his link.  That was several days ago.  No response.

I can confirm that this font causes this problem, but the question is why.  My wild guess is that if one did a test they would find that the bad fonts are outside of the spec or something.  This might cause perhaps an overflow into memory. 

Here is a workaround: whenever you download the fontpack at http://download.rockbox.org/release/3.13/rockbox-fonts-3.13.zip , copy over the 08-Namil.fnt file with 10-Fixed.fnt file.  (They seem about the same size, which itself supports the above theory.)

You might think that not using the font solves the problem but keep in mind that you can install dozens of themes and some use the bad font(s) in all sorts of ways.

A developer should probably replace the offending fonts in the zip file on the server, but I think we need to confirm which fonts cause the issue.  Perhaps someone else will chime in with their own reports?   Fonts don’t matter much to blind people, who are the best audience to complain about the voice features, so it is a slightly tougher bug to fix than normal, arguably.
Title: Re: Voice does not work at startup (font related !?)
Post by: gevaerts on January 19, 2017, 05:13:54 AM
A developer should probably replace the offending fonts in the zip file on the server, but I think we need to confirm which fonts cause the issue.

First someone has to confirm that your diagnosis is correct. I know you have a receipt to prove that you donated enough for that to be the case, but such things might be misleading.

As it happens, the font in question was added in 2004. That's a *long* time without issues...
Title: Re: Voice does not work at startup (font related !?)
Post by: Astrogoth on December 02, 2017, 09:10:13 PM

My Voice has been acting screwy so I changed the font to 10 Nimbus and shazam it now works fine. Good enough for me to say thank you.
Thank you!