Rockbox Technical Forums

Installation / Removal => Manual Installation => Apple - Installation/Removal => Topic started by: tonibordallo on September 27, 2017, 12:40:02 PM

Title: Installation not happening at all on iPod Classic 6th Gen
Post by: tonibordallo on September 27, 2017, 12:40:02 PM
Hi, everybody.

I'm venting here my frustration while trying to install Rockbox in my iPod 6th Gen

My configuration is:
iPod Classic 6thGen 160Gb (Logic Board number 820-2168-A)
now with iFlash-Quad + Sandisk Ultra MicroSDXC 200Gb
installing Rockbox via Windows 10

I have followed exactly all the steps that this video shows , as long as I have almost the same configuration as him. https://www.youtube.com/watch?v=Sc8WMcGBu8o&t=303s

but still, instead of "installation complete" at the end I only receive:

 "Action required:
  Could not remount the device, try to do it
  manually. If the iPod didn't restart, force
  a reset by pressing SELECT+MENU buttons
  for about 5 seconds. If the problem could
  not be solved then click 'Abort' to cancel."

and on the ipod it is written :

"Rockbox boot loader
Version: 1.0
Battery status ok : 4109mW
Loading Rockbox..
Error!
Can't loack rockbox.ipod:
File not found

Entering USB mode...
Bootloader USB mode"


How to mount this device manually? I haven't found any tutorial on how to do it. Can somebody please help me?
:(

thanks!
Title: Re: Installation not happening at all on iPod Classic 6th Gen
Post by: saratoga on September 27, 2017, 01:00:58 PM
The error message indicates that you've installed the bootloader but no the rockbox firmware. Could you explain the steps you performed so far?
Title: Re: Installation not happening at all on iPod Classic 6th Gen
Post by: Frankenpod on September 27, 2017, 02:47:22 PM
Have you tried doing what it tells you to do?

i.e. forcing a reset by pressing select+menu for 5 seconds or so, at that point where it won't proceed?

That ought to force reboot the ipod, at which point the actual installation of rockbox should happen.

If you've already done that and it didn't work, what did it actually do instead?
Title: Re: Installation not happening at all on iPod Classic 6th Gen
Post by: tonibordallo on September 29, 2017, 11:36:32 AM
Thank you very much for the help and suggestions.
I have already tried many times this cycle "ipod recovery--> fresh Rockbox install -->error --->ipod recovery"

Basically , the steps I take are:

-After a fresh recovery of iPod, I run the RockboxBootloaderInstaller_iPodClassic_v1_0.exe
-There, I select the iPod Partition, then, as device "Apple iPod Classic (6th gen) Unknown" , check all the boxes(if I leave bootloader unchecked, it accuses some illegal operation and it crashes) and then click on "install".
-It requires keeping "select+menu" pressed for 12secs. I do it.   
 
-While it shows the message "Restarting iPod, waiting for remount..." later it comes a Windows pop up saying "You need to format the disk in drive E: before you can use it. Do you want to format it?" 

at the same time, on Rockbox it shows the message "Action required:
  Could not remount the device, try to do it
  manually. If the iPod didn't restart, force
  a reset by pressing SELECT+MENU buttons
  for about 5 seconds. If the problem could
  not be solved then click 'Abort' to cancel." And there is only the Abort button as option .

If I do a reset with "select+menu" for 5 secs, Rockbock keep with the same error message and option to Abort, no changes at all. While it pops um another request to format the disk drive.

:(

If I decide to accept and format it, with exFAT and same Volume Lable as before, "Windows was unable to complete the formatting".
I click in Abort, and I see that in "My Computer", the iPod is shown as "USB Drive (E:)" but with no display of capacity (I guess it is because it got unformatted).
After a new reset, it offers to format, this time I accept and it works.
In Rockbox I click to install again and it shows "Could not find mounted iPod".


:(