Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: natanelho on September 27, 2015, 02:38:13 AM

Title: clip zip isn't working
Post by: natanelho on September 27, 2015, 02:38:13 AM
*please I'm noob so don't except me to know everything
**my english isn't very good, either. so pls be patient...

after a half a year of lying on the shelf, I wanted to use the clip zip and boom- it's not working!
when I power it up it shows "boot 4.0" and not really booting the actual rockbox.

when im trying to to boot OF, it shows me green screen without anything on it.

I have read somewhere on the forum that if I hold "select" button while connecting to usb, it will connect in "failsafe usb mode". I have done it, and when it installed (automatically) the driver for mass storage, it didnt showed up on "computer" (Im using windows 7 x64). then when I checked "device manager->disk drivers" it shows "Rockbox Internal Storage USB Device".

pls help me! I want to re-install the rockbox to work properly!
Title: Re: clip zip isn't working
Post by: zed187 on January 30, 2018, 01:32:11 PM
I have the same issue with a clip zip. In Windows the device is not available. Tested with different shortcuts while connecting etc. The best trick i found which have solved it for some users was "wait for it". I have plugged it in for around 12 hours but nothing happened. Maybe a linux can mount it... i will update my findings here.
Title: Re: clip zip isn't working
Post by: saratoga on January 30, 2018, 02:07:38 PM
What build are you running?
Title: Re: clip zip isn't working
Post by: zed187 on January 30, 2018, 02:41:24 PM
I have bought this player. I think it has never seen rockbox. Iam here cause i have some sansas running with rockbox and i want to rescue this little guy :) What i found yet is the recovery mode with the unbrick method from here http://forums.rockbox.org/index.php/topic,51205.0.html

seems not that easy to get the pcb out of the case. Behind the display its somehow connected...
Title: Re: clip zip isn't working
Post by: saratoga on January 30, 2018, 02:46:36 PM
If you don't have rockbox installed, you don't have the same issue with the rockbox bootloader. You should explain the issue you have.
Title: Re: clip zip isn't working
Post by: zed187 on January 30, 2018, 02:47:47 PM
My clip zip ends up with a green screen. I think the usb mode is off and the file system is bricked
Title: Re: clip zip isn't working
Post by: saratoga on January 30, 2018, 04:40:14 PM
Does the player boot at all? If not then you will not be able to use USB.
Title: Re: clip zip isn't working
Post by: Bilgus on January 31, 2018, 01:10:19 AM
The sansa are usually stuck into the case with some sticky foam around the screen area I imagine the clipzip is the same
If you can get it into "recovery" mode
(I use that term lightly as there is really no recovery about it it just makes
it so you can access the raw drive partition through USB)

We can probably write firmware to the drive

First what you need.. a PC (really LINUX is the way to go here but I have a follow up for windows users)
The files here: http://www.mediafire.com/folder/95g23cbrzz72w/ClipZip
(Ignore the .sansa file in the root in the above link this is for accessing the raw drive on a device already running rockbox)

On Linux
grab the file clipzip4GB_RECOVERY_image32.bin and follow the procedure in the unbrick instructions
!!ONLY FOR LINUX USERS!! (with this method the size of the player doesn't matter)


On Windows
!!THE SIZE OF THE PLAYER ABSOLUTELY MATTERS!!
I only have a 4GB image for you if your player is not 4GB do NOT attempt this

grab the file SansaClipZip 4G_RECOVERY.imgc.7z unzip it with 7Zip

You need to download and run this to use this image
http://hddguru.com/software/HDD-Raw-Copy-Tool/HDDRawCopy1.10Portable.exe

and finally you will connect the player DO NOT FORMAT IT WHEN WINDOWS ASKS!
and run HDDRawCopy1.10Portable.exe and write the whole image to your device
Title: Re: clip zip isn't working
Post by: zed187 on January 31, 2018, 11:38:28 AM
Hey,

today the clip zip showed up the sansa logo. It was connected via USB around 18 hours. Windows says it cant be mounted. After reboot the player it stuck on the green screen again.

@Bilgus
My Clip Zip is a 8GB model. I will give your linux recovery image with the unbrick instructions a try. First i have to remove the case from the display side.. dont want to damage anything so i have to search for a disassembly method.
Title: Re: clip zip isn't working
Post by: Bilgus on January 31, 2018, 06:50:03 PM
Yeah Unfortunately the only way to do it with windows involves copying the whole
image to the drive and being that the image is 4Gb it could do
one of three things: Its hard to say which.. the linux route is safer in this case
although as with all of it not without risk

Do be aware that once you start do not disconnect the player till you have verified the image
this means your best USB cable with the player set somewhere safe and unlikely to be moved etc.

Assuming success the images I provided have the rockbox bootloader already in them Its actually a special version that is able to boot from the sd card and seeing as your player has had issues you might want to use it like that from now on
see: http://forums.rockbox.org/index.php/topic,51844.0.html
Title: Re: clip zip isn't working
Post by: zed187 on February 01, 2018, 01:59:26 AM
Attached you find a screen when the player showed up the sansa logo after hours connected to my pc.
Title: Re: clip zip isn't working
Post by: zed187 on February 05, 2018, 03:29:45 PM
I think somehow i have broken it after unbrick with bridging the two pins. He doesnt show anything now. Its ok i selled 9€ for this broken clip zip, was a try.