Rockbox Technical Forums

Rockbox General => Rockbox General Discussion => Topic started by: CurlySue on September 12, 2017, 06:56:37 PM

Title: FUZE+ . . . how to disable BUTTONS LOCKED - not just supress the notification
Post by: CurlySue on September 12, 2017, 06:56:37 PM
Why?

SETTINGS
I have my RB 3.14 [deb build c6d5cd7] settings as follows . . . General Settings > Startup/Shutdown > Start Screen > Resume Playback

PROBLEM
Every time I go to shutoff the player by depressing the ON/OFF switch, BUTTONS LOCKED >:( activates and "yes" the FUZE+ player does shut down.  However, when I power on again, I get the following ERROR MESSAGE . . . File control file is invalid . . . which also means RESUME PLAYBACK does not work . . as a result, I must go back to the DATABASE and start from scratch selecting the artist, album, track, etc.  WHAT A DRAG!!

I have read the RB Fuze+ manual and I find no option to DISABLE the BUTTONS LOCKED >:( feature.  I do find an option to "Suppresses the notification" but all that does is eliminate the graphic that pops up when the ON/OFF switch is initially depressed.

This BUTTONS LOCKED >:( feature, IMO, should NOT be a DEFAULT setting - it should be an OPTIONAL SETTING.

Does anyone know how to DISABLE the BUTTONS LOCKED >:( feature/option???

Thank you.

CurlySue

P.S.  I do recognize that - as a workaround - I can depress the ON/OFF button once (which activates BUTTONS LOCKED) and then depress AND HOLD the ON/OFF button (which deactivates BUTTONS LOCKED) to shut down the player.  If all FUZE+ owners have to depress the ON/OFF button TWICE every time we go to shut down our players, it is abundantly clear the duty/life cycle (or MTBF) of the ON/OFF switch will likely be HALF of what MTBF would be if we could DISABLE the BUTTONS LOCKED >:( feature/option.  Where MTBF = Mean Time Before Failure . . . Just sayin'
Title: Re: FUZE+ . . . how to disable BUTTONS LOCKED - not just supress the notification
Post by: Bilgus on September 12, 2017, 11:02:55 PM
hmm I can't say I've ever run into that issue of corrupted playlist on the fuze+, you could try enabling autolock and that would remove the immediate screen lock issue you have

Main Menu>Settings>General Settings>System>Advanced Keylock>Settings>Autolock select it and put a + next to it
and possibly
Main Menu>Settings>General Settings>System>Advanced Keylock>Enabled>yes
Title: Re: FUZE+ . . . how to disable BUTTONS LOCKED - not just supress the notification
Post by: CurlySue on September 13, 2017, 02:46:05 AM
THAT WORKS!!!

Thank you, Bilgus!!!

One problem though, now that I put a + next to Autolock, once I am in that sub-directory I cannot get out . . . must shut down. 

Tried setting . . . Advanced Keylock>Enabled>no . . . and then going into Advanced Keylock>Settings - but (again) once I am in I cannot get out . . . must shut down.

While this appears to be a glitch, I am not that worried about it.

I was out taking photos of the moon a couple of hours ago and the automatic transmission in my car has a problem - out of no where, shifting into 4th gear it slips and then a HUGE CLUNK into gear.  As a result, my mind is going to be occupied by car repairs . . . I'm hoping (maybe) if I change the fluid and filter, the problem will go away as fast as it came . . . pretty sure I will try that first since I can buy fluid and a filter for less than $100 . . . and if it doesn't work, then I am going to sell the car for the motor.  But I digress. 

Many thanks for helping me on this Fuze+ issue, Bilgus!!

CurlySue

Title: Re: FUZE+ . . . how to disable BUTTONS LOCKED - not just supress the notification
Post by: Bilgus on September 13, 2017, 11:33:36 AM
you just aren't hitting the right button, its back on the dpad I didn't add cancel to either of those menus
Title: Re: FUZE+ . . . how to disable BUTTONS LOCKED - not just supress the notification
Post by: CurlySue on September 13, 2017, 05:55:38 PM
you just aren't hitting the right button, its back on the dpad I didn't add cancel to either of those menus

You, SIR, are correct.   :)

Took a 4th try and figured out with place to touch on the pad.

Back to the transmission for me.

CurlySue