Rockbox Technical Forums

Support and General Use => Audio Playback, Database and Playlists => Topic started by: bascule on March 17, 2017, 09:25:19 AM

Title: Sansa Clip+ asks to re-initialise database frequently
Post by: bascule on March 17, 2017, 09:25:19 AM
Coming back to Rockbox after a long while (still using every day, but I have not contributed for a while...)

I've started using a Clip+ because my ClipZip finally threw it's hand in  :( . Loaded 3.13 which was fine, then updated to most recent build about a week ago in order to get the battery life improvements introduced since that stable version.

Unfortunately, I have found it quite unstable, especially with respect to the database.

It seems that every time I try and use the database after resuming play, it has forgotten that the database has been initialised and asks to do it again.
Also, I'm finding that any entries in my custom tagnavi that filter on filename do not work at all.

I load database to RAM, use dircache and use Auto-resume.

I want to get a feel for the problem from others, before I investigate it more thoroughly myself.

Is anyone else is experiencing the same?
Title: Re: Sansa Clip+ asks to re-initialise database frequently
Post by: saratoga on March 17, 2017, 09:38:09 AM
You might want to talk to jhmikeS on IRC. He been committing database/dircache/file system work recently, including some stuff this week. He may be able to help you.
Title: Re: Sansa Clip+ asks to re-initialise database frequently
Post by: bascule on March 20, 2017, 04:58:54 AM
Thanks for that, but it looks like it was not a problem with the build.

Yesterday I had a string of *Panic* messages, Undefined Errors and weird WPS glitching to the point where I gave up on it, so this morning, as a last resort, I deleted the nvram.bin file (and subsequently the .playlist_control file because it was invalid) and the player has been absolutely solid since then  ;D

I don't really know what the nvram file contains (I presume some sort of hibernation information to maintain memory state between reboots?), but I'm guessing that it was corrupted.
Title: Re: Sansa Clip+ asks to re-initialise database frequently
Post by: bascule on March 21, 2017, 04:25:45 AM
I spoke too soon  :(

The specific problem with the filtering by filename in the tagnavi was fixed by turning off database 'Load to RAM' and I thought it was OK, but the instability, WPS glitches and errors when resuming playback raised their ugly heads again this morning.

I have reverted to 3.13 for now.

I managed to get the simulator to crash whilst trying to duplicate the filtering issue, so I may investigate further and raise an actual bug report.